Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#893 - LEDE 17.01.2 rpi-3 kmod-usb-net package issues #6461

Closed
openwrt-bot opened this issue Jul 6, 2017 · 2 comments
Closed

FS#893 - LEDE 17.01.2 rpi-3 kmod-usb-net package issues #6461

openwrt-bot opened this issue Jul 6, 2017 · 2 comments
Labels

Comments

@openwrt-bot
Copy link

@openwrt-bot openwrt-bot commented Jul 6, 2017

wschlich:

the kernel for rpi-3 uses CONFIG_USB_USBNET=y, therefore kmod-usb-net is a stub package which does effectively not contain usbnet.ko.

unfortunately, kmod-usb-net.postinst-pkg still tries to insert the module (insert_modules usbnet), which never works.

also, /etc/modules.d/usb-net still contains "usbnet".

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Jul 6, 2017

wschlich:

hrmz, overlooked to choose the correct category (Kernel) and version (17.01.2) :(

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Apr 17, 2018

NeoRaider:

Fixed/workarounded with https://git.openwrt.org/?p=openwrt/openwrt.git;a=commitdiff;h=efb6ca189641aec64ba94f0d6d4e008fb2c1668b

Fix will be in 17.01.5; in the mean time, it can be applied manually in /lib/functions.sh .

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant