Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#1647 - Linksys E3000 soft-bricks after reboot/power-cycle with 18.06-rc1 #6634

Closed
openwrt-bot opened this issue Jul 10, 2018 · 7 comments
Closed
Labels

Comments

@openwrt-bot
Copy link

@openwrt-bot openwrt-bot commented Jul 10, 2018

mamarley:

I recently got my old Linksys E3000 out of storage for a project and flashed 18.06-rc1 on it (initially by sysupgrading from a previous OpenWRT build (I forgot which, sorry)). It initially worked fine, but as soon as I tried to reboot it, it soft-bricked with the power LED flashing quickly and responding to pings with a TTL of 100 on 192.168.1.1. I was able to TFTP 18.06-rc1 again and it successfully flashed and booted, but once again, attempting to reboot it either by power-cycling or a software-commanded reboot caused it to soft-brick. I then tried TFTPing 17.05, which was successful and worked as it should, including reboots. I once again tried upgrading to 18.06-rc1 and the soft-brick happened yet again.

Sadly, one of the wires broke on my serial adapter and I don't have my soldering iron to fix it right now so I can't retrieve the boot messages at the moment.

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Jul 11, 2018

rmilecki:

I've tried two images:

  • openwrt-18.06.0-rc1-brcm47xx-generic-standard-squashfs.trx
  • openwrt-18.06.0-rc1-brcm47xx-mips74k-standard-squashfs.trx

on BCM4706 and BCM47186B0: everything worked as expected.

I don't have E3000 or any device based on BCM4718A1. So we need either a crystal ball or a serial console log to debug/fix this problem.

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Jul 11, 2018

mamarley:

I do have a USB serial converter hooked up to one of my units, but I accidentally dropped it a while back and broke one of the solder joints. I will see if I can make a temporary repair tonight and figure out what is going on.

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Jul 11, 2018

mamarley:

Oh, and another bit of possibly-useful information: Under "Model" in LuCI where it would normally display "Linksys E3000" or something similar, on 18.06 it shows "Unknown".

I also tried a trunk build, but that didn't work at all and the router is no longer accepting images over TFTP, so it looks like I am going to need to put a serial adapter on that one too. :(

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Jul 11, 2018

rmilecki:

If you boot image for the first time, then ssh into it, can you execute:
sh /rom/etc/uci-defaults/09_fix_crc
? What the output of above command?

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Jul 18, 2018

mamarley:

Wait, nevermind, please ignore the closure request. The build actually didn't flash at all and it was still running an old LEDE trunk build.

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Jul 18, 2018

mamarley:

OK, I have some more data now. When I try to execute that command on a freshly-flashed 18.06-rc1, it gives me an error message saying it couldn't find "mtd". I "opkg install"ed it and ran the command again. It succeeded the second time and the router was able to reboot successfully, indicating that the problem is missing packages in the provided image. In addition to "mtd", I also noticed that at least "dropbear" and "dnsmasq" were missing.

I also tried with 18.06-rc2, and with that the e3000 fails to boot even the first time. The serial console output is:

CFE version 1.0.37 for BCM947XX (32bit,SP,LE)
Build Date: Mon Dec 21 13:21:59 CST 2009 (ljh@team2-complier)
Copyright (C) 2000-2008 Broadcom Corporation.

Init Arena
Init Devs.

No DPN
This is a Parallel Flash
Boot partition size = 262144(0x40000)
et0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 5.10.56.51
CPU type 0x19740: 480MHz
Tot mem: 65536 KBytes

CFE mem: 0x80700000 - 0x8079DAC0 (645824)
Data: 0x80732A20 - 0x80737080 (18016)
BSS: 0x80737080 - 0x80737AC0 (2624)
Heap: 0x80737AC0 - 0x8079BAC0 (409600)
Stack: 0x8079BAC0 - 0x8079DAC0 (8192)
Text: 0x80700000 - 0x80732A1C (207388)

Boot version: v4.2
The boot is CFE

mac_init(): Find mac [68:7F:74:1F:5F:BE] in location 0
Nothing...
No country code find
Device eth0: hwaddr 68-7F-74-1F-5F-BE, ipaddr 192.168.1.1, mask 255.255.255.0
gateway not set, nameserver not set
Check CRC of image1
Header CRC: 0x66AD0CC6
Calculate CRC: 0x66AD0CC6
Image 1 is OK
Try to load image 1.
Loader:raw Filesys:tftp Dev:eth0 File:: Options:(null)
Loading: Failed.
Could not load :: Timeout occured
Loader:raw Filesys:raw Dev:flash0.os File: Options:(null)
Loading: .. 3832 bytes read
Entry at 0x80001000
Closing network.
Starting program at 0x80001000

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Jul 21, 2018

rmilecki:

Problem with missing mtd package (and so 09_fix_crc failing) in generic subtarget builds has been fixed by:

  • 69ea512 ("build: do not alter global default package selection from profiles") (master)
  • b84a1c5 ("build: do not alter global default package selection from profiles") (openwrt-18.06)

For the issue with 18.06-rc2 not booting please use a separated report.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant