Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#1566 - dsl2750b ver b1 wifi not working #6683

Closed
openwrt-bot opened this issue May 25, 2018 · 2 comments
Closed

FS#1566 - dsl2750b ver b1 wifi not working #6683

openwrt-bot opened this issue May 25, 2018 · 2 comments
Labels

Comments

@openwrt-bot
Copy link

@openwrt-bot openwrt-bot commented May 25, 2018

qwerty286:

Hi

I have a problem with flashed d-link dsl2750b ver b1, with firmware from model dsl2740b rev F1 (it’s the same hardware but mine have also usb)
Lede
model:D-Link DSL-2740B/DSL-2741B rev F1
Firmware Version: LEDE Reboot 17.01.4 r3560-79f57e422d / LuCI lede-17.01 branch (git-17.290.79498-d3f0685)
kernel: 4.4.92

The main problem is that that i cant turn on wifi, after fresh install i didn’t have wireless visible on gui, also in /etc/config/ wireless file is missing,
on ssh command wifi dont turn on, i think it’s something with kernel and module or system,

lspci:

00:00.0 PCI bridge: Broadcom Limited Device 6328
01:00.0 Ethernet controller: Qualcomm Atheros AR5008 Wireless Network Adapter (rev 01)

lsmod:

root@LEDE:~# lsmod
ath 17360 3 ath9k,ath9k_common,ath9k_hw
ath9k 87344 0
ath9k_common 18512 1 ath9k
ath9k_hw 334288 2 ath9k,ath9k_common
cfg80211 223984 4 ath9k,ath9k_common,ath,mac80211
compat 10384 4 ath9k,ath9k_common,mac80211,cfg80211
crc_ccitt 976 1 ppp_async
gpio_button_hotplug 6224 0
ip_tables 9248 3 iptable_nat,iptable_mangle,iptable_filter
ip6_tables 8992 2 ip6table_mangle,ip6table_filter
ip6t_REJECT 896 2
ip6table_filter 576 1
ip6table_mangle 1024 0
ipt_MASQUERADE 624 1
ipt_REJECT 864 2
iptable_filter 640 1
iptable_mangle 848 0
iptable_nat 704 1
mac80211 398800 1 ath9k
nf_conntrack 51264 9 nf_nat_ipv4,nf_conntrack_ipv6,nf_conntrack_ipv4,xt_state,xt_conntrack,xt_CT,nf_nat_masquerade_ipv4,nf_nat,nf_conntrack_rtcache
nf_conntrack_ipv4 5328 9
nf_conntrack_ipv6 5888 4
nf_conntrack_rtcache 2464 0
nf_defrag_ipv4 864 1 nf_conntrack_ipv4
nf_defrag_ipv6 9120 1 nf_conntrack_ipv6
nf_log_common 2384 2 nf_log_ipv4,nf_log_ipv6
nf_log_ipv4 3152 0
nf_log_ipv6 3312 0
nf_nat 9952 4 nf_nat_ipv4,xt_nat,nf_nat_redirect,nf_nat_masquerade_ipv4
nf_nat_ipv4 4112 1 iptable_nat
nf_nat_masquerade_ipv4 1232 1 ipt_MASQUERADE
nf_nat_redirect 880 1 xt_REDIRECT
nf_reject_ipv4 2000 1 ipt_REJECT
nf_reject_ipv6 2416 1 ip6t_REJECT
ppp_async 6352 0
ppp_generic 19984 3 pppoe,ppp_async,pppox
pppoe 7840 0
pppox 1184 1 pppoe
slhc 4144 1 ppp_generic
x_tables 10560 23 ipt_REJECT,ipt_MASQUERADE,xt_time,xt_tcpudp,xt_state,xt_nat,xt_multiport,xt_mark,xt_mac,xt_limit,xt_conntrack,xt_comment,xt_TCPMSS,xt_REDIRECT,xt_LOG,xt_CT,iptable_mangle,iptable_filter,ip_tables,ip6t_REJECT,ip6table_mangle,ip6table_filter,ip6_tables
xt_CT 2480 0
xt_LOG 720 0
xt_REDIRECT 624 0
xt_TCPMSS 2720 0
xt_comment 448107
xt_conntrack 2208 12
xt_limit 976 20
xt_mac 592 0
xt_mark 624 0
xt_multiport 1168 0
xt_nat 1104 0
xt_state 672 0
xt_tcpudp 1696 8
xt_time 1584 0

dmesg:

[ 0.000000] Linux version 4.4.92 (buildbot@debian8) (gcc version 5.4.0 (LEDE GCC 5.4.0 r3560-79f57e4) ) #0 Tue Oct 17 17:46:20 2017
[ 0.000000] Detected Broadcom 0×6328 CPU revision b0
[ 0.000000] CPU frequency is 320 MHz [ 0.000000] 64MB of RAM installed
[ 0.000000] board_bcm963xx: Boot address 0xb8000000
[ 0.000000] board_bcm963xx: CFE version: 1.0.37-106.5
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU0 revision is: 0002a075 (Broadcom BMIPS4350)
[ 0.000000] board: board name: AW4339U
[ 0.000000] MIPS: machine is D-Link DSL-2740B/DSL-2741B rev F1
[ 0.000000] Determined physical RAM map:
[ 0.000000] memory: 04000000 @ 00000000 (usable)
[ 0.000000] Initrd not found or empty - disabling initrd
[ 0.000000] Zone ranges:
[ 0.000000] Normal [mem 0×0000000000000000-0x0000000003ffffff]
[ 0.000000] Movable zone start for each node
[ 0.000000] Early memory node ranges
[ 0.000000] node 0: [mem 0×0000000000000000-0x0000000003ffffff]
[ 0.000000] Initmem setup node 0 [mem 0×0000000000000000-0x0000000003ffffff]
[ 0.000000] On node 0 totalpages: 16384
[ 0.000000] free_area_init_node: node 0, pgdat 803a4530, node_mem_map 81002700
[ 0.000000] Normal zone: 128 pages used for memmap
[ 0.000000] Normal zone: 0 pages reserved
[ 0.000000] Normal zone: 16384 pages, LIFO batch:3
[ 0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 16 bytes.
[ 0.000000] Primary data cache 32kB, 2-way, VIPT, cache aliases, linesize 16 bytes
[ 0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=132768
[ 0.000000] pcpu-alloc: [0] 0
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 16256
[ 0.000000] Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200
[ 0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[ 0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[ 0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[ 0.000000] Memory: 59584K/65536K available (3126K kernel code, 150K rwdata, 504K rodata, 1268K init, 198K bss, 5952K reserved, 0K cma-reserved)
[ 0.000000] SLUB: HWalign=16, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] NR_IRQS:256
[ 0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 11945377789 ns
[ 0.000018] sched_clock: 32 bits at 160MHz, resolution 6ns, wraps every 13421772796ns
[ 0.008096] Calibrating delay loop... 319.74 BogoMIPS (lpj=639488)
[ 0.046765] pid_max: default: 32768 minimum: 301
[ 0.051824] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.058625] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.073125] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 7645041785100000 ns
[ 0.083207] futex hash table entries: 256 (order: -1, 3072 bytes)
[ 0.092313] NET: Registered protocol family 16
[ 0.104731] Can’t analyze schedule() prologue at 80016d88
[ 0.347288] registering PCI controller with io_map_base unset
[ 0.371902] PCI host bridge to bus 0000:00
[ 0.376164] pci_bus 0000:00: root bus resource [mem 0x10f00000-0x10ffffff]
[ 0.383229] pci_bus 0000:00: root bus resource [??? 0×00000000 flags 0×0]
[ 0.390214] pci_bus 0000:00: root bus resource [??? 0×00000000 flags 0×0]
[ 0.397201] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[ 0.405413] pci 0000:00:00.0: [14e4:6328] type 01 class 0×060400 [ 0.405558] pci 0000:00:00.0: PME# supported from D0 D3hot
[ 0.406043] pci 0000:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[ 0.414662] pci 0000:01:00.0: [168c:ff1c] type 00 class 0×020000 [ 0.414779] pci 0000:01:00.0: reg 0×10: [mem 0×00000000-0x0000ffff 64bit]
[ 0.414964] pci 0000:01:00.0: supports D1
[ 0.414996] pci 0000:01:00.0: PME# supported from D0 D1 D3hot
[ 0.415420] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[ 0.415474] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 01
[ 0.415552] pci 0000:00:00.0: BAR 8: assigned [mem 0x10f00000-0x10ffffff]
[ 0.422591] pci 0000:01:00.0: BAR 0: assigned [mem 0x10f00000-0x10f0ffff 64bit]
[ 0.430126] pci 0000:00:00.0: PCI bridge to [bus 01]
[ 0.435222] pci 0000:00:00.0: bridge window [mem 0x10f00000-0x10ffffff]
[ 0.443688] clocksource: Switched to clocksource MIPS
[ 0.451901] NET: Registered protocol family 2
[ 0.458471] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.465766] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.472365] TCP: Hash tables configured (established 1024 bind 1024)
[ 0.479362] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.485473] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.492461] NET: Registered protocol family 1
[ 0.497060] pci 0000:01:00.0: invalid calibration data
[ 0.502356] PCI: CLS 0 bytes, default 16
[ 0.514069] Crashlog allocated RAM at address 0x3f00000
[ 0.555461] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 0.561494] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) © 2001-2006 Red Hat, Inc.
[ 0.578157] io scheduler noop registered
[ 0.582220] io scheduler deadline registered (default)
[ 0.588721] PCI: Enabling device 0000:00:00.0 (0000 → 0002)
[ 0.595444] bcm63xx_uart.0: ttyS0 at MMIO 0xb0000100 (irq = 36, base_baud = 1562500) is a bcm63xx_uart
[ 0.605101] console [ttyS0] enabled
[ 0.612253] bootconsole [early0] disabled
[ 0.630928] m25p80 spi1.0: found mx25l6405d, expected m25p80
[ 0.637044] m25p80 spi1.0: mx25l6405d (8192 Kbytes)
[ 0.642458] bcm63xxpart: CFE boot tag found with version 6 and board type AW4339U
[ 0.650263] bcm63xxpart: Partition 0 is CFE offset 0 and length 10000
[ 0.656915] bcm63xxpart: Partition 1 is kernel offset 10100 and length 136d38
[ 0.664236] bcm63xxpart: Partition 2 is rootfs offset 146e38 and length 6891c8
[ 0.671670] bcm63xxpart: Partition 3 is cal_data offset 7d0000 and length 10000
[ 0.679191] bcm63xxpart: Partition 4 is nvram offset 7e0000 and length 20000
[ 0.686453] bcm63xxpart: Partition 5 is linux offset 10000 and length 7c0000
[ 0.693708] 6 bcm63xxpart partitions found on MTD device spi1.0
[ 0.699799] Creating 6 MTD partitions on “spi1.0”:
[ 0.704743] 0×000000000000-0×000000010000 : “CFE” [ 0.712717] 0×000000010100-0x000000146e38 : “kernel” [ 0.721462] 0x000000146e38-0x0000007d0000 : “rootfs” [ 0.730140] mtd: device 2 (rootfs) set to be root filesystem
[ 0.736885] 1 squashfs-split partitions found on MTD device rootfs
[ 0.743287] 0×000000370000-0x0000007d0000 : “rootfs_data” [ 0.751671] 0x0000007d0000-0x0000007e0000 : “cal_data” [ 0.760627] 0x0000007e0000-0×000000800000 : “nvram” [ 0.769381] 0×000000010000-0x0000007d0000 : “linux” [ 0.817026] b53_common: found switch: BCM63xx, rev 0
[ 0.822650] bcm63xx-wdt bcm63xx-wdt: started, timer margin: 30 sec
[ 0.833980] NET: Registered protocol family 10
[ 0.848821] NET: Registered protocol family 17
[ 0.853561] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[ 0.866563] 8021q: 802.1Q VLAN Support v1.8
[ 0.880618] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[ 0.905004] Freeing unused kernel memory: 1268K
[ 2.624127] init: Console is alive
[ 2.627995] init: - watchdog -
[ 4.064552] kmodloader: loading kernel modules from /etc/modules-boot.d/

[ 4.214254] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[ 4.232321] init: - preinit -
[ 5.149129] random: jshn: uninitialized urandom read (4 bytes read, 108 bits of entropy available)
[ 5.241034] random: jshn: uninitialized urandom read (4 bytes read, 108 bits of entropy available)
[ 5.466573] random: jshn: uninitialized urandom read (4 bytes read, 109 bits of entropy available)
[ 5.558732] random: jshn: uninitialized urandom read (4 bytes read, 109 bits of entropy available)
[ 5.677661] random: jshn: uninitialized urandom read (4 bytes read, 110 bits of entropy available)
[ 6.503993] bcm63xx_enetsw bcm63xx_enetsw.0: link UP on Port 4, 100Mbps, full-duplex
[ 6.643598] random: procd: uninitialized urandom read (4 bytes read, 118 bits of entropy available)
[ 9.203749] random: nonblocking pool is initialized
[ 10.113267] jffs2: notice: (334) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[ 10.134810] mount_root: switching to jffs2 overlay
[ 10.159183] urandom-seed: Seeding with /etc/urandom.seed
[ 10.385596] procd: - early -
[ 10.388836] procd: - watchdog -
[ 11.121061] procd: - watchdog -
[ 11.124797] procd: - ubus -
[ 11.279538] procd: - init -
[ 12.080117] kmodloader: loading kernel modules from /etc/modules.d/*
[ 12.096705] ip6_tables: (C) 2000-2006 Netfilter Core Team
[ 12.125694] Loading modules backported from Linux version wt-2017-01-31-0-ge882dff19e7f
[ 12.133999] Backport generated by backports.git backports-20160324-13-g24da7d3c
[ 12.147648] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 12.171590] nf_conntrack version 0.5.0 (950 buckets, 3800 max)
[ 12.244961] xt_time: kernel timezone is -0000
[ 12.383931] PPP generic driver version 2.4.2
[ 12.393543] NET: Registered protocol family 24
[ 12.592551] kmodloader: done loading kernel modules from /etc/modules.d/*
[ 24.500449] bcm63xx_enetsw bcm63xx_enetsw.0: link UP on Port 4, 100Mbps, full-duplex
[ 24.627258] device eth0.1 entered promiscuous mode
[ 24.632224] device eth0 entered promiscuous mode
[ 24.640667] br-lan: port 1(eth0.1) entered forwarding state
[ 24.646497] br-lan: port 1(eth0.1) entered forwarding state
[ 26.647764] br-lan: port 1(eth0.1) entered forwarding state

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Jul 24, 2018

war3333:

Here to say that i have the exact same problem on a DSL-2740B F1

00:00.0 PCI bridge: Broadcom Limited Device 6328
01:00.0 Ethernet controller: Qualcomm Atheros AR5008 Wireless Network Adapter (rev 01)

ath 17408 3 ath9k,ath9k_common,ath9k_hw
ath9k 88272 0
ath9k_common 18560 1 ath9k
ath9k_hw 334416 2 ath9k,ath9k_common
cfg80211 225360 4 ath9k,ath9k_common,mac80211,ath
compat 10960 4 ath9k,ath9k_common,mac80211,cfg80211
crc_ccitt 976 1 ppp_async
gpio_button_hotplug 6208 0
ip_tables 10576 3 iptable_nat,iptable_mangle,iptable_filter
ip6_tables 10272 2 ip6table_mangle,ip6table_filter
ip6t_REJECT 896 2
ip6table_filter 576 1
ip6table_mangle 1024 0
ipt_MASQUERADE 624 1
ipt_REJECT 864 2
iptable_filter 640 1
iptable_mangle 848 0
iptable_nat 704 1
mac80211 401168 1 ath9k
nf_conntrack 57520 9 nf_nat_ipv4,nf_conntrack_ipv6,nf_conntrack_ipv4,xt_state,xt_conntrack,xt_CT,nf_nat_masquerade_ipv4,nf_nat,nf_conntrack_rtcache
nf_conntrack_ipv4 5392 9
nf_conntrack_ipv6 5984 4
nf_conntrack_rtcache 2560 0
nf_defrag_ipv4 864 1 nf_conntrack_ipv4
nf_defrag_ipv6 13216 1 nf_conntrack_ipv6
nf_log_common 2400 2 nf_log_ipv4,nf_log_ipv6
nf_log_ipv4 3152 0
nf_log_ipv6 3312 0
nf_nat 10096 4 nf_nat_ipv4,xt_nat,nf_nat_redirect,nf_nat_masquerade_ipv4
nf_nat_ipv4 4112 1 iptable_nat
nf_nat_masquerade_ipv4 1232 1 ipt_MASQUERADE
nf_nat_redirect 880 1 xt_REDIRECT
nf_reject_ipv4 2032 1 ipt_REJECT
nf_reject_ipv6 2448 1 ip6t_REJECT
ppp_async 6512 0
ppp_generic 20240 3 pppoe,ppp_async,pppox
pppoe 8176 0
pppox 1184 1 pppoe
slhc 4176 1 ppp_generic
x_tables 11568 23 ipt_REJECT,ipt_MASQUERADE,xt_time,xt_tcpudp,xt_state,xt_nat,xt_multiport,xt_mark,xt_mac,xt_limit,xt_conntrack,xt_comment,xt_TCPMSS,xt_REDIRECT,xt_LOG,xt_CT,iptable_mangle,iptable_filter,ip_tables,ip6t_REJECT,ip6table_mangle,ip6table_filter,ip6_tables
xt_CT 2624 0
xt_LOG 720 0
xt_REDIRECT 624 0
xt_TCPMSS 2720 0
xt_comment 448107
xt_conntrack 2208 12
xt_limit 1008 20
xt_mac 592 0
xt_mark 624 0
xt_multiport 1168 0
xt_nat 1104 0
xt_state 672 0
xt_tcpudp 1696 8
xt_time 1584 0

wifi config doesn't create any wireless config.
This on Lede Reboot (17.01.5, r3919-38e704be71) on 18.06.01 Beta 2 and on trunk

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Dec 16, 2020

acoul:

FWIW, you may try enabling the owl-loader. see bug [[https://bugs.openwrt.org/index.php?do=details&task_id=3489|#3489]] for more detailes

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant