Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#2682 - TP-Link Archer C7 v2 / 19.07.0-rc2 / 5GHz erratic #7529

Closed
openwrt-bot opened this issue Dec 18, 2019 · 2 comments
Closed

FS#2682 - TP-Link Archer C7 v2 / 19.07.0-rc2 / 5GHz erratic #7529

openwrt-bot opened this issue Dec 18, 2019 · 2 comments
Labels

Comments

@openwrt-bot
Copy link

@openwrt-bot openwrt-bot commented Dec 18, 2019

systemcrash:

Supply the following if possible:

  • Device problem occurs on
  • Software versions of OpenWrt/LEDE release, packages, etc.
  • Steps to reproduce

Dev: TP-Link Archer C7 v2
File: openwrt-19.07.0-rc2-ath79-generic-tplink_archer-c7-v2-squashfs-sysupgrade.bin
OpenWrt 19.07.0-rc2 r10775-db8345d8e4 / LuCI openwrt-19.07 branch git-19.334.63023-039ef1f

Report details also here:

https://forum.openwrt.org/t/openwrt-19-07-0-second-release-candidate/49593/48?u=systemcrash

===

Kernel log prints the following with factory installed ath10k-firmware-qca988x-ct:

[ 13.086218] ath10k 4.19 driver, optimized for CT firmware, probing pci device: 0x3c.
[ 13.095400] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
[ 13.101323] ath10k_pci 0000:00:00.0: pci irq legacy oper_irq_mode 1 irq_mode 0 reset_mode 0
[ 13.377901] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/fwcfg-pci-0000:00:00.0.txt failed with error -2
[ 13.388608] ath10k_pci 0000:00:00.0: Falling back to user helper
[ 13.482138] firmware ath10k!fwcfg-pci-0000:00:00.0.txt: firmware_loading_store: map pages failed
[ 13.491335] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:00:00.0.bin failed with error -2
[ 13.502212] ath10k_pci 0000:00:00.0: Falling back to user helper
[ 13.685319] firmware ath10k!pre-cal-pci-0000:00:00.0.bin: firmware_loading_store: map pages failed
[ 13.697084] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/ct-firmware-5.bin failed with error -2
[ 13.708238] ath10k_pci 0000:00:00.0: Falling back to user helper
[ 13.892125] firmware ath10k!QCA988X!hw2.0!ct-firmware-5.bin: firmware_loading_store: map pages failed
[ 13.901743] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/ct-firmware-2.bin failed with error -2
[ 13.912891] ath10k_pci 0000:00:00.0: Falling back to user helper
[ 14.096256] firmware ath10k!QCA988X!hw2.0!ct-firmware-2.bin: firmware_loading_store: map pages failed
[ 14.105887] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-6.bin failed with error -2
[ 14.116769] ath10k_pci 0000:00:00.0: Falling back to user helper
[ 14.299239] firmware ath10k!QCA988X!hw2.0!firmware-6.bin: firmware_loading_store: map pages failed
[ 14.308602] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-5.bin failed with error -2
[ 14.319477] ath10k_pci 0000:00:00.0: Falling back to user helper
[ 14.501747] firmware ath10k!QCA988X!hw2.0!firmware-5.bin: firmware_loading_store: map pages failed
[ 14.511104] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-4.bin failed with error -2
[ 14.521982] ath10k_pci 0000:00:00.0: Falling back to user helper
[ 14.705019] firmware ath10k!QCA988X!hw2.0!firmware-4.bin: firmware_loading_store: map pages failed
[ 14.714378] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-3.bin failed with error -2
[ 14.725254] ath10k_pci 0000:00:00.0: Falling back to user helper
[ 14.909602] firmware ath10k!QCA988X!hw2.0!firmware-3.bin: firmware_loading_store: map pages failed
[ 14.940268] ath10k_pci 0000:00:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000
[ 14.949669] ath10k_pci 0000:00:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0
[ 14.962074] ath10k_pci 0000:00:00.0: firmware ver 10.1-ct-8x-__fW-022-64cc8007 api 2 features wmi-10.x,has-wmi-mgmt-tx,mfp,txstatus-noack,wmi-10.x-CT,ratemask-CT,txrate-CT,get-temp-CT,tx-rc-CT,cust-stats-CT,retry-gt2-CT,txrate2-CT,beacon-cb-CT,wmi-block-ack-CT crc32 156478f0
[ 15.084602] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/board-2.bin failed with error -2
[ 15.095220] ath10k_pci 0000:00:00.0: Falling back to user helper
[ 15.201357] firmware ath10k!QCA988X!hw2.0!board-2.bin: firmware_loading_store: map pages failed
[ 15.210608] ath10k_pci 0000:00:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
[ 16.153935] ath10k_pci 0000:00:00.0: 10.1 wmi init: vdevs: 16 peers: 127 tid: 256
[ 16.170710] ath10k_pci 0000:00:00.0: wmi print 'P 128 V 8 T 410'
[ 16.177043] ath10k_pci 0000:00:00.0: wmi print 'msdu-desc: 1424 sw-crypt: 0 ct-sta: 0'
[ 16.185190] ath10k_pci 0000:00:00.0: wmi print 'alloc rem: 20904 iram: 26072'
[ 16.235030] ath10k_pci 0000:00:00.0: htt-ver 2.1 wmi-op 2 htt-op 2 cal file max-sta 128 raw 0 hwcrypto 1
[ 16.247941] ath10k_pci 0000:00:00.0: NOTE: Firmware DBGLOG output disabled in debug_mask: 0x10000000

5GHz throughput fine, but ping shabby/erratic:

64 bytes from 192.168.19.1: icmp_seq=0 ttl=64 time=84.622 ms
64 bytes from 192.168.19.1: icmp_seq=1 ttl=64 time=132.775 ms
64 bytes from 192.168.19.1: icmp_seq=2 ttl=64 time=126.104 ms
64 bytes from 192.168.19.1: icmp_seq=3 ttl=64 time=161.075 ms
64 bytes from 192.168.19.1: icmp_seq=4 ttl=64 time=152.727 ms
64 bytes from 192.168.19.1: icmp_seq=5 ttl=64 time=88.039 ms
64 bytes from 192.168.19.1: icmp_seq=6 ttl=64 time=244.452 ms
64 bytes from 192.168.19.1: icmp_seq=7 ttl=64 time=160.907 ms
64 bytes from 192.168.19.1: icmp_seq=8 ttl=64 time=93.757 ms
64 bytes from 192.168.19.1: icmp_seq=9 ttl=64 time=52.239 ms
64 bytes from 192.168.19.1: icmp_seq=10 ttl=64 time=42.693 ms
64 bytes from 192.168.19.1: icmp_seq=11 ttl=64 time=129.177 ms
64 bytes from 192.168.19.1: icmp_seq=12 ttl=64 time=9.369 ms
64 bytes from 192.168.19.1: icmp_seq=13 ttl=64 time=102.590 ms
64 bytes from 192.168.19.1: icmp_seq=14 ttl=64 time=1.520 ms
64 bytes from 192.168.19.1: icmp_seq=15 ttl=64 time=191.061 ms
64 bytes from 192.168.19.1: icmp_seq=16 ttl=64 time=9.951 ms
64 bytes from 192.168.19.1: icmp_seq=17 ttl=64 time=7.680 ms
64 bytes from 192.168.19.1: icmp_seq=18 ttl=64 time=122.895 ms
64 bytes from 192.168.19.1: icmp_seq=19 ttl=64 time=29.572 ms
64 bytes from 192.168.19.1: icmp_seq=20 ttl=64 time=53.503 ms
64 bytes from 192.168.19.1: icmp_seq=21 ttl=64 time=36.006 ms
64 bytes from 192.168.19.1: icmp_seq=22 ttl=64 time=188.858 ms
64 bytes from 192.168.19.1: icmp_seq=23 ttl=64 time=62.573 ms
64 bytes from 192.168.19.1: icmp_seq=24 ttl=64 time=7.543 ms
64 bytes from 192.168.19.1: icmp_seq=25 ttl=64 time=152.713 ms
64 bytes from 192.168.19.1: icmp_seq=26 ttl=64 time=25.517 ms

For ref - 2.4GHz ping:

64 bytes from 192.168.19.1: icmp_seq=219 ttl=64 time=1.332 ms
64 bytes from 192.168.19.1: icmp_seq=220 ttl=64 time=1.625 ms
64 bytes from 192.168.19.1: icmp_seq=221 ttl=64 time=1.111 ms
64 bytes from 192.168.19.1: icmp_seq=222 ttl=64 time=1.558 ms
64 bytes from 192.168.19.1: icmp_seq=223 ttl=64 time=1.404 ms
64 bytes from 192.168.19.1: icmp_seq=224 ttl=64 time=1.596 ms
64 bytes from 192.168.19.1: icmp_seq=225 ttl=64 time=7.978 ms
64 bytes from 192.168.19.1: icmp_seq=226 ttl=64 time=7.733 ms
64 bytes from 192.168.19.1: icmp_seq=227 ttl=64 time=1.517 ms
64 bytes from 192.168.19.1: icmp_seq=228 ttl=64 time=9.955 ms
64 bytes from 192.168.19.1: icmp_seq=229 ttl=64 time=34.035 ms
64 bytes from 192.168.19.1: icmp_seq=230 ttl=64 time=1.359 ms
64 bytes from 192.168.19.1: icmp_seq=231 ttl=64 time=1.509 ms

Tried the above advice and removed ath10k-firmware-qca988x-ct and installed ath10k-firmware-qca988x - same results.

Kernel log looked like this:

[ 13.881135] ath10k_pci 0000:00:00.0: pci irq legacy oper_irq_mode 1 irq_mode 0 reset_mode 0
[ 14.158416] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:00:00.0.bin failed with error -2
[ 14.169302] ath10k_pci 0000:00:00.0: Falling back to user helper
[ 14.271542] firmware ath10k!pre-cal-pci-0000:00:00.0.bin: firmware_loading_store: map pages failed
[ 14.286560] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-6.bin failed with error -2
[ 14.297460] ath10k_pci 0000:00:00.0: Falling back to user helper
[ 14.479744] firmware ath10k!QCA988X!hw2.0!firmware-6.bin: firmware_loading_store: map pages failed
[ 14.995308] ath10k_pci 0000:00:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000
[ 15.004692] ath10k_pci 0000:00:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 1
[ 15.017752] ath10k_pci 0000:00:00.0: firmware ver 10.2.4-1.0-00047 api 5 features no-p2p,raw-mode,mfp,allows-mesh-bcast crc32 35bd9258
[ 15.062794] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/board-2.bin failed with error -2
[ 15.073408] ath10k_pci 0000:00:00.0: Falling back to user helper
[ 15.167769] firmware ath10k!QCA988X!hw2.0!board-2.bin: firmware_loading_store: map pages failed
[ 15.178498] ath10k_pci 0000:00:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
[ 16.301698] ath10k_pci 0000:00:00.0: htt-ver 2.1 wmi-op 5 htt-op 2 cal file max-sta 128 raw 0 hwcrypto 1

With ping:

64 bytes from 192.168.19.1: icmp_seq=0 ttl=64 time=33.290 ms
64 bytes from 192.168.19.1: icmp_seq=1 ttl=64 time=56.834 ms
64 bytes from 192.168.19.1: icmp_seq=2 ttl=64 time=1.313 ms
64 bytes from 192.168.19.1: icmp_seq=3 ttl=64 time=232.480 ms
64 bytes from 192.168.19.1: icmp_seq=4 ttl=64 time=219.849 ms
64 bytes from 192.168.19.1: icmp_seq=5 ttl=64 time=98.685 ms
64 bytes from 192.168.19.1: icmp_seq=6 ttl=64 time=120.222 ms
64 bytes from 192.168.19.1: icmp_seq=7 ttl=64 time=236.720 ms
64 bytes from 192.168.19.1: icmp_seq=8 ttl=64 time=242.812 ms
64 bytes from 192.168.19.1: icmp_seq=9 ttl=64 time=169.742 ms
64 bytes from 192.168.19.1: icmp_seq=10 ttl=64 time=262.349 ms
64 bytes from 192.168.19.1: icmp_seq=11 ttl=64 time=196.983 ms
64 bytes from 192.168.19.1: icmp_seq=12 ttl=64 time=118.585 ms
64 bytes from 192.168.19.1: icmp_seq=13 ttl=64 time=1.449 ms
64 bytes from 192.168.19.1: icmp_seq=14 ttl=64 time=13.646 ms
64 bytes from 192.168.19.1: icmp_seq=15 ttl=64 time=308.754 ms
64 bytes from 192.168.19.1: icmp_seq=16 ttl=64 time=189.855 ms
64 bytes from 192.168.19.1: icmp_seq=17 ttl=64 time=721.944 ms
64 bytes from 192.168.19.1: icmp_seq=18 ttl=64 time=539.833 ms
64 bytes from 192.168.19.1: icmp_seq=19 ttl=64 time=932.816 ms
64 bytes from 192.168.19.1: icmp_seq=20 ttl=64 time=283.675 ms
64 bytes from 192.168.19.1: icmp_seq=21 ttl=64 time=113.168 ms
64 bytes from 192.168.19.1: icmp_seq=22 ttl=64 time=276.538 ms
64 bytes from 192.168.19.1: icmp_seq=23 ttl=64 time=213.385 ms
64 bytes from 192.168.19.1: icmp_seq=24 ttl=64 time=20.263 ms

Tried with ath10k-firmware-qca988x-ct-htt variant also:

64 bytes from 192.168.19.1: icmp_seq=0 ttl=64 time=36.010 ms
64 bytes from 192.168.19.1: icmp_seq=1 ttl=64 time=20.136 ms
64 bytes from 192.168.19.1: icmp_seq=2 ttl=64 time=77.301 ms
64 bytes from 192.168.19.1: icmp_seq=3 ttl=64 time=1.603 ms
64 bytes from 192.168.19.1: icmp_seq=4 ttl=64 time=1.263 ms
64 bytes from 192.168.19.1: icmp_seq=5 ttl=64 time=241.632 ms
64 bytes from 192.168.19.1: icmp_seq=6 ttl=64 time=55.359 ms
64 bytes from 192.168.19.1: icmp_seq=7 ttl=64 time=17.019 ms
64 bytes from 192.168.19.1: icmp_seq=8 ttl=64 time=442.122 ms
64 bytes from 192.168.19.1: icmp_seq=9 ttl=64 time=242.875 ms
64 bytes from 192.168.19.1: icmp_seq=10 ttl=64 time=77.195 ms
64 bytes from 192.168.19.1: icmp_seq=11 ttl=64 time=383.413 ms
64 bytes from 192.168.19.1: icmp_seq=12 ttl=64 time=198.462 ms
64 bytes from 192.168.19.1: icmp_seq=13 ttl=64 time=609.896 ms
64 bytes from 192.168.19.1: icmp_seq=14 ttl=64 time=189.793 ms
Request timeout for icmp_seq 15
64 bytes from 192.168.19.1: icmp_seq=15 ttl=64 time=1690.473 ms
64 bytes from 192.168.19.1: icmp_seq=16 ttl=64 time=872.054 ms
64 bytes from 192.168.19.1: icmp_seq=17 ttl=64 time=178.592 ms
64 bytes from 192.168.19.1: icmp_seq=18 ttl=64 time=143.039 ms
64 bytes from 192.168.19.1: icmp_seq=19 ttl=64 time=235.958 ms
64 bytes from 192.168.19.1: icmp_seq=20 ttl=64 time=72.661 ms
64 bytes from 192.168.19.1: icmp_seq=21 ttl=64 time=203.631 ms

PS - DISMISS button for opkg update in the GUI is horse-shit. Waste of my clicks. Plz at least give auto-dismiss.

Edit: ping on 5GHz is a TON better when something is using/saturating the 5GHz link, e.g. TimeMachine backup is ongoing then boom. Stable:

64 bytes from 192.168.19.1: icmp_seq=1 ttl=64 time=74.032 ms
64 bytes from 192.168.19.1: icmp_seq=2 ttl=64 time=1.397 ms
64 bytes from 192.168.19.1: icmp_seq=3 ttl=64 time=1.281 ms
64 bytes from 192.168.19.1: icmp_seq=4 ttl=64 time=1.322 ms
64 bytes from 192.168.19.1: icmp_seq=5 ttl=64 time=4.756 ms
64 bytes from 192.168.19.1: icmp_seq=6 ttl=64 time=1.339 ms
64 bytes from 192.168.19.1: icmp_seq=7 ttl=64 time=1.309 ms
64 bytes from 192.168.19.1: icmp_seq=8 ttl=64 time=5.388 ms
64 bytes from 192.168.19.1: icmp_seq=9 ttl=64 time=1.497 ms
64 bytes from 192.168.19.1: icmp_seq=10 ttl=64 time=1.116 ms
64 bytes from 192.168.19.1: icmp_seq=11 ttl=64 time=7.326 ms
64 bytes from 192.168.19.1: icmp_seq=12 ttl=64 time=3.464 ms
64 bytes from 192.168.19.1: icmp_seq=13 ttl=64 time=2.244 ms
64 bytes from 192.168.19.1: icmp_seq=14 ttl=64 time=1.118 ms
64 bytes from 192.168.19.1: icmp_seq=15 ttl=64 time=1.496 ms
64 bytes from 192.168.19.1: icmp_seq=16 ttl=64 time=2.007 ms
64 bytes from 192.168.19.1: icmp_seq=17 ttl=64 time=1.472 ms
64 bytes from 192.168.19.1: icmp_seq=18 ttl=64 time=117.913 ms

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Jan 4, 2020

muddyfeet:

See also FS#2563 - Similar issues on 5GHz on the same device.

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Feb 6, 2020

systemcrash:

Quite probably resolved by FS#2679

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant