Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#2864 - New trunks (atleast 12297 and 12320) overwrite ART mtd partition on ar71xx #7673

Closed
openwrt-bot opened this issue Feb 27, 2020 · 4 comments
Labels

Comments

@openwrt-bot
Copy link

droncheg:

Device: TP-Link WDR4300 v1, wifi chips AR9344 and AR95801.
Platform: ar71xx
Trunk version: 12297 and newer (maybe earlier, but 12162 doesnt have this bug)
What's wrong: after first clean firmware write boots ok. But after first restart it will zeroed ART mtd4 partition. So no wifi (2.4 and 5GHz). In dmesg there's a errors like this:
[ 9.662487] ath: phy0: Unable to initialize hardware; initialization status: -5
[ 9.864421] ath: phy1: Unable to initialize hardware; initialization status: -5

Restoring ART partition helps till next reboot, then again no wifi (partiion zeroed again).
How to fix: write ART mtd4 partition without reboot, flash older (12162) firmware, reboot.

I got ART from [[http://https://github.com/gwlim/art-radio/tree/master/AR9344-Tested_on_WDR4300|this nice repo]]. Then build (or got from my site) new 12320 firmware with kmod-mtd-rw module. Flash firmware, scp working [[http://https://github.com/gwlim/art-radio/blob/master/AR9344-Tested_on_WDR4300/2.4-24dbm-5-24dbm-art-ar9344-ar9580%20(7).bin|ART]] to /tmp. Write ART without reboot:
insmod mtd-rw i_want_a_brick=1
mtd unlock art
mtd write /tmp/2.4-24dbm-5-24dbm-art-ar9344-ar9580\ 20(7).bin art

Then write old (12162) firmware, reboot. Everything works well!

My builds avaible [[http://openwrt.do2.pw/my_builds/firmware/|here]].

@openwrt-bot
Copy link
Author

pepe2k:

Please, provide full bootlog.

@openwrt-bot
Copy link
Author

droncheg:

Phase 1 (flashed via web-interface from 12162, indice working wifi):
[ 0.000000] Linux version 4.14.171 (lede@do2.pw) (gcc version 8.3.0 (OpenWrt GCC 8.3.0 r12297-7e9c7e7b2d)) #0 Tue Feb 25 16:50:46 2020
[ 0.000000] MyLoader: sysp=4b1bf7b5, boardp=9002c600, parts=6bde8914
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU0 revision is: 0001974c (MIPS 74Kc)
[ 0.000000] SoC: Atheros AR9344 rev 2
[ 0.000000] Determined physical RAM map:
[ 0.000000] memory: 08000000 @ 00000000 (usable)
[ 0.000000] Initrd not found or empty - disabling initrd
[ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[ 0.000000] Zone ranges:
[ 0.000000] Normal [mem 0x0000000000000000-0x0000000007ffffff]
[ 0.000000] Movable zone start for each node
[ 0.000000] Early memory node ranges
[ 0.000000] node 0: [mem 0x0000000000000000-0x0000000007ffffff]
[ 0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
[ 0.000000] On node 0 totalpages: 32768
[ 0.000000] free_area_init_node: node 0, pgdat 805478d0, node_mem_map 81000020
[ 0.000000] Normal zone: 288 pages used for memmap
[ 0.000000] Normal zone: 0 pages reserved
[ 0.000000] Normal zone: 32768 pages, LIFO batch:7
[ 0.000000] random: get_random_bytes called from start_kernel+0x98/0x4a0 with crng_init=0
[ 0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=132768
[ 0.000000] pcpu-alloc: [0] 0
[ 0.000000] Built 1 zonelists, mobility grouping on. Total pages: 32480
[ 0.000000] Kernel command line: board=TL-WDR4300 console=ttyS0,115200 rootfstype=squashfs noinitrd
[ 0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
[ 0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[ 0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[ 0.000000] Writing ErrCtl register=00000000
[ 0.000000] Readback ErrCtl register=00000000
[ 0.000000] Memory: 123848K/131072K available (3915K kernel code, 192K rwdata, 916K rodata, 280K init, 209K bss, 7224K reserved, 0K cma-reserved)
[ 0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] NR_IRQS: 51
[ 0.000000] Clocks: CPU:560.000MHz, DDR:450.000MHz, AHB:225.000MHz, Ref:40.000MHz
[ 0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6825930166 ns
[ 0.000009] sched_clock: 32 bits at 280MHz, resolution 3ns, wraps every 7669584382ns
[ 0.008307] Calibrating delay loop... 278.93 BogoMIPS (lpj=1394688)
[ 0.084933] pid_max: default: 32768 minimum: 301
[ 0.090124] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.097187] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.107556] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[ 0.118061] futex hash table entries: 256 (order: -1, 3072 bytes)
[ 0.125129] NET: Registered protocol family 16
[ 0.131252] MIPS: machine is TP-LINK TL-WDR3600/4300/4310
[ 0.140341] registering PCI controller with io_map_base unset
[ 0.401332] PCI host bridge to bus 0000:00
[ 0.405705] pci_bus 0000:00: root bus resource [mem 0x10000000-0x13ffffff]
[ 0.413069] pci_bus 0000:00: root bus resource [io 0x0000]
[ 0.419001] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[ 0.426236] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[ 0.434697] pci 0000:00:00.0: [168c:0033] type 00 class 0x028000
[ 0.434713] pci 0000:00:00.0: invalid calibration data
[ 0.440229] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x0001ffff 64bit]
[ 0.440286] pci 0000:00:00.0: reg 0x30: [mem 0x00000000-0x0000ffff pref]
[ 0.440369] pci 0000:00:00.0: supports D1
[ 0.440380] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[ 0.440607] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 00
[ 0.440636] pci 0000:00:00.0: BAR 0: assigned [mem 0x10000000-0x1001ffff 64bit]
[ 0.448437] pci 0000:00:00.0: BAR 6: assigned [mem 0x10020000-0x1002ffff pref]
[ 0.456815] clocksource: Switched to clocksource MIPS
[ 0.463349] NET: Registered protocol family 2
[ 0.468819] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.476244] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.483060] TCP: Hash tables configured (established 1024 bind 1024)
[ 0.489967] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.496197] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.503220] NET: Registered protocol family 1
[ 0.507958] PCI: CLS 0 bytes, default 32
[ 0.513540] Crashlog allocated RAM at address 0x3f00000
[ 0.520622] workingset: timestamp_bits=14 max_order=15 bucket_order=1
[ 0.533666] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 0.539920] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[ 0.562419] io scheduler noop registered
[ 0.566593] io scheduler deadline registered (default)
[ 0.572409] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[ 0.579606] console [ttyS0] disabled
[ 0.603498] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11, base_baud = 2500000) is a 16550A
[ 0.612691] console [ttyS0] enabled
[ 0.620118] bootconsole [early0] disabled
[ 0.633243] m25p80 spi0.0: found s25fl064k, expected m25p80
[ 0.649392] m25p80 spi0.0: s25fl064k (8192 Kbytes)
[ 0.654551] 5 tp-link partitions found on MTD device spi0.0
[ 0.660248] Creating 5 MTD partitions on "spi0.0":
[ 0.665118] 0x000000000000-0x000000020000 : "u-boot"
[ 0.672012] 0x000000020000-0x0000001ba5e4 : "kernel"
[ 0.678526] 0x0000001ba5e4-0x0000007f0000 : "rootfs"
[ 0.684358] mtd: device 2 (rootfs) set to be root filesystem
[ 0.690185] 1 squashfs-split partitions found on MTD device rootfs
[ 0.696455] Creating 1 MTD partitions on "rootfs":
[ 0.701337] 0x000000295a1c-0x000000635a1c : "rootfs_data"
[ 0.709976] 0x0000007f0000-0x000000800000 : "art"
[ 0.716620] 0x000000020000-0x0000007f0000 : "firmware"
[ 0.724254] libphy: Fixed MDIO Bus: probed
[ 0.743135] switch0: Atheros AR8327 rev. 2 switch registered on ag71xx-mdio.0
[ 1.421371] libphy: ag71xx_mdio: probed
[ 2.048217] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.0:00 [uid=004dd033, driver=Atheros AR8216/AR8236/AR8316]
[ 2.059624] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode: rgmii
[ 2.067916] NET: Registered protocol family 10
[ 2.077308] Segment Routing with IPv6
[ 2.081132] NET: Registered protocol family 17
[ 2.086282] 8021q: 802.1Q VLAN Support v1.8
[ 2.097850] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[ 2.106249] Freeing unused kernel memory: 280K
[ 2.110798] This architecture does not have kernel memory protection.
[ 2.566831] random: fast init done
[ 2.875807] init: Console is alive
[ 2.879561] init: - watchdog -
[ 4.003361] kmodloader: loading kernel modules from /etc/modules-boot.d/

[ 4.074168] usbcore: registered new interface driver usbfs
[ 4.079877] usbcore: registered new interface driver hub
[ 4.085359] usbcore: registered new device driver usb
[ 4.096228] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 4.104643] ehci-platform: EHCI generic platform driver
[ 4.110087] ehci-platform ehci-platform: EHCI Host Controller
[ 4.115959] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
[ 4.126094] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
[ 4.156862] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
[ 4.164087] hub 1-0:1.0: USB hub found
[ 4.168340] hub 1-0:1.0: 1 port detected
[ 4.173551] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[ 4.183823] init: - preinit -
[ 4.795761] usb 1-1: new high-speed USB device number 2 using ehci-platform
[ 5.049717] random: procd: uninitialized urandom read (4 bytes read)
[ 5.056947] hub 1-1:1.0: USB hub found
[ 5.067117] hub 1-1:1.0: 4 ports detected
[ 5.135015] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 6.188080] eth0: link up (1000Mbps/Full duplex)
[ 6.192857] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 9.393888] mount_root: jffs2 not ready yet, using temporary tmpfs overlay
[ 9.428379] urandom-seed: Seed file not found (/etc/urandom.seed)
[ 9.611761] eth0: link down
[ 9.627775] procd: - early -
[ 9.630807] procd: - watchdog -
[ 10.259213] procd: - watchdog -
[ 10.262726] procd: - ubus -
[ 10.339029] random: ubusd: uninitialized urandom read (4 bytes read)
[ 10.398906] random: ubusd: uninitialized urandom read (4 bytes read)
[ 10.405859] random: ubusd: uninitialized urandom read (4 bytes read)
[ 10.413496] procd: - init -
[ 11.172668] kmodloader: loading kernel modules from /etc/modules.d/*
[ 11.339748] ip6_tables: (C) 2000-2006 Netfilter Core Team
[ 11.368041] Loading modules backported from Linux version v5.4-rc8-0-gaf42d3466bdc
[ 11.375730] Backport generated by backports.git v5.4-rc8-1-0-g368e8c51
[ 11.408451] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 11.432817] nf_conntrack version 0.5.0 (2048 buckets, 8192 max)
[ 11.560626] xt_time: kernel timezone is -0000
[ 11.634163] urngd: v1.0.2 started.
[ 11.692668] PPP generic driver version 2.4.2
[ 11.707932] NET: Registered protocol family 24
[ 11.784770] ath: EEPROM regdomain: 0x0
[ 11.784779] ath: EEPROM indicates default country code should be used
[ 11.784783] ath: doing EEPROM country->regdmn map search
[ 11.784799] ath: country maps to regdmn code: 0x3a
[ 11.784806] ath: Country alpha2 being used: US
[ 11.784810] ath: Regpair used: 0x3a
[ 11.798613] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[ 11.800402] ieee80211 phy0: Atheros AR9340 Rev:2 mem=0xb8100000, irq=47
[ 11.807364] pci 0000:00:00.0: using irq 40 for pin 1
[ 11.812421] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
[ 11.823524] ath: EEPROM regdomain: 0x0
[ 11.823533] ath: EEPROM indicates default country code should be used
[ 11.823537] ath: doing EEPROM country->regdmn map search
[ 11.823553] ath: country maps to regdmn code: 0x3a
[ 11.823559] ath: Country alpha2 being used: US
[ 11.823564] ath: Regpair used: 0x3a
[ 11.835479] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
[ 11.837347] ieee80211 phy1: Atheros AR9300 Rev:4 mem=0xb0000000, irq=40
[ 12.017228] kmodloader: done loading kernel modules from /etc/modules.d/*
[ 12.073375] random: crng init done
[ 12.076867] random: 6 urandom warning(s) missed due to ratelimiting
[ 81.888296] jffs2_scan_eraseblock(): End of filesystem marker found at 0x0
[ 81.895289] jffs2_build_filesystem(): unlocking the mtd device...
[ 81.911577] done.
[ 81.919857] jffs2_build_filesystem(): erasing all blocks after the end marker...
[ 82.761993] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 82.820832] br-lan: port 1(eth0.1) entered blocking state
[ 82.826324] br-lan: port 1(eth0.1) entered disabled state
[ 82.832187] device eth0.1 entered promiscuous mode
[ 82.837107] device eth0 entered promiscuous mode
[ 82.923560] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[ 83.018274] IPv6: ADDRCONF(NETDEV_UP): eth0.2: link is not ready
[ 83.788519] eth0: link up (1000Mbps/Full duplex)
[ 83.793294] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 83.848566] br-lan: port 1(eth0.1) entered blocking state
[ 83.854081] br-lan: port 1(eth0.1) entered forwarding state
[ 83.860105] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.2: link becomes ready
[ 83.961447] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[ 102.027032] done.
[ 102.029029] jffs2: notice: (1493) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[ 102.517737] overlayfs: upper fs does not support tmpfile.

Phase 2 (setting password and reboot newly flashed firmware, indice not working wifi):
[ 0.000000] Linux version 4.14.171 (lede@do2.pw) (gcc version 8.3.0 (OpenWrt GCC 8.3.0 r12297-7e9c7e7b2d)) #0 Tue Feb 25 16:50:46 2020
[ 0.000000] MyLoader: sysp=4b1bf7b5, boardp=9002c600, parts=6bde8914
[ 0.000000] bootconsole [early0] enabled
[ 0.000000] CPU0 revision is: 0001974c (MIPS 74Kc)
[ 0.000000] SoC: Atheros AR9344 rev 2
[ 0.000000] Determined physical RAM map:
[ 0.000000] memory: 08000000 @ 00000000 (usable)
[ 0.000000] Initrd not found or empty - disabling initrd
[ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[ 0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[ 0.000000] Zone ranges:
[ 0.000000] Normal [mem 0x0000000000000000-0x0000000007ffffff]
[ 0.000000] Movable zone start for each node
[ 0.000000] Early memory node ranges
[ 0.000000] node 0: [mem 0x0000000000000000-0x0000000007ffffff]
[ 0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
[ 0.000000] On node 0 totalpages: 32768
[ 0.000000] free_area_init_node: node 0, pgdat 805478d0, node_mem_map 81000020
[ 0.000000] Normal zone: 288 pages used for memmap
[ 0.000000] Normal zone: 0 pages reserved
[ 0.000000] Normal zone: 32768 pages, LIFO batch:7
[ 0.000000] random: get_random_bytes called from start_kernel+0x98/0x4a0 with crng_init=0
[ 0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=132768
[ 0.000000] pcpu-alloc: [0] 0
[ 0.000000] Built 1 zonelists, mobility grouping on. Total pages: 32480
[ 0.000000] Kernel command line: board=TL-WDR4300 console=ttyS0,115200 rootfstype=squashfs noinitrd
[ 0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
[ 0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[ 0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[ 0.000000] Writing ErrCtl register=00000000
[ 0.000000] Readback ErrCtl register=00000000
[ 0.000000] Memory: 123848K/131072K available (3915K kernel code, 192K rwdata, 916K rodata, 280K init, 209K bss, 7224K reserved, 0K cma-reserved)
[ 0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] NR_IRQS: 51
[ 0.000000] Clocks: CPU:560.000MHz, DDR:450.000MHz, AHB:225.000MHz, Ref:40.000MHz
[ 0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6825930166 ns
[ 0.000009] sched_clock: 32 bits at 280MHz, resolution 3ns, wraps every 7669584382ns
[ 0.008308] Calibrating delay loop... 278.93 BogoMIPS (lpj=1394688)
[ 0.084933] pid_max: default: 32768 minimum: 301
[ 0.090124] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.097186] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.107548] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[ 0.118053] futex hash table entries: 256 (order: -1, 3072 bytes)
[ 0.125120] NET: Registered protocol family 16
[ 0.131246] MIPS: machine is TP-LINK TL-WDR3600/4300/4310
[ 0.140333] registering PCI controller with io_map_base unset
[ 0.401327] PCI host bridge to bus 0000:00
[ 0.405704] pci_bus 0000:00: root bus resource [mem 0x10000000-0x13ffffff]
[ 0.413068] pci_bus 0000:00: root bus resource [io 0x0000]
[ 0.418993] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[ 0.426227] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[ 0.434689] pci 0000:00:00.0: [168c:0033] type 00 class 0x028000
[ 0.434705] pci 0000:00:00.0: invalid calibration data
[ 0.440221] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x0001ffff 64bit]
[ 0.440278] pci 0000:00:00.0: reg 0x30: [mem 0x00000000-0x0000ffff pref]
[ 0.440362] pci 0000:00:00.0: supports D1
[ 0.440373] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[ 0.440599] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 00
[ 0.440628] pci 0000:00:00.0: BAR 0: assigned [mem 0x10000000-0x1001ffff 64bit]
[ 0.448429] pci 0000:00:00.0: BAR 6: assigned [mem 0x10020000-0x1002ffff pref]
[ 0.456806] clocksource: Switched to clocksource MIPS
[ 0.463340] NET: Registered protocol family 2
[ 0.468808] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.476236] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.483051] TCP: Hash tables configured (established 1024 bind 1024)
[ 0.489959] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.496189] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.503215] NET: Registered protocol family 1
[ 0.507957] PCI: CLS 0 bytes, default 32
[ 0.513570] Crashlog allocated RAM at address 0x3f00000
[ 0.520658] workingset: timestamp_bits=14 max_order=15 bucket_order=1
[ 0.533719] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[ 0.539970] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[ 0.562465] io scheduler noop registered
[ 0.566643] io scheduler deadline registered (default)
[ 0.572457] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[ 0.579655] console [ttyS0] disabled
[ 0.603549] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11, base_baud = 2500000) is a 16550A
[ 0.612747] console [ttyS0] enabled
[ 0.620175] bootconsole [early0] disabled
[ 0.633299] m25p80 spi0.0: found s25fl064k, expected m25p80
[ 0.649488] m25p80 spi0.0: s25fl064k (8192 Kbytes)
[ 0.654650] 5 tp-link partitions found on MTD device spi0.0
[ 0.660350] Creating 5 MTD partitions on "spi0.0":
[ 0.665219] 0x000000000000-0x000000020000 : "u-boot"
[ 0.672116] 0x000000020000-0x0000001ba5e4 : "kernel"
[ 0.678625] 0x0000001ba5e4-0x0000007f0000 : "rootfs"
[ 0.684457] mtd: device 2 (rootfs) set to be root filesystem
[ 0.690284] 1 squashfs-split partitions found on MTD device rootfs
[ 0.696555] Creating 1 MTD partitions on "rootfs":
[ 0.701438] 0x000000295a1c-0x000000635a1c : "rootfs_data"
[ 0.710064] 0x0000007f0000-0x000000800000 : "art"
[ 0.716703] 0x000000020000-0x0000007f0000 : "firmware"
[ 0.724341] libphy: Fixed MDIO Bus: probed
[ 0.743198] switch0: Atheros AR8327 rev. 2 switch registered on ag71xx-mdio.0
[ 1.421354] libphy: ag71xx_mdio: probed
[ 2.048209] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.0:00 [uid=004dd033, driver=Atheros AR8216/AR8236/AR8316]
[ 2.059609] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode: rgmii
[ 2.067889] NET: Registered protocol family 10
[ 2.077277] Segment Routing with IPv6
[ 2.081110] NET: Registered protocol family 17
[ 2.086260] 8021q: 802.1Q VLAN Support v1.8
[ 2.097829] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[ 2.106214] Freeing unused kernel memory: 280K
[ 2.110768] This architecture does not have kernel memory protection.
[ 2.566821] random: fast init done
[ 2.877392] init: Console is alive
[ 2.881077] init: - watchdog -
[ 4.005439] kmodloader: loading kernel modules from /etc/modules-boot.d/

[ 4.076977] usbcore: registered new interface driver usbfs
[ 4.082623] usbcore: registered new interface driver hub
[ 4.088142] usbcore: registered new device driver usb
[ 4.099027] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 4.107471] ehci-platform: EHCI generic platform driver
[ 4.112858] ehci-platform ehci-platform: EHCI Host Controller
[ 4.118770] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
[ 4.128893] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
[ 4.156852] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
[ 4.164038] hub 1-0:1.0: USB hub found
[ 4.168341] hub 1-0:1.0: 1 port detected
[ 4.173467] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[ 4.191290] init: - preinit -
[ 4.805559] usb 1-1: new high-speed USB device number 2 using ehci-platform
[ 5.059754] random: procd: uninitialized urandom read (4 bytes read)
[ 5.066981] hub 1-1:1.0: USB hub found
[ 5.077110] hub 1-1:1.0: 4 ports detected
[ 5.143570] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 6.188071] eth0: link up (1000Mbps/Full duplex)
[ 6.192839] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 9.407132] jffs2: notice: (446) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[ 9.424420] mount_root: overlay filesystem has not been fully initialized yet
[ 9.680135] mount_root: switching to jffs2 overlay
[ 9.722360] overlayfs: upper fs does not support tmpfile.
[ 9.732032] urandom-seed: Seed file not found (/etc/urandom.seed)
[ 9.949839] eth0: link down
[ 9.965069] procd: - early -
[ 9.968891] procd: - watchdog -
[ 10.596865] procd: - watchdog -
[ 10.600391] procd: - ubus -
[ 10.688289] random: ubusd: uninitialized urandom read (4 bytes read)
[ 10.758129] random: ubusd: uninitialized urandom read (4 bytes read)
[ 10.765078] random: ubusd: uninitialized urandom read (4 bytes read)
[ 10.772716] procd: - init -
[ 11.592708] kmodloader: loading kernel modules from /etc/modules.d/*
[ 11.763682] ip6_tables: (C) 2000-2006 Netfilter Core Team
[ 11.791723] Loading modules backported from Linux version v5.4-rc8-0-gaf42d3466bdc
[ 11.799469] Backport generated by backports.git v5.4-rc8-1-0-g368e8c51
[ 11.829550] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 11.855621] nf_conntrack version 0.5.0 (2048 buckets, 8192 max)
[ 12.003757] xt_time: kernel timezone is -0000
[ 12.077652] urngd: v1.0.2 started.
[ 12.142686] PPP generic driver version 2.4.2
[ 12.157920] NET: Registered protocol family 24
[ 12.233720] ath: phy0: Unable to initialize hardware; initialization status: -5
[ 12.241208] ath9k ar934x_wmac: failed to initialize device
[ 12.246834] ath9k: probe of ar934x_wmac failed with error -5
[ 12.252745] pci 0000:00:00.0: using irq 40 for pin 1
[ 12.257847] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
[ 12.267873] ath: phy1: Unable to initialize hardware; initialization status: -5
[ 12.275297] ath9k 0000:00:00.0: Failed to initialize device
[ 12.281026] ath9k: probe of 0000:00:00.0 failed with error -5
[ 12.357227] kmodloader: done loading kernel modules from /etc/modules.d/*
[ 12.391584] random: crng init done
[ 12.395050] random: 6 urandom warning(s) missed due to ratelimiting
[ 62.547631] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 62.648780] br-lan: port 1(eth0.1) entered blocking state
[ 62.654273] br-lan: port 1(eth0.1) entered disabled state
[ 62.660139] device eth0.1 entered promiscuous mode
[ 62.665012] device eth0 entered promiscuous mode
[ 62.672877] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[ 62.705040] IPv6: ADDRCONF(NETDEV_UP): eth0.2: link is not ready
[ 63.641596] eth0: link up (1000Mbps/Full duplex)
[ 63.646366] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 63.706942] br-lan: port 1(eth0.1) entered blocking state
[ 63.712439] br-lan: port 1(eth0.1) entered forwarding state
[ 63.718467] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.2: link becomes ready
[ 63.836898] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready

I suppose, rootfs_data overwrite art partition. Cause when i'm not setting password - after reboot wifi keep working. Setting password or any other settings cause that?

@openwrt-bot
Copy link
Author

pepe2k:

This could be related: https://bugs.openwrt.org/index.php?do=details&task_id=2837
Please, try this patch: https://patchwork.ozlabs.org/patch/1247614/

@openwrt-bot
Copy link
Author

droncheg:

Thank you! That's works now. I tested on 12464 and now my art-partiion keeps untouched =)
Hope this included in main trunk tree.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant