Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#3061 - Wi-Fi: Cannot set country code on AVM FRITZ 1750E #7830

Open
openwrt-bot opened this issue May 2, 2020 · 1 comment
Open

FS#3061 - Wi-Fi: Cannot set country code on AVM FRITZ 1750E #7830

openwrt-bot opened this issue May 2, 2020 · 1 comment
Labels

Comments

@openwrt-bot
Copy link

@openwrt-bot openwrt-bot commented May 2, 2020

sindastra:

It is not possible to set the country code on both 2.4 and 5 GHz.

Device: AVM FRITZ!WLAN REPEATER 1750E (target ath79 generic)
Software version: OpenWrt SNAPSHOT r13136-ad27c133eb
Steps to reproduce:

Console:
Execute iw reg set DE and then iw reg get, and see how "global" sets to "DE" but phy#1 and phy#0 remain on "US".

LuCI:
Sign in to LuCI, go to Network>Wireless (click Edit and then the "Advanced" tab) try to change the country code on either Wi-Fi device/frequency to "DE" and see how it resets to "driver default" after apply, which seems to be "US".

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented May 8, 2020

adrianschmutzler:

From my experience, I've never been able to change the phy settings, but only the global reg domain. On all my devices, phy has always stayed at US.

When I change it via LuCi, I get the same result. However, it seems the global setting is the one being applied, as it's more constrained.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant