Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#2130 - usbip fails to list USB devices due to libudev-fbsd #8102

Closed
openwrt-bot opened this issue Feb 17, 2019 · 5 comments
Closed

FS#2130 - usbip fails to list USB devices due to libudev-fbsd #8102

openwrt-bot opened this issue Feb 17, 2019 · 5 comments
Labels

Comments

@openwrt-bot
Copy link

openwrt-bot commented Feb 17, 2019

TampertK:

The usbip package fails to list connected USB devices. "usbip list -l" simply gives an empty return.

This is not a kernel issue, it’s caused by libudev-fbsd. The dependencies for usbip are still pointing to libudev-fbsd. This lib contains just a stub for udev_device_get_sysattr_value, which leads to the errors mentioned by blasters and arrmo. Using libudev instead, everything’s working as expected.

This problem exists in 18.06 and trunk.

@openwrt-bot
Copy link
Author

openwrt-bot commented Mar 4, 2020

Jakdaw:

Problem still exists in 19.07.1.

Workaround (uninstall libudev-fbsd, install libudev from 17.01.7) still works nicely.

@openwrt-bot
Copy link
Author

openwrt-bot commented Apr 6, 2020

thiagoricciardi:

Problem still exists in 19.07.2 (tested with tl-wr703n ar71xx)

Workaround still works too

@openwrt-bot
Copy link
Author

openwrt-bot commented May 10, 2020

vklimk:

Problem still exists in 19.07.2 (tested with tl-wr1045n)

@openwrt-bot
Copy link
Author

openwrt-bot commented Jun 1, 2020

notgood:

Confirming, usbip is broken on 19.07.3

@openwrt-bot
Copy link
Author

openwrt-bot commented Jul 17, 2020

morzexxx:

This problem started in v18.
To solve copy libudev.so.1.6.3 from downloads.openwrt.org/releases/17.01.7/packages/(arc)/packages/libudev_3.2-1_(arc).ipk
and replace /usr/lib/libudev.so (or /overlay/upper/usr/lib/libudev.so for squashfs) with it.
For rpi4 (cortex a72) I used downloads.openwrt.org/releases/17.01.7/packages/aarch64_armv8-a/packages/libudev_3.2-1_aarch64_armv8-a.ipk with success.
Used 7-zip to extract files from ipk.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant