Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#3301 - Cannot satisfy dependency on iptables-mod-tproxy #8167

Closed
openwrt-bot opened this issue Aug 24, 2020 · 2 comments
Closed

FS#3301 - Cannot satisfy dependency on iptables-mod-tproxy #8167

openwrt-bot opened this issue Aug 24, 2020 · 2 comments
Labels
flyspray packages release/19.07 target/sunxi

Comments

@openwrt-bot
Copy link

@openwrt-bot openwrt-bot commented Aug 24, 2020

lowsfer:

One example is iptables-mod-tproxy. It is available in 19.07.0, but not in 19.07.1. This causes dependency issue when installing some packages.
How to reproduce:
# opkg install shadowsocks-libev-ss-rules
Installing shadowsocks-libev-ss-rules (3.2.5-5) to root...
Downloading http://downloads.openwrt.org/releases/19.07.1/packages/aarch64_cortex-a53/packages/shadowsocks-libev-ss-rules_3.2.5-5_aarch64_cortex-a53.ipk
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for shadowsocks-libev-ss-rules:
  •  iptables-mod-tproxy
    
  • opkg_install_cmd: Cannot install package shadowsocks-libev-ss-rules.

I reproduced it on aarch64_coretex_a53, but I see it's missing for other platforms like a72 and x86_64, too.

It was reported here: openwrt/packages#11457
But was closed and the maintainer said it belongs here.

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Aug 24, 2020

bjonglez:

The package exists as expected, here for a few targets:

https://downloads.openwrt.org/releases/19.07.1/targets/sunxi/cortexa53/packages/
https://downloads.openwrt.org/releases/19.07.1/targets/x86/64/packages/

It's not as the same place as other packages because it's tightly coupled with the kernel.

You are possibly missing the core packages feed in your opkg configuration (in /etc/opkg/):

src/gz openwrt_core http://downloads.openwrt.org/releases/19.07.1/targets/YOURTARGET/YOURSUBTARGET/packages

Btw you should always use the latest 19.07.X release in any case.

Please provide the content of all files in /etc/opkg/ and try with 19.07.3.

@aparcar aparcar added release/19.07 packages labels Feb 22, 2022
@ynezz ynezz added the target/sunxi label Mar 7, 2022
@ynezz
Copy link
Member

@ynezz ynezz commented Mar 8, 2022

Too old and probably not a bug.

@ynezz ynezz closed this as completed Mar 8, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
flyspray packages release/19.07 target/sunxi
Projects
None yet
Development

No branches or pull requests

3 participants