Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#3624 - AVM FITZ!Box 7320 USB ports have no power (fix) #8668

Closed
openwrt-bot opened this issue Feb 16, 2021 · 10 comments
Closed

FS#3624 - AVM FITZ!Box 7320 USB ports have no power (fix) #8668

openwrt-bot opened this issue Feb 16, 2021 · 10 comments
Labels

Comments

@openwrt-bot
Copy link

openwrt-bot commented Feb 16, 2021

HACKER-3000:

On the base 19.07.6 firmware for a 7320, the USB ports have no power. this can be fixed by pulling GPIO50 and GPIO51 high with the gpiocontrol.sh script. Workaround is explaind here: [[https://openwrt.org/toh/avm/avm_fritz_box_7320#getting_the_usb_ports_to_power_up]]

@openwrt-bot
Copy link
Author

openwrt-bot commented Feb 16, 2021

mkresin:

Does the following patch fixes the issue?

One patch is for the 19.07 branch, the other one in case you test master.

@openwrt-bot
Copy link
Author

openwrt-bot commented Feb 16, 2021

HACKER-3000:

i only see the patch for master

@openwrt-bot
Copy link
Author

openwrt-bot commented Feb 16, 2021

mkresin:

Here it is for 19.07.

@openwrt-bot
Copy link
Author

openwrt-bot commented Feb 17, 2021

HACKER-3000:

Thanks. I am a bit new to this tho... Can you give me a link for a "How-To apply patch"?

@openwrt-bot
Copy link
Author

openwrt-bot commented Feb 17, 2021

mkresin:

Can you give me a link for a "How-To apply patch"?

Well, it means to build OpenWrt from source. Judging from your question it's likely you never build OpenWrt from source.

Would you please try the following image instead: https://www.kresin.me/files/openwrt-19.07.6-lantiq-xway-avm_fritz7320-squashfs-sysupgrade.bin

@openwrt-bot
Copy link
Author

openwrt-bot commented Feb 17, 2021

HACKER-3000:

nope. this did not fix it. control via the gpiocontrol.sh script works fine tho. are you sure the pin numbering scheme is the same between the script and FRITZ7320.dts

@openwrt-bot
Copy link
Author

openwrt-bot commented Feb 17, 2021

mkresin:

are you sure the pin numbering scheme is the same between the script and FRITZ7320.dts

Not entirely but it should be the same.

I updated the Image. Would you please download the new one and try again.

@openwrt-bot
Copy link
Author

openwrt-bot commented Feb 17, 2021

HACKER-3000:

works. thank you

@openwrt-bot
Copy link
Author

openwrt-bot commented Feb 18, 2021

mkresin:

Will be fixed in OpenWrt v19.07.8 and later.

@openwrt-bot
Copy link
Author

openwrt-bot commented Feb 18, 2021

HACKER-3000:

nice

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant