Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#3746 - x86_64 EFI image fails to boot when USB device is plugged #8765

Open
openwrt-bot opened this issue Apr 20, 2021 · 0 comments
Open

FS#3746 - x86_64 EFI image fails to boot when USB device is plugged #8765

openwrt-bot opened this issue Apr 20, 2021 · 0 comments
Labels
flyspray release/21.02

Comments

@openwrt-bot
Copy link

@openwrt-bot openwrt-bot commented Apr 20, 2021

txcanyon:

Snapshot OR 21.02.0-rc1-x86_64 will not boot EFI

System: AsRock J5005-ITX (EFI only boot), 4GB ram, Intel Dual 1000PT server adapter

Steps used to typically install snapshot:

Boot SystemRescueCD to prompt
issue dd if=openwrt-xxx of=/dev/sda
partitions are copied over, reboot
Error on Snapshot: "error: disk 'hd0,gpt1' not found

on RC1 file copies over as above but it does not boot in any fashion just returns to the bios screen.

It's been a long time since I tested the EFI snapshots, but at one point they worked fine. Given that the EFI support was added to master, I decided to wait on 2021.02 for full implementation.

The original pull on github was #1968, but it has since been closed, and I saw there was some work on the EFI stack for dual booting. That image may in fact boot on a non-EFI system, but I do not have any way to test.

At this point I would say both snapshot and RC1 are broken for x86_64 EFI systems.

@aparcar aparcar added the release/21.02 label Feb 22, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
flyspray release/21.02
Projects
None yet
Development

No branches or pull requests

2 participants