Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#3817 - SSIDs on 5GHz radio dissapear a few days after boot #8817

Open
openwrt-bot opened this issue May 19, 2021 · 1 comment
Open

FS#3817 - SSIDs on 5GHz radio dissapear a few days after boot #8817

openwrt-bot opened this issue May 19, 2021 · 1 comment
Labels
flyspray release/21.02

Comments

@openwrt-bot
Copy link

@openwrt-bot openwrt-bot commented May 19, 2021

andyburns:

Supply the following if possible:

  • Device problem occurs on

BT homehub 5a (xrx200)

  • Software versions of OpenWrt/LEDE release, packages, etc.

21.02-rc1

  • Steps to reproduce

after upgrade from 19.07 all worked, then after a few days my 5GHz SSID was no longer visible, tried disable/enable the radio0, that didn't help, radio1 on 2.4GHz still working, had to reboot to get 5GHz back

after another 5.75 days, same happened again.

most recent messages in dmesg

[508519.675343] device wlan0 left promiscuous mode
[508519.678732] br-lan: port 3(wlan0) entered disabled state
[508519.713414] ath10k_pci 0000:02:00.0: mac flush null vif, drop 0 queues 0xffff
[508520.786031] ath10k_pci 0000:02:00.0: 10.1 wmi init: vdevs: 16 peers: 127 tid: 256
[508520.802066] ath10k_pci 0000:02:00.0: wmi print 'P 128 V 8 T 410'
[508520.806810] ath10k_pci 0000:02:00.0: wmi print 'msdu-desc: 1424 sw-crypt: 0 ct-sta: 0'
[508520.815553] ath10k_pci 0000:02:00.0: wmi print 'alloc rem: 24984 iram: 38672'
[508520.884894] ath10k_pci 0000:02:00.0: pdev param 0 not supported by firmware
[508520.898436] ath10k_pci 0000:02:00.0: rts threshold -1
[508520.912045] br-lan: port 3(wlan0) entered blocking state
[508520.916090] br-lan: port 3(wlan0) entered disabled state
[508520.922193] device wlan0 entered promiscuous mode

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Jun 17, 2021

andyburns:

I upgraded to rc2 and though the issue had gone away, but now it has re-occured after 15.6 days
same message in kernel log, still only 5GHz radio gone, 2.4GHz radio available

[1354252.316872] device wlan0 left promiscuous mode
[1354252.320318] br-lan: port 2(wlan0) entered disabled state
[1354252.341702] ath10k_pci 0000:02:00.0: could not get mac80211 beacon, vdev_id : 0 addr: a0:8e:78:1c:f8:d1
[1354252.351639] ath10k_pci 0000:02:00.0: mac flush null vif, drop 0 queues 0xff ff
[1354253.429160] ath10k_pci 0000:02:00.0: 10.1 wmi init: vdevs: 16 peers: 127 tid: 256
[1354253.445473] ath10k_pci 0000:02:00.0: wmi print 'P 128 V 8 T 410'
[1354253.450316] ath10k_pci 0000:02:00.0: wmi print 'msdu-desc: 1424 sw-crypt: 0 ct-sta: 0'
[1354253.459128] ath10k_pci 0000:02:00.0: wmi print 'alloc rem: 24984 iram: 3867 2'
[1354253.527235] ath10k_pci 0000:02:00.0: pdev param 0 not supported by firmware
[1354253.540826] ath10k_pci 0000:02:00.0: rts threshold -1
[1354253.554351] br-lan: port 2(wlan0) entered blocking state
[1354253.558507] br-lan: port 2(wlan0) entered disabled state
[1354253.564670] device wlan0 entered promiscuous mode

@aparcar aparcar added the release/21.02 label Feb 22, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
flyspray release/21.02
Projects
None yet
Development

No branches or pull requests

2 participants