Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#3696 - Windows devices can't get IPv6 from DHCPv6 #8937

Closed
openwrt-bot opened this issue Mar 20, 2021 · 3 comments
Closed

FS#3696 - Windows devices can't get IPv6 from DHCPv6 #8937

openwrt-bot opened this issue Mar 20, 2021 · 3 comments
Labels

Comments

@openwrt-bot
Copy link

openwrt-bot commented Mar 20, 2021

tiagogaspar8:

Supply the following if possible:

  • Device problem occurs on:
    WRT2300ACM

  • Software versions of OpenWrt/LEDE release, packages, etc.
    All the latest versions from trunk.

  • Steps to reproduce

  • Add a Windows device to lan

  • Set the Lease Time to 4h in Luci

  • Renew the IPv6 lease in the windows device

  • The device can't get an IPv6 (trough DHCP) anymore

More useful information:

  • If you restore the lease time to 12h Windows can get an IPv6 address again.
  • My LG webos TV can get an IPv6 address with the short lease, but my ubuntu machine cannot, same as windows.
  • The information we get from the windows logs is:
    • Solicit is sent from the interface 11. Status code is 0x0
    • Message is Invalid and it is discarded
  • The windows device still gets an IPv6 address via RA.
  • In the logs odhcpd shows that it receives the solicitation and responds adequately.
@openwrt-bot
Copy link
Author

openwrt-bot commented Mar 20, 2021

tiagogaspar8:

I have chosen the wrong category.

@openwrt-bot
Copy link
Author

openwrt-bot commented Jul 6, 2021

vevere:

Hi,

I can confirm this problem (I don't have a LG TV, so all my hosts lost loose their DHCPv6 addresses)

I made a declaration of the same bug at the wrong place:
openwrt/odhcpd#170

The problem is bigger, no IPv6-PD sent to downstream routers if lease time < 12h

workaround: specify a 12h lease time for each host that needs an IPv6 ... not good !

@openwrt-bot
Copy link
Author

openwrt-bot commented Sep 6, 2021

tiagogaspar8:

This issue is fixed, thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant