Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#4015 - Linksys WRT1900ACS sysupgrade image for 21.02.0 shows warning after upload #9005

Open
openwrt-bot opened this issue Sep 8, 2021 · 3 comments
Labels

Comments

@openwrt-bot
Copy link

@openwrt-bot openwrt-bot commented Sep 8, 2021

ianmtaylor1:

Device:

Model: Linksys WRT1900ACS
Architecture: ARMv7 Processor rev 1 (v7l)

Software versions:

Firmware Version: OpenWrt 19.07.7 r11306-c4a6851c72 / LuCI openwrt-19.07 branch git-21.044.30835-34e0d65
Kernel Version: 4.14.221

Steps to reproduce:

  • Download sysupgrade image, openwrt-21.02.0-mvebu-cortexa9-linksys_wrt1900acs-squashfs-sysupgrade.bin from [[https://openwrt.org/toh/linksys/wrt1900acs|Linksys WRT1900acs page]]. SHA256: 3880d91cdc54e1cb88cdb3123244d5cf85b8a05d64b4206fb0bd6462a6c73f49
  • In LuCi interface, go to "Backup / Flash Firmware" page and upload file in the "Flash new Firmware Image" box.
  • Get the warning.

Warning Text:

"Device linksys,shelby not supported by this image Supported devices: linksys,wrt1900acs armada-385-linksys-shelby linksys,shelby - Image version mismatch: image 1.1, device 1.0. Please wipe config during upgrade (force required) or reinstall. Reason: Config cannot be migrated from swconfig to DSA Image check failed.

The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform."

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Sep 8, 2021

ianmtaylor1:

Apologies for not setting the severity and reported version, I did not see those options until too late.

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Sep 8, 2021

ianmtaylor1:

I have found information about this warning on the [[https://openwrt.org/releases/21.02/notes-21.02.0|release notes for 21.02.0]]. So would the best course of action be to do a fresh install of 21.02.0 and set up my configuration again from scratch?

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Sep 8, 2021

anomeome:

Yes, [[https://forum.openwrt.org/t/should-i-force-upgrade-mvebu-dsa-change-warning/105458|forum thread]]

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant