Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#4113 - uboot-lantiq u-boot-2013.10 tftpboot ignores given boot file name. Uses 0101A8C0.img . #9119

Closed
openwrt-bot opened this issue Oct 27, 2021 · 2 comments
Labels

Comments

@openwrt-bot
Copy link

openwrt-bot commented Oct 27, 2021

jospezial:

Device problem occurs on VGV7510KW22
OpenWrt master

U-Boot 2013.10-openwrt4 (Oct 27 2021 - 12:27:58) VGV7510KW22

Board: Arcadyan VGV7510KW22
SoC: Lantiq VRX288 v1.2
CPU: 500 MHz
IO: 250 MHz
BUS: 250 MHz
BOOT: NOR
DRAM: 64 MiB
Flash: 16 MiB
In: serial
Out: serial
Err: serial
Net: Phy not found
ltq-eth
Hit any key to stop autoboot: 0
VGV7510KW22 # printenv
addconsole=setenv bootargs $bootargs console=$consoledev,$baudrate
addeth=setenv bootargs $bootargs ethaddr=$ethaddr
addip=setenv bootargs $bootargs ip=$ipaddr:$serverip::::$netdev:off
addmachtype=setenv bootargs $bootargs machtype=VGV7510KW22
baudrate=115200
bootcmd=bootm ${kernel_addr}
bootdelay=2
consoledev=ttyLTQ1
ethact=ltq-eth
ethaddr=00:01:02:03:04:05
ipaddr=192.168.1.1
kernel_addr=0xB0080000
load-uboot-nor=tftpboot u-boot.bin
load-uboot-norspl=tftpboot u-boot.ltq.norspl
load-uboot-norspl-lzma=tftpboot u-boot.ltq.lzma.norspl
load-uboot-norspl-lzo=tftpboot u-boot.ltq.lzo.norspl
loadaddr=0x81000000
netdev=eth0
serverip=192.168.1.23
stderr=serial
stdin=serial
stdout=serial
write-uboot-nor=protect off 0xB0000000 +$filesize && erase 0xB0000000 +$filesize && cp.b $fileaddr 0xB0000000 $filesize

Environment size: 853/131068 bytes
VGV7510KW22 # run load-uboot-nor
ltq_phy: addr 17, link 1, speed 100, duplex 1
ltq_phy: addr 18, link 0, speed 10, duplex 0
ltq_phy: addr 19, link 0, speed 10, duplex 0
ltq_phy: addr 20, link 0, speed 10, duplex 0
*** Warning: no boot file name; using '0101A8C0.img'
Using ltq-eth device
TFTP from server 192.168.1.23; our IP address is 192.168.1.1
Filename '0101A8C0.img'.
Load address: 0x81000000
Loading: T T

VGV7510KW22 # tftpboot xyz
ltq_phy: addr 17, link 1, speed 100, duplex 1
ltq_phy: addr 18, link 0, speed 10, duplex 0
ltq_phy: addr 19, link 0, speed 10, duplex 0
ltq_phy: addr 20, link 0, speed 10, duplex 0
*** Warning: no boot file name; using '0101A8C0.img'
Using ltq-eth device
TFTP from server 192.168.1.23; our IP address is 192.168.1.1
Filename '0101A8C0.img'.
Load address: 0x81000000
Loading: *

@openwrt-bot
Copy link
Author

openwrt-bot commented Oct 27, 2021

jospezial:

https://source.denx.de/u-boot/u-boot
Environment Variables:
bootfile - Name of the image to load with TFTP

setenv bootfile xyz does no change.

@openwrt-bot
Copy link
Author

openwrt-bot commented Oct 31, 2021

mkresin:

It's related to gcc.

gcc 9.3.0 works
gcc 10.3.0 shows the issues

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant