Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#4184 - USB port dead on WD livebook duo #9196

Closed
openwrt-bot opened this issue Dec 12, 2021 · 2 comments
Closed

FS#4184 - USB port dead on WD livebook duo #9196

openwrt-bot opened this issue Dec 12, 2021 · 2 comments
Labels

Comments

@openwrt-bot
Copy link

@openwrt-bot openwrt-bot commented Dec 12, 2021

thwe:

On a WD livebook duo using OpenWrt 21.02.1, r16325-88151b8303, i expect power on for a device on plugging in. I like to use backup devices on the USB port and tried an external harddisk and USB-Sticks. None of them are powered on and i can't see any messages in the kernel- or system-log. On power up, an USB device gets power via the port, but after booting the kernel the port seems to be dead.
dmesg shows the following lines related to the USB subsystem (please let me know, if the full log is required):

] usb-regulator GPIO handle specifies active low - ignored
] kmodloader: loading kernel modules from /etc/modules-boot.d/*
] usbcore: registered new interface driver usbfs
] usbcore: registered new interface driver hub
] usbcore: registered new device driver usb
] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
] ehci-fsl: Freescale EHCI Host controller driver
] ehci-platform: EHCI generic platform driver
] uhci_hcd: USB Universal Host Controller Interface driver
] dwc2 4bff80000.usbotg: 4bff80000.usbotg supply vusb_d not found, using dummy regulator
] dwc2 4bff80000.usbotg: 4bff80000.usbotg supply vusb_a not found, using dummy regulator
] dwc2 4bff80000.usbotg: DWC OTG Controller
] dwc2 4bff80000.usbotg: new USB bus registered, assigned bus number 1
] dwc2 4bff80000.usbotg: irq 36, io mem 0x4bff80000
] hub 1-0:1.0: USB hub found
] hub 1-0:1.0: 1 port detected
] usbcore: registered new interface driver usb-storage
] usbcore: registered new interface driver uas
] kmodloader: done loading kernel modules from /etc/modules-boot.d/*

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Dec 28, 2021

chunkeey:

OpenWrt Forum thread about the topic:

[[https://forum.openwrt.org/t/wd-my-book-duo-usb/111926/8]]

There's an proposed fix for both Snapshot (and backported to OpenWrt-21.02).
[[https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=832b9cbd741cdb6cc8483b2cddfef6de000ec61d]]

If this works out as intended this is hopefully "fixed."

@openwrt-bot
Copy link
Author

@openwrt-bot openwrt-bot commented Jan 1, 2022

thwe:

After building and testing the current development (master at 2e1206a) and stable snapshots (openwrt-21.02 at 4dddb7c) i confirm, it works as intended.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant