Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#4249 - image builder show collected errors #9229

Open
openwrt-bot opened this issue Feb 2, 2022 · 1 comment
Open

FS#4249 - image builder show collected errors #9229

openwrt-bot opened this issue Feb 2, 2022 · 1 comment
Labels

Comments

@openwrt-bot
Copy link

openwrt-bot commented Feb 2, 2022

andygaof:

Supply the following if possible:

  • Device problem occurs on

image builder

  • Software versions of OpenWrt/LEDE release, packages, etc.

openwrt-imagebuilder-rockchip-armv8.Linux-x86_64.tar.xz Wed Feb 2 14:22:36 2022

  • Steps to reproduce

with Arch Linux

tar -xvf openwrt-imagebuilder-rockchip-armv8.Linux-x86_64.tar.xz
cd openwrt-imagebuilder-rockchip-armv8.Linux-x86_64
make image PROFILE="friendlyarm_nanopi-r4s"

try three times, it always show below message.seems this version of image builder is base on kernel 5.10.92, but below packags need 5.10.96

Configuring urngd.
Collected errors:

  • pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.96-1-07d10da2ae97351f8e93da080d950687) for kmod-nf-reject6
  • pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.96-1-07d10da2ae97351f8e93da080d950687) for kmod-lib-crc32c
  • pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.96-1-07d10da2ae97351f8e93da080d950687) for kmod-nft-offload
  • pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.96-1-07d10da2ae97351f8e93da080d950687) for kmod-nf-nat6
  • satisfy_dependencies_for: Cannot satisfy the following dependencies for firewall4:
  • kernel (= 5.10.96-1-07d10da2ae97351f8e93da080d950687)
  • opkg_install_cmd: Cannot install package firewall4.
  • pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.96-1-07d10da2ae97351f8e93da080d950687) for kmod-gpio-button-hotplug
  • pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.96-1-07d10da2ae97351f8e93da080d950687) for kmod-libphy
  • pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.96-1-07d10da2ae97351f8e93da080d950687) for kmod-fixed-phy
  • pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.96-1-07d10da2ae97351f8e93da080d950687) for kmod-r8169
  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-r8169:
  • kernel (= 5.10.96-1-07d10da2ae97351f8e93da080d950687)
  • opkg_install_cmd: Cannot install package kmod-r8169.
  • pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.96-1-07d10da2ae97351f8e93da080d950687) for kmod-lib-crc-ccitt
  • satisfy_dependencies_for: Cannot satisfy the following dependencies for ppp:
  • kernel (= 5.10.96-1-07d10da2ae97351f8e93da080d950687)
  • opkg_install_cmd: Cannot install package ppp.
  • satisfy_dependencies_for: Cannot satisfy the following dependencies for ppp-mod-pppoe:
  • kernel (= 5.10.96-1-07d10da2ae97351f8e93da080d950687)
  • opkg_install_cmd: Cannot install package ppp-mod-pppoe.
    make[2]: *** [Makefile:168: package_install] Error 255
    make[1]: *** [Makefile:123: _call_image] Error 2
    make: *** [Makefile:241: image] Error 2
@cryobry
Copy link

cryobry commented Feb 26, 2022

I'm seeing this same issue on latest snapshot.

Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-nfnetlink
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nfnetlink found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-nf-reject
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nf-reject found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-nf-reject6
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nf-reject6 found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-nf-conntrack
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nf-conntrack found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-nf-conntrack6
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nf-conntrack6 found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-nf-nat
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nf-nat found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-crypto-hash
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-crypto-hash found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-crypto-crc32c
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-crypto-crc32c found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-lib-crc32c
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-lib-crc32c found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-nft-core
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nft-core found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-nft-fib
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nft-fib found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-nf-flow
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nf-flow found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-nft-nat
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nft-nat found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-nft-offload
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nft-offload found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-nf-nat6
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nf-nat6 found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-nft-nat6
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nft-nat6 found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-nf-ipt
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nf-ipt found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-ipt-core
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ipt-core found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-ipt-conntrack
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ipt-conntrack found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-ipt-nat
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ipt-nat found, but incompatible with the architectures configured
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci:
 *      kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1)
 * opkg_install_cmd: Cannot install package luci.
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-nf-ipt6
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nf-ipt6 found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-ip6tables
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ip6tables found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-nf-conntrack-netlink
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nf-conntrack-netlink found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-crypto-lib-blake2s
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-crypto-lib-blake2s found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-crypto-lib-chacha20
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-crypto-lib-chacha20 found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-crypto-lib-poly1305
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-crypto-lib-poly1305 found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-crypto-lib-chacha20poly1305
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-crypto-lib-chacha20poly1305 found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-crypto-kpp
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-crypto-kpp found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-crypto-lib-curve25519
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-crypto-lib-curve25519 found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-udptunnel4
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-udptunnel4 found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-udptunnel6
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-udptunnel6 found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-wireguard
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-wireguard found, but incompatible with the architectures configured
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-wireguard:
 *      kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1)
 * opkg_install_cmd: Cannot install package luci-app-wireguard.
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-ipt-ipset
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ipt-ipset found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-ipt-ipopt
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ipt-ipopt found, but incompatible with the architectures configured
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-pbr:
 *      kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1)
 * opkg_install_cmd: Cannot install package luci-app-pbr.
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for dnsmasq-full:
 *      kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1)
 * opkg_install_cmd: Cannot install package dnsmasq-full.
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-sched-core
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-sched-core found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-sched-cake
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-sched-cake found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-ifb
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ifb found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-nft-compat
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nft-compat found, but incompatible with the architectures configured
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-sqm:
 *      kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1)
 * opkg_install_cmd: Cannot install package luci-app-sqm.
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-ipt-nat6
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ipt-nat6 found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package kmod-ipt-nat6.
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for ip6tables:
 *      kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1)
 * opkg_install_cmd: Cannot install package ip6tables.
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-ipt-offload
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ipt-offload found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package kmod-ipt-offload.
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-gpio-button-hotplug
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-gpio-button-hotplug found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package kmod-gpio-button-hotplug.
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-mii
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-mii found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-libphy
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-libphy found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-phy-realtek
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-phy-realtek found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-fixed-phy
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-fixed-phy found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-of-mdio
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-of-mdio found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-mdio-devres
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-mdio-devres found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-r8169
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-r8169 found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package kmod-r8169.
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-lib-crc-ccitt
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-lib-crc-ccitt found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-slhc
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-slhc found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-ppp
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ppp found, but incompatible with the architectures configured
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for ppp:
 *      kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1)
 * opkg_install_cmd: Cannot install package ppp.
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-pppox
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-pppox found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1) for kmod-pppoe
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-pppoe found, but incompatible with the architectures configured
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for ppp-mod-pppoe:
 *      kernel (= 5.10.100-1-3c9fedb1418392470fcd3250626310a1)
 * opkg_install_cmd: Cannot install package ppp-mod-pppoe.

It has been happening for several days now.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

2 participants