Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Zpool add problem #1028

Closed
RicardoLorenzo opened this issue Oct 9, 2012 · 6 comments
Closed

Zpool add problem #1028

RicardoLorenzo opened this issue Oct 9, 2012 · 6 comments
Milestone

Comments

@RicardoLorenzo
Copy link

@RicardoLorenzo RicardoLorenzo commented Oct 9, 2012

If i use two type of disks (/dev/sdb is SAS RAID, and /dev/sdc, /dev/sdd USB disks). The problem is about efi_write() method.

zpool create -f Pool1 /dev/sdb

zpool add -f Pool1 /dev/sdc

cannot label 'sdc': try using parted(8) and then provide a specific slice: -4

But, if i use:

zpool create -f Pool1 /dev/sdb /dev/sdc

Everything is fine!

And:

zpool create -f Pool1 /dev/sdc

zpool add -f Pool1 /dev/sdd

Everything is fine again!

@behlendorf
Copy link
Contributor

@behlendorf behlendorf commented Oct 9, 2012

Interesting... thanks for filing it when we get a little time we'll look in to it.

@behlendorf
Copy link
Contributor

@behlendorf behlendorf commented Nov 8, 2013

This looks like an issue with existing labels. You should be able to resolve this using the zpool labelclear command. For example:

# zpool create -f Pool1 /dev/sdb
# zpool add -f Pool1 /dev/sdc
cannot label 'sdc': try using parted(8) and then provide a specific slice: -4

# zpool labelclear /dev/sdc
# zpool add -f Pool1 /dev/sdc
@FransUrbo
Copy link
Contributor

@FransUrbo FransUrbo commented Jun 8, 2014

@behlendorf Exactly what and where should be documented?

@ilovezfs
Copy link
Contributor

@ilovezfs ilovezfs commented Jun 8, 2014

This is a minor bug, not a documentation issue.

@behlendorf behlendorf added Bug and removed Documentation labels Jun 9, 2014
@behlendorf
Copy link
Contributor

@behlendorf behlendorf commented Jun 9, 2014

Retagged as a bug. Someone should look in to exactly what's going on here. At worst we should be providing a more useful error message.

@behlendorf behlendorf removed this from the 0.6.5 milestone Oct 6, 2014
@behlendorf behlendorf added Bug - Minor and removed Bug labels Oct 6, 2014
@behlendorf behlendorf added this to the 0.8.0 milestone Mar 26, 2016
@behlendorf behlendorf removed the Bug - Minor label Sep 30, 2016
@behlendorf
Copy link
Contributor

@behlendorf behlendorf commented Oct 5, 2016

Closing as stale. If in fact this is still and issue we can reopen it.

@behlendorf behlendorf closed this Oct 5, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
4 participants
You can’t perform that action at this time.