Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Setting Read-Only to "No" with a calculated MIP no longer works #3950

Closed
ebruchez opened this Issue Feb 15, 2019 · 1 comment

Comments

@ebruchez
Copy link
Collaborator

ebruchez commented Feb 15, 2019

Regressed with #3746, where we added logic to remove the readonly attribute when set to false. But the attribute must not be removed if there is a calculation.

+1 from customer

@ebruchez ebruchez self-assigned this Feb 15, 2019

@ebruchez ebruchez added this to To review in Orbeon Forms 2019.1 via automation Feb 15, 2019

@ebruchez ebruchez added this to To Review in Orbeon Forms 2018.2.2 via automation Feb 15, 2019

@ebruchez

This comment has been minimized.

Copy link
Collaborator Author

ebruchez commented Feb 16, 2019

This is probably a regression when writing the attribute, but might not be a regression when reading the attribute: in that case, we took the default of false() for readonly even when there was a calculate. Anyway, this needs fixing.

@ebruchez ebruchez moved this from To Review to To Do in Orbeon Forms 2018.2.2 Feb 19, 2019

@ebruchez ebruchez closed this in 481170e Feb 20, 2019

Orbeon Forms 2019.1 automation moved this from To review to Done Feb 20, 2019

Orbeon Forms 2018.2.2 automation moved this from To Do to Done Feb 20, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.