Skip to content

New commits not showing up in PR #21585

New commits not showing up in PR #21585
Jun 2, 2021 · 1 answer

I opened a pull request here:

  <a href="https://github.com/AcademySoftwareFoundation/openexr/pull/1032" target="_blank" rel="noopener nofollow ugc">github.com/AcademySoftwareFoundation/openexr</a>

Fix pkg-config lib suffix for cmake debug builds

<div class="branches">
  <code>AcademySoftwareFoundation:RB-2.5</code> ← <code>mcmtroffaes:feature/fix-pkgconf-lib-suffix</code>
</div>

<div class="github-info">
  <div class="date">
    opened <span class="discourse-local-date" data-format="ll" data-date="2021-06-01" data-time="07:18:38" data-timezone="UTC">07:18AM - 01 Jun 21 UTC</span>
  </div>

  <div class="user">
    <a href="https://github.com/mcmtroffaes" target="_blank" rel="noopener nofollow ugc">
      <img alt="mcmtroffaes" src="https://user-images.githubusercontent.com/158568/181065732-97dc8333-63e4-4e2a-8901-0b46df786dc5.jpeg" class="onebox-avatar-inline" width="20" height="20">
      mcmtroffaes
    </a>
  </div>

  <div class="lines" title="1 commits changed 3 files with 6 additions and 3 deletions">
    <a href="https://github.com/AcademySoftwareFoundation/openexr/pull/1032/files" target="_blank" rel="noopener nofollow ugc">
      <span class="added">+6</span>
      <span class="removed">-3</span>
    </a>
  </div>
</div>

This fixes the generated pkgconfig file in debug builds (for instance, see https://github.com/microsoft/vcpkg/pull/18123): the debug libraries end with a _d postfix but the pc file was missing this postfix.

The configure.ac script does not support debug builds as far as I can tell so I've left that as is.

I then added some commits later, did a forced push (which showed), then added a few more commits and pushed them but those were not showing in the PR. I tried rebasing the branch and doing another forced push hoping github would resync the PR, but to no avail. I realize there can sometimes be a slight delay, but it’s been several hours now and still the PR appears not in sync with the branch that it is merging.

Actual diff it should show: https://github.com/mcmtroffaes/openexr/compare/RB-2.5..feature/fix-pkgconf-lib-suffix (not matching the PR above sadly)

Any idea what’s going on?

Update: The problem seems to have fixed itself today with another forced push.

Replies

1 suggested answer

Update: The problem seems to have fixed itself today with another forced push.

0 replies
Answer selected
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
1 participant