Skip to content

[Compiled VS Code Linux] Copilot claims vscode is outdated, yet running latest release #6629

Locked Answered by Krzysztof-Cieslak
Kaydax asked this question in Copilot
Discussion options

You must be logged in to vote

Hey,

GitHub Copilot is using some of the APIs that are still marked as proposed in the VSCode. They need to be manually enabled on non-standard VSCode releases.
To enable those APIs, in your version of VSCode, run Preferences: Configure Runtime Arguments command, and in the JSON file add following entry: "enable-proposed-api":["github.copilot"]. And then restart VSCode.

Replies: 2 comments 19 replies

Comment options

You must be logged in to vote
9 replies
@davecheney
Comment options

@sheepy0125
Comment options

@Kaydax
Comment options

@jcuenod
Comment options

@togetherwithasteria
Comment options

Comment options

You must be logged in to vote
10 replies
@Rigel772
Comment options

@Vanclief
Comment options

@Rigel772
Comment options

@Krzysztof-Cieslak
Comment options

@Zauberbutter
Comment options

Answer selected by Kaydax
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Copilot Code accurately and faster with your AI powered pair-programmer. Product Feedback
9 participants