Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

npm package.json errors #24

Open
zefhemel opened this Issue · 0 comments

1 participant

@zefhemel

I'm using node 0.4.1 with npm 0.3.9. When I try to install sqlite via npm I get the following error:

$ npm install sqlite
npm info it worked if it ends with ok
npm info using npm@0.3.9
npm info using node@v0.4.1
npm info fetch http://registry.npmjs.org/sqlite/-/sqlite-1.0.2.tgz
npm info calculating sha1 /var/folders/Es/EsMnDChmE+qahsDMbT+IMk+++TI/-Tmp-/npm-1298838692411/1298838692411-0.7790314091835171/tmp.tgz
npm info shasum d0d2c234d3ffe2dcca2fcffb1709d12b02aa325c
npm ERR! couldn't read package.json in /var/folders/Es/EsMnDChmE+qahsDMbT+IMk+++TI/-Tmp-/npm-1298838692411/1298838692411-0.7790314091835171/contents/package
npm ERR! Error installing sqlite@1.0.2
npm ERR! Error: Failed to parse json
npm ERR! Unexpected token ILLEGAL
npm ERR!     at jsonParseFail (/Users/zef/.node_libraries/.npm/npm/0.3.9/package/lib/utils/read-json.js:89:11)
npm ERR!     at /Users/zef/.node_libraries/.npm/npm/0.3.9/package/lib/utils/read-json.js:82:14
npm ERR!     at P (/Users/zef/.node_libraries/.npm/npm/0.3.9/package/lib/utils/read-json.js:62:40)
npm ERR!     at cb (/Users/zef/.node_libraries/.npm/npm/0.3.9/package/lib/utils/graceful-fs.js:31:9)
npm ERR!     at [object Object].<anonymous> (fs.js:86:5)
npm ERR!     at [object Object].emit (events.js:39:17)
npm ERR!     at afterRead (fs.js:843:12)
npm ERR! JSON.parse 
npm ERR! JSON.parse Failed to parse package.json data.
npm ERR! JSON.parse Note that package.json must be actual JSON, not
npm ERR! JSON.parse just a JavaScript object.
npm ERR! JSON.parse 
npm ERR! JSON.parse This changed in npm 0.3.0, and is not a bug in npm.
npm ERR! JSON.parse Tell the package author to fix their package.json file.
npm ERR! JSON.parse
npm ERR! System Darwin 10.6.0
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.