New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

1.9.12 - Office 365 Login fails php 5.6.x #2604

Closed
jdelhome3578 opened this Issue Oct 1, 2015 · 3 comments

Comments

Projects
None yet
3 participants
@jdelhome3578
Contributor

jdelhome3578 commented Oct 1, 2015

I am having trouble getting osticket to log in to an office 365 account running on php 5.6+. I am able to get it to work when running php 5.5.x. I believe it has something to do with the SSL/TLS improvements in 5.6.x.

With php 5.5.28 it works fine.
with php 5.6.14 I get SMTP: STARTTLS failed (code: 220, response: 2.0.0 SMTP server ready)

@jdelhome3578 jdelhome3578 changed the title from 1.9.12 - Office 365 to 1.9.12 - Office 365 Login fails php5.6 Oct 2, 2015

@jdelhome3578 jdelhome3578 changed the title from 1.9.12 - Office 365 Login fails php5.6 to 1.9.12 - Office 365 Login fails php 5.6.x Oct 2, 2015

@bobbeims

This comment has been minimized.

Show comment
Hide comment
@bobbeims

bobbeims Apr 14, 2016

same issue here ... is this slated to be fixed in 1.10?

bobbeims commented Apr 14, 2016

same issue here ... is this slated to be fixed in 1.10?

@ntozier

This comment has been minimized.

Show comment
Hide comment
@ntozier

ntozier Apr 15, 2016

Contributor

Other threads similar to this indicate that the 'fix' is to use a different version of PHP. There are a number of threads here indicating PHP7 compatibility for 1.10.x. So my guess would be the easy fix choice would be to run PHP 5.4, 5.5, or 7.

Contributor

ntozier commented Apr 15, 2016

Other threads similar to this indicate that the 'fix' is to use a different version of PHP. There are a number of threads here indicating PHP7 compatibility for 1.10.x. So my guess would be the easy fix choice would be to run PHP 5.4, 5.5, or 7.

@jdelhome3578

This comment has been minimized.

Show comment
Hide comment
@jdelhome3578

jdelhome3578 Nov 2, 2016

Contributor

Fixed with commit 4f68aeb

Contributor

jdelhome3578 commented Nov 2, 2016

Fixed with commit 4f68aeb

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment