Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Making parameter connections in graphical editor fails #1865

Closed
jjhudak opened this issue Jul 1, 2019 · 5 comments
Closed

Making parameter connections in graphical editor fails #1865

jjhudak opened this issue Jul 1, 2019 · 5 comments
Assignees
Milestone

Comments

@jjhudak
Copy link

@jjhudak jjhudak commented Jul 1, 2019

Summary

Expected and Current Behavior

Steps to Reproduce

Paste your model here

Environment

  • OSATE Version:
  • Operating System:
@jjhudak
Copy link
Author

@jjhudak jjhudak commented Jul 1, 2019

Attached is example model illustrating the problem. Open the diagram associated with thread implementation ComposeAircraftStatus.impl and attempt to make parameter connection among parameter ports.
-Selecting source parameter and extending pointer shows dotted connection...then clicking on destination parameter results in dotted connection vanishing. AADL text editor does not show any connections.

  • Go to thread implementation ComposeAircraftStatus.impl and un-comment the three parameter
    connection statements. Save and open the drawing-the connections are shown.

GraphicalEditorParamaterConnectionBug.zip

@philip-alldredge
Copy link
Collaborator

@philip-alldredge philip-alldredge commented Jul 1, 2019

When I try to make a connection the "no" symbol appears when hovering over the destination port. This indicates that validation is failing for some reason. Need to look into why.

@jjhudak
Copy link
Author

@jjhudak jjhudak commented Jul 2, 2019

@philip-alldredge
Copy link
Collaborator

@philip-alldredge philip-alldredge commented Jul 3, 2019

It doesn't have the word no in it. It's a small icon that indicates that the connection isn't valid. If you click when it appears, then nothing happens. Unfortunately, this isn't a behavior we can customize at this time.

@lwrage lwrage added this to the 2.5.1 milestone Jul 3, 2019
philip-alldredge added a commit that referenced this issue Jul 3, 2019
@philip-alldredge
Copy link
Collaborator

@philip-alldredge philip-alldredge commented Jul 15, 2019

@lwrage @jjhudak an issue was found that can cause additional problems creating parameter connections. Fixed with #1902. It would be nice if this can make it in 2.5.1 since it is a relatively non invasive change.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

3 participants