Manage your alerts causes error... #220

Closed
maxxo opened this Issue Apr 24, 2012 · 9 comments

Projects

None yet

4 participants

@maxxo
maxxo commented Apr 24, 2012

When logged in a user, in "my account", click on "manage your alerts"...causes the following error: Fatal error:

Call to a member function numRows() on a non-object in /home/user/public_html/osc24/oc-includes/osclass/model/Search.php on line 956

Also: If user is logged in and subscribes to a search, there is a confirmation pop-up, but no email notification/validation message. That is probably the way you want it, but just thought I'd let you know.

@juanramon

I cannot reproduce this issue... Can you add more information to your problem? For example:
- Was it a clean install or an update?
- How many languages were you using?
- Were ads for this alert?
- Can you attach a screenshot?

About your suggestion, yeah, you're right. Perhaps will be better to send a notification/validation message. We'll add this to our list and see if in the end we do it or not.

@maxxo
maxxo commented Apr 24, 2012
  • Clean Install
  • Default intallation > US Language
  • Site is empty. Search alert for non-existent item, but otherwise valid search criteria.
  • I'd attach a screen shot, but don't know how here.
  • OSClass 2.4 beta, FireFox latest, Windows XP Pro, Java Enabled, flashblock plugin, otherwise normal environment.
@juanramon

@maxxo for upload screenshots you can use http://imgur.com/ and then paste the url here.

@maxxo
maxxo commented Apr 24, 2012

Ok. Thanks. Here's a screenshot with some additional info: http://imgur.com/5OT2g . If you want to test it on my server/site, I'll send you the link via email or PM. Just let me know.

@garciademarina
Member

Hi,

I cannot reproduce this issue,

Clean install -> create a user -> subscribe alert (via search, site is empty)
Go to 'My Account' -> 'Manage Alerts' [ Without errors ]

If you can provide more information ( step by step ), maybe we can reproduce this issue.

PS: Only anonymous alerts will need to be validated.

mail me with more info if you can at carlos at osclass.org

@maxxo
maxxo commented Apr 26, 2012

I emailed you info.

From home page > if user searches for xyz > sees search results page with xyz pre-populated in search box. However, if user tries to subscribe to search without first clicking "apply", causes error when user attempts to access "manage alerts" under "my account". Maybe the user should not be able to subscribe to a search without first searching ("apply") and getting results from the search (sidebar).

@garciademarina
Member

Thanks maxxo! it's fixed now.

@maxxo
maxxo commented Apr 26, 2012

Thanks Carlos! I also noticed, if logged-in user searches for a word that does not exist in database/classifieds and then attempts to subscribe (email alert), in the users "manage your alerts" area...there is no definition of the term that the user searched for. For example, user searched for "sillyalligator" and there are no ads with "sillyalligator", and user subscribes to search email alert...the resulting user area "mange your alerts" will show something like this: http://imgur.com/Xwj6Q

@garciademarina
Member

Hi maxxo,

For the moment we show '0 Items' if the alert don't return any results.

We'll improve alerts management for the next version.

http://i.imgur.com/ommeU.png

@conejoninja conejoninja added the CLOSED label Apr 2, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment