Skip to content
Permalink
Browse files

Добавил получение блоков из файла настроек

  • Loading branch information...
KrapivinAndrey committed Oct 25, 2018
1 parent c085caa commit 498d47d7f3681af65f12fda71471eefc160091f5
Showing with 35 additions and 6 deletions.
  1. +1 −5 CHANGELOG.md
  2. +34 −1 src/cmd/Классы/СтруктураЛога.os
@@ -1,5 +1 @@
# Changelog

## X.X.X

2018-10-25
# Changelog
@@ -1,5 +1,6 @@
#Использовать strings
#Использовать asserts
#Использовать yaml

Перем Лог;

@@ -48,6 +49,23 @@

КонецФункции

Функция ЗаполнитьНастройкиИзДанных(ВхСоответствие)

Результат = новый Соответствие();
Для Каждого Группа из ВхСоответствие Цикл

Для Каждого Эл Из Группа.Значение Цикл

Результат.Вставить(Эл, Группа.Ключ);

КонецЦикла;

КонецЦикла;

Возврат Результат;

КонецФункции

Процедура ОбработатьЭлементНастроек(Дерево, Настройка)

НужнаяГруппа = Дерево.Строки.Найти(Настройка.Значение, "Блок");
@@ -91,7 +109,22 @@

Процедура ИспользоватьНастройкиИзФайла(ПутьКФайлуНастроек) Экспорт

//Здесь будет разбор файла yml
Чтение = Новый ЧтениеТекста(ПутьКФайлуНастроек, КодировкаТекста.UTF8);
текстВФайле = Чтение.Прочитать();
Чтение.Закрыть();

Разбор = Новый ПарсерYAML;
Результат = Разбор.ПрочитатьYAML(текстВФайле);

Если Результат["massage_groups"] = Неопределено Тогда

НастройкиБлоков = НастройкиСоответствияБлоковПоУмолчанию();

Иначе

НастройкиБлоков = ЗаполнитьНастройкиИзДанных(Результат["massage_groups"]);

КонецЕсли;

КонецПроцедуры

0 comments on commit 498d47d

Please sign in to comment.
You can’t perform that action at this time.