Skip to content
Permalink
Browse files

Реализована возможность переопределения параметров тестового окружени…

…я через файл "ПараметрыТестирования.txt";

В тестах константные значения заменены на параметрические
  • Loading branch information...
AKuznetsov AKuznetsov
AKuznetsov authored and AKuznetsov committed Jun 7, 2018
1 parent e307c2a commit 88252d8135911df3d88f7c00540ce80d00d7176b
@@ -5,3 +5,4 @@ sonarlint.json
test-reports/
coverage/
*.ospx
tests/fixtures/ПараметрыТестирования.txt
@@ -45,7 +45,7 @@
ПроцедурыЗаполнения.Вставить(ВРег("Сервис") , "ЗаполнитьПараметрыСервиса");
ПроцедурыЗаполнения.Вставить(ВРег("session") , "ЗаполнитьПараметрыСеанса");
ПроцедурыЗаполнения.Вставить(ВРег("Сеанс") , "ЗаполнитьПараметрыСеанса");
ПроцедурыЗаполнения.Вставить(ВРег("connection") , "ЗаполнитьПараметрыСоединения");
ПроцедурыЗаполнения.Вставить(ВРег("connection") , "ЗаполнитьПараметрыСоединения");
ПроцедурыЗаполнения.Вставить(ВРег("Соединение") , "ЗаполнитьПараметрыСоединения");
ПроцедурыЗаполнения.Вставить(ВРег("process.license") , "ЗаполнитьПараметрыЛицензииПроцесса");
ПроцедурыЗаполнения.Вставить(ВРег("Процесс.Лицензия") , "ЗаполнитьПараметрыЛицензииПроцесса");
@@ -39,7 +39,7 @@

Функция Агент_СтрокаПодключения()

Возврат "localhost:1545";
Возврат Параметры().Агент_Адрес + ":" + Параметры().Агент_Порт;

КонецФункции // Агент_СтрокаПодключения()

@@ -53,18 +53,40 @@

Функция Агент_СтрокаАвторизации()

СтрокаАвторизации = СтрШаблон("--agent-user=%1 --agent-pwd=%2",
"""mainadmin""",
"123");
Если НЕ Параметры().Свойство("Агент_Администратор") Тогда
Возврат "";
КонецЕсли;

Если ПустаяСтрока(Параметры().Агент_Администратор) Тогда
Возврат "";
КонецЕсли;

СтрокаАвторизации = СтрШаблон("--agent-user=%1", Параметры().Агент_Администратор);

Если Не ПустаяСтрока(Параметры().Агент_Пароль) Тогда
СтрокаАвторизации = СтрокаАвторизации + СтрШаблон(" --agent-pwd=%1", Параметры().Агент_Пароль);
КонецЕсли;

Возврат СтрокаАвторизации;

КонецФункции // Кластер_СтрокаАвторизации()

Функция Кластер_СтрокаАвторизации()

СтрокаАвторизации = СтрШаблон("--cluster-user=%1 --cluster-pwd=%2",
"""clusteradmin""",
"123");
Если НЕ Параметры().Свойство("Кластер_Администратор") Тогда
Возврат "";
КонецЕсли;

Если ПустаяСтрока(Параметры().Кластер_Администратор) Тогда
Возврат "";
КонецЕсли;

СтрокаАвторизации = СтрШаблон("--cluster-user=%1", Параметры().Кластер_Администратор);

Если Не ПустаяСтрока(Параметры().Кластер_Пароль) Тогда
СтрокаАвторизации = СтрокаАвторизации + СтрШаблон(" --cluster-pwd=%1", Параметры().Кластер_Пароль);
КонецЕсли;

Возврат СтрокаАвторизации;

КонецФункции // Кластер_СтрокаАвторизации()
@@ -87,9 +109,20 @@

Функция ИБ_СтрокаАвторизации()

СтрокаАвторизации = СтрШаблон("--infobase-user=%1 --infobase-pwd=%2",
"""Пользователь И. Б.""",
"123");
Если НЕ Параметры().Свойство("ИБ_Администратор") Тогда
Возврат "";
КонецЕсли;

Если ПустаяСтрока(Параметры().ИБ_Администратор) Тогда
Возврат "";
КонецЕсли;

СтрокаАвторизации = СтрШаблон("--infobase-user=%1", Параметры().ИБ_Администратор);

Если Не ПустаяСтрока(Параметры().ИБ_Пароль) Тогда
СтрокаАвторизации = СтрокаАвторизации + СтрШаблон(" --infobase-pwd=%1", Параметры().ИБ_Пароль);
КонецЕсли;

Возврат СтрокаАвторизации;

КонецФункции // ИБ_СтрокаАвторизации()
@@ -911,6 +944,61 @@

КонецФункции // ПрочитатьМакетыОбъектовСервера()

// Возвращает текущие параметры тестового окружения
//
// Возвращаемое значение:
// Структура - параметры тестового окружения
//
Функция Параметры() Экспорт

Параметры = Новый Структура();

ЭтоСерверСборок = Ложь;
ЭтоСерверСборок = ВРег(ПолучитьПеременнуюСреды("CI")) = ВРег("true");

Параметры.Вставить("ЭтоСерверСборок" , ЭтоСерверСборок);
Параметры.Вставить("Агент_Адрес" , "localhost");
Параметры.Вставить("Агент_Порт" , "1545");
Параметры.Вставить("Агент_Администратор" , """mainadmin""");
Параметры.Вставить("Агент_Пароль" , "123");

Параметры.Вставить("Кластер_АдресПорт" , "Sport1:1541");
Параметры.Вставить("Кластер_Администратор", """clusteradmin""");
Параметры.Вставить("Кластер_Пароль" , "123");

Параметры.Вставить("Сервер_АдресПорт" , "Sport1:1541");

Параметры.Вставить("ИБ_Имя" , "DEV_User1_ACC_Cust1");
Параметры.Вставить("ИБ_Администратор" , """Пользователь И. Б.""");
Параметры.Вставить("ИБ_Пароль" , "123");

МакетПараметров = Новый Файл(ОбъединитьПути(ТекущийСценарий().Каталог, "ПараметрыТестирования.txt"));

Если НЕ МакетПараметров.Существует() Тогда
Возврат Параметры;
КонецЕсли;

ТекстМакета = Новый ТекстовыйДокумент();
ТекстМакета.Прочитать(МакетПараметров.ПолноеИмя, КодировкаТекста.UTF8);

Для й = 1 По ТекстМакета.КоличествоСтрок() Цикл
Параметр = СтрРазделить(ТекстМакета.ПолучитьСтроку(й), "=");

Если НЕ Параметр.Количество() = 2 Тогда
Продолжить;
КонецЕсли;

Попытка
Параметры.Вставить(СокрЛП(Параметр[0]), СокрЛП(Параметр[1]));
Исключение
Лог.Предупреждение("Ошибка чтения параметра """ + СокрЛП(Параметр[0]) + """: " + ОписаниеОшибки());
КонецПопытки;
КонецЦикла;

Возврат Параметры;

КонецФункции // Параметры()

// Функция преобразует переданный текст вывода команды в массив соответствий
// элементы массива создаются по блокам текста, разделенным пустой строкой
// пары <ключ, значение> структуры получаются для каждой строки с учетом разделителя ":"

0 comments on commit 88252d8

Please sign in to comment.
You can’t perform that action at this time.