Italian translation and localization of Mapgive: https://github.com/state-hiu/Mapgive
CSS JavaScript Shell
Switch branches/tags
Nothing to show
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
_assets
_includes
_layouts
a-proposito-open-mapping
domande-frequenti
impara-a-mappare
mappa-sito
perche-mappare
storie
trascrizioni
ulteriori-informazioni
.gitignore
.htaccess
404.html
Gruntfile.js
README.md
_config.yml
amara.html
build.sh
clean.sh
favicon.ico
humans.txt
index.html
package.json
robots.txt

README.md

MapgiveIT

English

A brief English description can be found at the bottom of this file.

Italiano

Questo repository contiene la versione in lingua italiana, tradotta ed adattata, del sito Mapgive installata qui http://mapgive.openstreetmap.it

Attribuzione

Mapgive è un progetto della Humanitarian Information Unit (HIU) del Dipartimento di Stato degli Stati Uniti d'America.

Il codice sorgente per il sito originale è disponibile sul repository Mapgive su Github.

È possibile leggere le informazioni di copyright per il sito originale a questo link] (in inglese)

Autori

La traduzione di MapgiveIT è stata effettuata da:

  • Cristian Consonni, Fondazione Bruno Kessler, Trento (TN) - Italy
  • Simone Cortesi
  • Stefano Sabatini
  • Maurizio Napolitano, Fondazione Bruno Kessler, Trento (TN) - Italy
  • Leonardo Frassetto
  • Giovanni Cascafico
  • Alessandro Palmas
  • Simone F. (Groppo)

Un ringraziamento va anche a tutti coloro i quali hanno segnalato errori e refusi e in particolare alla lista talk-it di OpenStreetMap ed alla Humanitarian Information Unit (HIU) del Dipartimento di Stato degli Stati Uniti per il supporto fornito durante la traduzione.

Istruzioni per lo sviluppo, la traduzione e la localizzazione

Se volete partecipare al miglioramento del sito potete forkare questo repository e mandare una pull request.

Di seguito troverete alcune informazioni utili.

Jekyll + Grunt

Il sito è costruito usando Jekyll e Grunt.

Le seguenti versioni permettono di costruire una build funzionante del sito:

  • ruby v2.1.0
  • jekyll v1.5.1
  • nodejs v0.10.15
  • grunt-cli v0.1.13
  • grunt v0.4.4
  • OptiPNG v0.7.5
  • jpegtran v1.2.0

Per installare Jekyll è necessario avere un'ambiente di sviluppo Ruby sulla propria macchina, in particolare si consiglia di installare RVM (Ruby Version Manager). Seguite queste istruzioni per installare RVM su Ubuntu e se aveste bisogno di approfondire potrete trovare ulteriori info su rvm.io.

Attenzione: la versione di Ruby che viene installata attraverso apt-get è vecchia. Seguite le istruzioni del post indicato sopra per installare una versione recente di Ruby. Potete rimuovere le vecchie versioni di Ruby installate tramite il sistema a pacchetti con apt-get purge --remove ruby*.

Quando avrete completato l'installazione di RVM potete installare Jekyll con:

gem install jekyll

Per installare Grunt avrete bisogno di Node.js e npm che possono essere installati su Ubuntu attraverso apt-get.

Attenzione: la versione di Node.js installata su versioni precedenti di Ubuntu (e.g. 12.04 LTS server) è troppo vecchia per poter essere usata, è necessario avere una versione di Node.js >= 0.8.0. Se la vostra versione è troppo vecchia rimuovetela (con apt-get purge --remove nodejs) e installate Node.js seguendo queste istruzioni.

Quindi è possibile installare tutti i moduli richiesti con il seguente comando.

npm install

Infine create una cartella per ospitare i backup del sito (verrà ignorata da git):

mkdir backup

Importante: nel caso ci si dimentichi di creare la cartella si riscontrerà un errore nell'esecuzione di Grunt simile al seguente:

Running "backupSite" task
Warning: ENOENT, no such file or directory 'backups/201464192549' Use --force to continue.

Aborted due to warnings.

per risolverlo basta creare la cartella backup nella radice del repository.

Dipendenze

Per potere eseguire i vari task di Grunt è necessario avere installato: OptiPNG e jpegtran.

Installare OptiPNG

La versione di OptiPNG presente nei repository di Ubuntu 13.10 non supporta un'opzione necessaria alla costruzione del sito.

È possibile scaricare la versione minima richiesta, v0.7.5, di OptiPNG dal sito del progetto su Sourceforge.

Dopodicché è possibile installare il programma con:

./configure
make
sudo make install

Installare jpegtran

È possibile installare jpegtran con il comando

sudo apt-get install libjpeg-progs

build.sh

Una volta installati quanto descritto sopra è possibile costruire il sito usando lo script build.sh:

./build.sh

Il sito verrà creato nella cartella _site, potete copiare quella cartella e servirla con il vostro webserver preferito.

Se volete testare le pagine, Jekyll mette a disposizione un comodo server di sviluppo attivabile lanciando, dalla radice del repository il seguente comando:

rvm use 2.1.0
jekyll serve

clean.sh

Lo script clean.sh rimuove le cartelle assets (temporanea) e _site:

./clean.sh

English

This repository contains the Italian translation and localization of the Mapgive website.

Credits

Mapgive is a project by the Humanitarian Information Unit (HIU) of the Department of State of the United States of America.

The source code for the original website is available on the Mapgive repository on Github.

Read the copyright info for the original website.

Authors

The following people have contributed to MapgiveIT:

  • Cristian Consonni, Fondazione Bruno Kessler, Trento (TN) - Italy
  • Simone Cortesi
  • Stefano Sabatini
  • Maurizio Napolitano, Fondazione Bruno Kessler, Trento (TN) - Italy
  • Leonardo Frassetto
  • Giovanni Cascafico
  • Alessandro Palmas
  • Simone F. (Groppo)

A special thank goes to everybody who contributed reporting bugs and misprints and in particular to the talk-it OpenStreetMap mailing list and to the Humanitarian Information Unit of the State Department of the United States of America for the assistance provided with the translation.

Development, localization and internationalization instructions

To participate in the development of the MapgiveIT website you can fork this repo and send a pull request.

You can find below some useful information.

Jekyll + Grunt

The website is built using Jekyll and Grunt.

The following software at the given versions allow to build a working version of the website:

  • ruby v2.1.0
  • jekyll v1.5.1
  • nodejs v0.10.15
  • grunt-cli v0.1.13
  • grunt v0.4.4
  • OptiPNG v0.7.5
  • jpegtran v1.2.0

To install Jekyll a Ruby you'll need to have a working Ruby development environment on your workstation. This is provided installing RVM (Ruby Version Manager). Please follow these instructions to install RVM on Ubuntu if you need more info you can visit the site rvm.io.

Warning: the Ruby version installed with apt-get is very old. If you have already installed an old version of Ruby through the package manager you can remove it with apt-get purge --remove ruby. Install a recent version of Ruby following the instructions in the aforementioned post.

Upon completing the installation of RVM you can install Jekyll with:

gem install jekyll

To install Grunt you need Node.js and npm that can be installed on Ubuntu system using the apt-get package manager.

Warning: the Node.js version which is shipped with the previous releases of Ubuntu (e.g. 12.04 LTS server) is too old, you need a version of Node.js >= 0.8.0. If you have already installed an old version of Node.js you can remove it (with apt-get purge --remove nodejs) and install a newer version following these instructions.

Once you have Node.js and npm you can install all the requested modules with the following command:

npm install

Create a directory to host the backups for the website (it will be ignore by git):

mkdir backup

Important: if you forget to create the directory you will receive an error like this when executing Grunt:

Running "backupSite" task
Warning: ENOENT, no such file or directory 'backups/201464192549' Use --force to continue.

Aborted due to warnings.

to solve it just create the backup directory in the repository root.

Dependencies

To execute all the Grunt task you need to have the following two software installed in your system: OptiPNG and jpegtran.

Installing OptiPNG

The OptiPNG version available in the Ubuntu 13.10 repositories does not support an option which is needed to build the site.

You can download and install the minimum required version, v0.7.5, of OptiPNG from the project site on Sourceforge.

You can install it with:

./configure
make
sudo make install

Installing jpegtran

You can install jpegtran with

sudo apt-get install libjpeg-progs

build.sh

This repo contains a simple script, build.sh, to build the site:

./build.sh

The website will be build in the _site directory, you can then copy this folder and serve it using your favorite webserver.

If you want to test the pages, Jekyll provides a simple development webserver which can be activated launching the following command from the repo root:

rvm use 2.1.0
jekyll serve

clean.sh

The script clean.sh removes the assets (temporary) and _site directories. Launch it with:

./clean.sh