Skip to content
Permalink
Browse files

bug/#1265 - switching to mapsforge 0.10.0 (from 0.8.0)

Impacted files:
* `MapsForgeTileSource.java`: removed the call to `ReadBuffer.setMaximumBufferSize` in `createInstance`
* `osmdroid-mapsforge/build.gradle`: now using version `0.10.0` of mapsforge
  • Loading branch information...
monsieurtanuki committed Feb 20, 2019
1 parent c622325 commit 48e5618becd9b67d827c996c3cdacaf9db4a320f
@@ -37,9 +37,9 @@ dependencies {
testCompile "junit:junit:${project.property('junit.version')}"

//Mapsforge rendering and database support, which is LGPL
compile 'org.mapsforge:mapsforge-map-android:0.8.0'
compile 'org.mapsforge:mapsforge-map:0.8.0'
compile 'org.mapsforge:mapsforge-themes:0.8.0'
compile 'org.mapsforge:mapsforge-map-android:0.10.0'
compile 'org.mapsforge:mapsforge-map:0.10.0'
compile 'org.mapsforge:mapsforge-themes:0.10.0'

//osmdroid which is ASF licensed
compile project(':osmdroid-android')
@@ -208,9 +208,6 @@ public synchronized Drawable renderTile(final long pMapTileIndex) {

public static void createInstance(Application app) {
AndroidGraphicFactory.createInstance(app);

// see https://github.com/mapsforge/mapsforge/issues/868
ReadBuffer.setMaximumBufferSize(6500000);
}


0 comments on commit 48e5618

Please sign in to comment.
You can’t perform that action at this time.