Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
@legastero legastero
104 lines (103 sloc) 2.383 kb
{
"name": "stanza.io",
"description": "Modern XMPP in the browser, with a JSON API",
"version": "7.2.0",
"author": "Lance Stout <lance@andyet.net>",
"browser": {
"request": "xhr",
"faye-websocket": false,
"./lib/plugins/index.js": "./lib/plugins/index-browser.js"
},
"browserify": {
"transform": [
[
"browserify-versionify",
{
"placeholder": "__STANZAIO_VERSION__"
}
]
]
},
"bugs": "https://github.com/otalk/stanza.io/issues",
"contributors": [
"Philipp Hancke <fippo@andyet.net>",
"Steven Lloyd Watkin <lloyd@evilprofessor.co.uk>"
],
"dependencies": {
"alt-sasl-digest-md5": "^1.0.0",
"async": "^0.9.0",
"bluebird": "^2.3.2",
"browserify-versionify": "^1.0.4",
"faye-websocket": "^0.9.0",
"hostmeta": "^2.0.0",
"iana-hashes": "^1.0.2",
"jingle": "^1.5.1",
"jxt": "^3.0.1",
"jxt-xmpp-types": "^2.1.0",
"lodash.assign": "^3.0.0",
"lodash.filter": "^3.1.0",
"lodash.foreach": "^3.0.2",
"lodash.isarray": "^3.0.1",
"lodash.uniq": "^3.1.0",
"request": "^2.53.0",
"sasl-anonymous": "^0.1.0",
"sasl-external": "^0.1.0",
"sasl-plain": "^0.1.0",
"sasl-scram-sha-1": "^1.1.0",
"saslmechanisms": "^0.1.1",
"uuid": "^2.0.1",
"wildemitter": "^1.0.1",
"xhr": "^2.0.1",
"xmpp-jid": "^1.0.0"
},
"devDependencies": {
"browserify": "^9.0.0",
"jshint": "^2.6.3",
"make-better": "^0.4.1",
"nsp": "^1.0.0",
"precommit-hook": "^2.0.0",
"tap-spec": "^2.0.0",
"tape": "^3.0.3",
"uglify-js": "^2.4.15"
},
"homepage": "http://stanza.io",
"keywords": [
"XMPP",
"xmpp",
"websocket",
"stanza",
"json",
"bosh",
"stanza.io",
"otalk",
"jingle"
],
"license": "MIT",
"main": "./index.js",
"repository": {
"type": "git",
"url": "https://github.com/otalk/stanza.io.git"
},
"scripts": {
"audit": "make audit",
"build": "make build",
"test": "make test"
},
"testling": {
"files": [
"test/connection.js"
],
"browsers": [
"ie/10..latest",
"chrome/20..latest",
"chrome/canary",
"firefox/10..latest",
"firefox/nightly",
"opera/next",
"safari/6..latest",
"iphone/6..latest",
"ipad/6..latest",
"android-browser/4.2..latest"
]
}
}
Jump to Line
Something went wrong with that request. Please try again.