Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Which version stays with lua-5.1? #277

Open
hungshihhan opened this issue Dec 19, 2019 · 1 comment
Open

Which version stays with lua-5.1? #277

hungshihhan opened this issue Dec 19, 2019 · 1 comment

Comments

@hungshihhan
Copy link

@hungshihhan hungshihhan commented Dec 19, 2019

I am trying to install ipe with my gentoo machine. However, currently lua-5.3 is masked (https://packages.gentoo.org/packages/dev-lang/lua) and many packages still use lua-5.1. There does not seem an easy way to upgrade it to 5.3. Which version of ipe should I use to avoid heavy upgrades?

@otfried

This comment has been minimized.

Copy link
Owner

@otfried otfried commented Dec 20, 2019

You'll have to go quite far back: Ipe 7.1.3 from early 2013. I really cannot recommend that.

Why don't you simply compile a private copy of Lua 5.3 and use that to compile Ipe yourself?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.