Skip to content
This repository has been archived by the owner. It is now read-only.

OC5: Editing a Contact Breaks the Umlauts (temporarily) #970

Closed
ccoenen opened this issue Apr 8, 2013 · 8 comments

Comments

@ccoenen
Copy link

commented Apr 8, 2013

I have contacts with german umlauts in them. Let's call them "Hubert Müller" for now.

After i edit a contact (adding an address, not even touching the name), the name will display as "Hubert Müller" in the Contact list. Re-Opening the Edit-Form will display the name correctly there (but only there, not in the list). I have no way to fix this contact afterwards.

This Issue happened with OwnCloud 5.0.3 and Contacts (also 5.0.3)

Expected behaviour

The name in the list should display normally i.e. "Hubert Müller"

Actual behaviour

The name containing the umlaut will show up with html-entities. i.e. "Hubert Müller"

Steps to reproduce

  1. Have a contact with Umlaut in the name
  2. Click it, so the edit form shows up
  3. Alter something (i added a private address, but this shouldn't matter)
  4. Close to save it
  5. Look at the entry in the list.

Server configuration

Operating system:
Debian 6.0.7

Web server:
Apache (from debian packages)

Database:
MySQL (from debian packages)

PHP version:
5.3.3-7 (you guessed it: debian package)

ownCloud version:
5.0.3

Client configuration

Browser:
Firefox 19.0.2

Operating system:
Windows 7

Logs

currently no logs. Sorry.

@ccoenen

This comment has been minimized.

Copy link
Author

commented Apr 8, 2013

This problem is not permanent, so you don't acually lose any data.

After Reloading the page, the characters are back to normal. Just switching to a different contact-group won't help!

@ccoenen

This comment has been minimized.

Copy link
Author

commented Apr 8, 2013

I'd tag it app:contacts and bug, but i don't know how. I guess, tagging is just for the project owners.

@tanghus

This comment has been minimized.

Copy link
Contributor

commented Apr 8, 2013

Thanks. Fixed in 5.0.4.

@ccoenen

This comment has been minimized.

Copy link
Author

commented Apr 9, 2013

That's 34 minutes from my first (pretty awkward, i edited it later) ticket to your commit.

Hats off to you, that's pretty amazing! Thanks!

@tanghus

This comment has been minimized.

Copy link
Contributor

commented Apr 9, 2013

We aim to please 😄

@schwantuschke

This comment has been minimized.

Copy link

commented Apr 11, 2013

I had update from 5.0.3 to 5.0.4 and my existing contacts with Umlauts have now wrong coding like ä for ä.
if i create a new contact than the new contact its ok.
The problem its only in the webinterface. I have no problems with the iPhone with CardDav.
in opera 12.14 its everything ok. in firefox 20.0 I see the problem

@tanghus

This comment has been minimized.

Copy link
Contributor

commented Apr 11, 2013

@foomep

now wrong coding like ä for ä.

It looks all right to me ;)

Try to Shift-reload your browser.

@schwantuschke

This comment has been minimized.

Copy link

commented Apr 11, 2013

ohh. its great. it works now. thanks

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
3 participants
You can’t perform that action at this time.