Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Windows] Windows client lost network, never recovers #3969

Closed
robert128 opened this issue Oct 19, 2015 · 47 comments

Comments

@robert128
Copy link

commented Oct 19, 2015

Hello,

I've found that my Windows client [2.0.1 (build 5446)] never recovers from a lost network. When I move my laptop off it's dock, it doesn't connect to the wireless network. Immediately, my ownCloud client says "No connection at ..., SSL handshake failed" When I put my machine back on its dock which reconnects the network, the error doesn't go away. I have to kill the client and restart it to get it functioning again. I don't recall every seeing this behavior before updating to 2.0.1.

If there's a settings fix for this, I'd appreciate it. Otherwise it looks like a bug to me.

Server is 8.0.4, laptop is Windows 7.

Thanks

@guruz

This comment has been minimized.

Copy link
Collaborator

commented Oct 19, 2015

@robert128 What is your current proxy setting in the client?
Is it "system proxy"? What if you turn the setting off?

Did you sleep/hibernate/close-lid the machine in between?

@guruz guruz changed the title Windows client lost network failure [Windows] Windows client lost network, never recovers Oct 19, 2015

@guruz guruz added this to the 2.1-next milestone Oct 19, 2015

@guruz guruz added the bug label Oct 19, 2015

@robert128

This comment has been minimized.

Copy link
Author

commented Oct 19, 2015

I uninstalled version 2.0.1, reinstalled 1.8.4, found out it gets stuck in discovery, then reinstalled 2.0.1. Before I ran your test, I tried reproducing the error, but this time the client logged back into the server. I had reinstalled 2.0.1 before, so didn't expect this to solve the problem, but hope it did. With a sudden network failure, again the client recovered.

To answer, I have "system proxy" set (must be the default). My machine didn't go to sleep in between connecting to the network.

I'd been having problems for weeks, so if I see another failure, I'll write back.

Thanks

@guruz guruz added the Needs info label Oct 21, 2015

@guruz guruz modified the milestones: 2.2-next, 2.1-next Oct 21, 2015

@robert128

This comment has been minimized.

Copy link
Author

commented Oct 21, 2015

This issue has returned. I've moved my machine from one location to another, putting it to sleep between locations, and found that when the network doesn't exist at the new location, the ownCloud client won't recover when the network returns. I've done this both with the system proxy and without, same failure.

I also disconnected my machine from the network (but kept it awake) while setting proxy to no proxy, and when I connected to the network, the client still says it's disconnected. So it looks like this problem really exists.

@guruz guruz removed the Needs info label Oct 22, 2015

@robert128

This comment has been minimized.

Copy link
Author

commented Oct 29, 2015

I updated to the 2.0.2 client, but still have this problem.

@guruz guruz modified the milestones: 2.1-next, 2.2-next Oct 30, 2015

@guruz guruz self-assigned this Nov 3, 2015

@guruz

This comment has been minimized.

Copy link
Collaborator

commented Nov 3, 2015

@ThomasLeister I think you commented on the wrong issue, maybe you can have a look to comment on #3888 and delete your comment here. Please also tell there your Qt version (from the client settings dialog)

@ThomasLeister

This comment has been minimized.

Copy link

commented Nov 3, 2015

Thx for the hint, guruz! I moved my comment.

@guruz

This comment has been minimized.

Copy link
Collaborator

commented Nov 3, 2015

@robert128 Is there a specific error message visible in the client settings dialog? It would be good if you can tell us that message.
(I mean after the "No connection at ..., SSL handshake failed" message when you put it into the dock or similar?)

@robert128

This comment has been minimized.

Copy link
Author

commented Nov 3, 2015

I'd be happy to tell you what it says, but I don't know where the settings dialog is. The client has 4 tabs, the folder selection, activity, general (and settings), and network. Would it be something under one of these?

@guruz

This comment has been minimized.

Copy link
Collaborator

commented Nov 4, 2015

The message should be on the folder selection tab

@robert128

This comment has been minimized.

Copy link
Author

commented Nov 4, 2015

The only message I see on that tab is "No connection to ownCloud at https://... Host not found

When I open the log window, here is what it says:

11-04 12:36:27:954 0x4689b90 OCC::AccountState::checkConnectivity: ConnectionValidator already running, ignoring
11-04 12:36:59:963 0x4689b90 OCC::AccountState::checkConnectivity: ConnectionValidator already running, ignoring

@guruz

This comment has been minimized.

Copy link
Collaborator

commented Nov 6, 2015

Similar issues:
#3776 @MegaV0lt
#3476
#2899 @MegaV0lt

@guruz

This comment has been minimized.

Copy link
Collaborator

commented Nov 6, 2015

@robert128 Did you see anything in the log with Network access is disabled or QDisabledNetworkReply ?

@guruz

This comment has been minimized.

Copy link
Collaborator

commented Nov 6, 2015

@dragotin @danimo For our 5.4+x on Windows we're missing two patches that could probably fix this:

5.5.1 c056e63cea1915667997c982f48296ce5acdcc80 QTBUG-46323 Make sure to report correct NetworkAccessibility

5.5.BRANCH bb281eea179d50a413f4ec1ff172d27ee48d3a41 QTBUG-46323 Make sure networkAccessibilityChanged is emitted (recommended and proven to work for #4051 #3888 )

@guruz

This comment has been minimized.

Copy link
Collaborator

commented Nov 10, 2015

@robert128 Could you try this build of the 2.1 client? We have those Qt patches applied now
http://download.owncloud.com/desktop/daily/ownCloud-2.1.0.5615-nightly20151110-setup.exe

(As usual note that 2.1 is in alpha/beta quality).

@robert128

This comment has been minimized.

Copy link
Author

commented Nov 10, 2015

This version isn't working for me at all. I've been connected all morning, but ownCloud doesn't think so. Here's my log:

11-10 12:21:32:000 0x3d9a80 OCC::FolderWatcher::pathIsIgnored: * Ignoring file "C:/Users/.../ownCloud/.csync_journal.db-shm"
11-10 12:21:32:001 0x3d9a80 OCC::Account::resetNetworkAccessManager: Resetting QNAM
11-10 12:21:32:001 0x3d9a80 OCC::ConnectionValidator::checkServerAndAuth: Checking server and authentication
11-10 12:21:32:002 0x3d9a80 OCC::ConnectionValidator::checkServerAndAuth: Trying to look up system proxy
11-10 12:21:32:020 0x3d9a80 OCC::SocketApi::slotNewConnection: SocketApi: New connection QLocalSocket(0x73d50e8)
11-10 12:21:32:020 0x3d9a80 OCC::SocketApi::sendMessage: SocketApi: Sending message: "REGISTER_PATH:C:\Users...\ownCloud"
11-10 12:21:32:021 0x3d9a80 OCC::SocketApi::slotNewConnection: SocketApi: New connection QLocalSocket(0x73d5258)
11-10 12:21:32:021 0x3d9a80 OCC::SocketApi::sendMessage: SocketApi: Sending message: "REGISTER_PATH:C:\Users...\ownCloud"
11-10 12:21:32:002 0x7b7f9c0 OCC::SystemProxyRunnable::run: virtual void OCC::SystemProxyRunnable::run() Starting system proxy lookup
11-10 12:21:34:293 0x3d9a80 OCC::ConnectionValidator::systemProxyLookupDone: void OCC::ConnectionValidator::systemProxyLookupDone(const QNetworkProxy&) Setting QNAM proxy to be system proxy "2://:0"
11-10 12:21:34:294 0x3d9a80 OCC::AbstractNetworkJob::start: !!! OCC::CheckServerJob created for "https://space..." + "status.php"
11-10 12:21:34:295 0x3d9a80 OCC::AbstractNetworkJob::slotFinished: void OCC::AbstractNetworkJob::slotFinished() 99 "Network access is disabled." QVariant(Invalid)
11-10 12:21:34:295 0x3d9a80 OCC::ConnectionValidator::slotNoStatusFound: void OCC::ConnectionValidator::slotNoStatusFound(QNetworkReply_) 99 "Network access is disabled."
11-10 12:21:34:295 0x3d9a80 OCC::AccountState::slotConnectionValidatorResult: AccountState connection status change: "Undefined" -> "Status not found"
11-10 12:21:34:295 0x3d9a80 OCC::AccountState::setState: AccountState state change: "Disconnected" -> "Network error"
11-10 12:21:34:296 0x3d9a80 OCC::AccountSettings::showConnectionLabel: "No connection to ownCloud at https://space.....
Network access is disabled."
11-10 12:21:34:297 0x3d9a80 OCC::FolderMan::slotAccountStateChanged: Account "...@space..." disconnected, terminating or descheduling sync folders
11-10 12:21:34:298 0x3d9a80 unknown: QIODevice::read: device not open
11-10 12:21:34:298 0x3d9a80 OCC::CheckServerJob::finished: error: status.php replied 0 ""
11-10 12:21:35:001 0x3d9a80 OCC::OCUpdater::backgroundCheckForUpdate: virtual void OCC::OCUpdater::backgroundCheckForUpdate() checking for available update
11-10 12:21:35:002 0x3d9a80 OCC::OCUpdater::slotVersionInfoArrived: Failed to reach version check url: "Network access is disabled."
11-10 12:21:57:075 0x3d9a80 OCC::ownCloudGui::slotShowSettings: void OCC::ownCloudGui::slotShowSettings()
11-10 12:21:57:077 0x3d9a80 unknown: Failed to resolve EGL function eglGetPlatformDisplayEXT (The specified procedure could not be found.)
11-10 12:21:57:079 0x3d9a80 unknown: static QWindowsEGLStaticContext_ QWindowsEGLStaticContext::create(): Could not initialize EGL display: error 0x3001

11-10 12:21:57:079 0x3d9a80 unknown: static QWindowsEGLStaticContext* QWindowsEGLStaticContext::create(): When using ANGLE, check if d3dcompiler_4x.dll is available
11-10 12:22:04:000 0x3d9a80 OCC::Account::resetNetworkAccessManager: Resetting QNAM
11-10 12:22:04:001 0x3d9a80 OCC::ConnectionValidator::checkServerAndAuth: Checking server and authentication
11-10 12:22:04:001 0x3d9a80 OCC::ConnectionValidator::checkServerAndAuth: Trying to look up system proxy
11-10 12:22:04:002 0x7b7f9c0 OCC::SystemProxyRunnable::run: virtual void OCC::SystemProxyRunnable::run() Starting system proxy lookup
11-10 12:22:04:003 0x3d9a80 OCC::ConnectionValidator::systemProxyLookupDone: void OCC::ConnectionValidator::systemProxyLookupDone(const QNetworkProxy&) Setting QNAM proxy to be system proxy "2://:0"
11-10 12:22:04:003 0x3d9a80 OCC::AbstractNetworkJob::start: !!! OCC::CheckServerJob created for "https://space...." + "status.php"
11-10 12:22:04:004 0x3d9a80 OCC::AbstractNetworkJob::slotFinished: void OCC::AbstractNetworkJob::slotFinished() 99 "Network access is disabled." QVariant(Invalid)
11-10 12:22:04:004 0x3d9a80 OCC::ConnectionValidator::slotNoStatusFound: void OCC::ConnectionValidator::slotNoStatusFound(QNetworkReply*) 99 "Network access is disabled."
11-10 12:22:04:004 0x3d9a80 OCC::AccountSettings::showConnectionLabel: "No connection to ownCloud at https://space....
Network access is disabled."
11-10 12:22:04:010 0x3d9a80 OCC::FolderMan::slotAccountStateChanged: Account "...@space..." disconnected, terminating or descheduling sync folders
11-10 12:22:04:010 0x3d9a80 unknown: QIODevice::read: device not open
11-10 12:22:04:011 0x3d9a80 OCC::CheckServerJob::finished: error: status.php replied 0 "

@MegaV0lt

This comment has been minimized.

Copy link

commented Nov 14, 2015

ater 15 minutes it has connection:
Image of Yaktocat
but the mentioned hidden file is not hidden
log https://dl.dropboxusercontent.com/u/1490505/oc/sync.-log2.txt

@guruz

This comment has been minimized.

Copy link
Collaborator

commented Nov 16, 2015

@MegaV0lt But it does recover after all?
The 15 minutes are still odd though.

The "hidden" file is seen as hidden because it starts with a dot (which signals hidden files on Linux/OSX).. In the ignore/exclude settings you can enable syncing of hidden files.
FYI @dragotin

@guruz

This comment has been minimized.

Copy link
Collaborator

commented Nov 16, 2015

@robert128 Are you sure you're on the version I had mentioned? Maybe you can check the settings dialog for the build number?
Did you also have to wait 15 minutes?

@MegaV0lt

This comment has been minimized.

Copy link

commented Nov 16, 2015

@guruz The 15 minutes delay you can see in the last screenshot. There is nothing between 08:02 and 08:17 !

Problem is, that in windows the dot noes not mean hidden! What happens with REAL hidden files from Windows in Linux client? Do the get added a "."?

@robert128

This comment has been minimized.

Copy link
Author

commented Nov 16, 2015

Build 5619. I let the client sit for hours, entire days sometimes.

guruz added a commit that referenced this issue Nov 17, 2015

@guruz

This comment has been minimized.

Copy link
Collaborator

commented Nov 17, 2015

OK, I did another attempt now, see patch above. It works fine for me, I get reconnected after ~1 min in my Windows 8 VM.

http://download.owncloud.com/desktop/daily/ownCloud-2.1.0.5632-nightly20151117-setup.exe

@robert128 @MegaV0lt let's hope the best this time.

@robert128

This comment has been minimized.

Copy link
Author

commented Nov 19, 2015

I tried it out today; unfortunately, it isn't working on this machine. Don't know why this machine is so stubborn!

11-18 16:58:04:446 0x5b7ef88 OCC::AccountState::checkConnectivity: ConnectionValidator already running, ignoring "user@space..."

@MegaV0lt

This comment has been minimized.

Copy link

commented Nov 19, 2015

Looks good here except the log:

11-19 08:25:40:061 0x795e268 unknown: void QHttpNetworkConnectionChannel::_q_error(QAbstractSocket::SocketError) QAbstractSocket::RemoteHostClosedError QSslSocket(0x739c7f8) QObject(0x0)  0 false 3 0 QAbstractSocket::ConnectedState
11-19 08:25:40:062 0x795e268 unknown: void QHttpNetworkConnectionChannel::_q_disconnected() 0 QSslSocket(0x739c7f8) QObject(0x0)  0 false 3 0
11-19 08:25:55:049 0x44ade58 OCC::Folder::slotRunEtagJob: * Trying to check "ownCloud" for changes via ETag check. (time since last sync: 1095 s)
11-19 08:25:55:067 0x44ade58 OCC::FolderMan::slotRunOneEtagJob: Scheduling "ownCloud" to check remote ETag
11-19 08:25:55:069 0x44ade58 OCC::AbstractNetworkJob::start: !!! OCC::RequestEtagJob created for "https://.../owncloud" + ""
11-19 08:25:55:233 0x44ade58 OCC::Folder::etagRetreived: * Compare etag with previous etag: last: ""564c339db826d"" , received: ""564c339db826d""
11-19 08:25:55:236 0x44ade58 OCC::FolderMan::slotRunOneEtagJob: No more remote ETag check jobs to schedule.
11-19 08:26:00:234 0x795e268 unknown: void QHttpNetworkConnectionChannel::_q_error(QAbstractSocket::SocketError) QAbstractSocket::RemoteHostClosedError QSslSocket(0x739c7f8) QObject(0x0)  0 false 3 0 QAbstractSocket::ConnectedState
11-19 08:26:00:235 0x795e268 unknown: void QHttpNetworkConnectionChannel::_q_disconnected() 0 QSslSocket(0x739c7f8) QObject(0x0)  0 false 3 0
@noliveira87

This comment has been minimized.

Copy link

commented Nov 20, 2015

@guruz I tried this last version in Windows 8.1 and I receive the following error:

11-20 10:53:17:049 0x43f7b10 OCC::AccountState::checkConnectivity: ConnectionValidator already running, ignoring "noliveira@domain"
11-20 10:53:49:052 0x43f7b10 OCC::AccountState::checkConnectivity: ConnectionValidator already running, ignoring "noliveira@domain"
11-20 10:54:21:045 0x43f7b10 OCC::AccountState::checkConnectivity: ConnectionValidator already running, ignoring "noliveira@domain"
11-20 10:54:53:055 0x43f7b10 OCC::AccountState::checkConnectivity: ConnectionValidator already running, ignoring "noliveira@domain"

If you need to test something else, say it.

@guruz

This comment has been minimized.

Copy link
Collaborator

commented Nov 20, 2015

@noliveira87 @robert128 What is relevant are the messages before that. Why would the ConnectioValidator be running but never error out or timeout?

@noliveira87

This comment has been minimized.

Copy link

commented Nov 20, 2015

@guruz here is the log after lost the connection to server:


11-20 17:42:54:624 0x8b79f8 OCC::Folder::slotRunEtagJob: * Trying to check "ownCloud" for changes via ETag check. (time since last sync: 146 s)
11-20 17:42:54:625 0x8b79f8 OCC::FolderMan::slotRunOneEtagJob: Scheduling "ownCloud" to check remote ETag
11-20 17:42:54:626 0x8b79f8 OCC::AbstractNetworkJob::start: !!! OCC::RequestEtagJob created for "https://owncloud.domain" + "/"
11-20 17:42:54:744 0x8b79f8 OCC::Folder::etagRetreived: * Compare etag with previous etag: last: ""564e6a7a616c3"" , received: ""564e6a7a616c3""
11-20 17:42:54:749 0x8b79f8 OCC::FolderMan::slotRunOneEtagJob: No more remote ETag check jobs to schedule.
11-20 17:42:59:747 0x74425e0 unknown: void QHttpNetworkConnectionChannel::_q_error(QAbstractSocket::SocketError) QAbstractSocket::RemoteHostClosedError QSslSocket(0x7442590) QObject(0x0)  0 false 3 0 QAbstractSocket::ConnectedState
11-20 17:42:59:747 0x74425e0 unknown: void QHttpNetworkConnectionChannel::_q_disconnected() 0 QSslSocket(0x7442590) QObject(0x0)  0 false 3 0
11-20 17:43:05:049 0x8b79f8 OCC::ConnectionValidator::checkAuthentication: # Check whether authenticated propfind works.
11-20 17:43:05:051 0x8b79f8 OCC::AbstractNetworkJob::start: !!! OCC::PropfindJob created for "https://owncloud.domain" + "/"
11-20 17:43:07:797 0x8b79f8 OCC::AbstractNetworkJob::start: !!! OCC::PropfindJob created for "https://owncloud.domain" + "/"
11-20 17:43:12:873 0x74425e0 unknown: void QHttpNetworkConnectionChannel::_q_error(QAbstractSocket::SocketError) QAbstractSocket::RemoteHostClosedError QSslSocket(0x7442590) QObject(0x0)  0 false 3 0 QAbstractSocket::ConnectedState
11-20 17:43:12:873 0x74425e0 unknown: void QHttpNetworkConnectionChannel::_q_disconnected() 0 QSslSocket(0x7442590) QObject(0x0)  0 false 3 0
11-20 17:43:24:620 0x8b79f8 OCC::Folder::slotRunEtagJob: * Trying to check "ownCloud" for changes via ETag check. (time since last sync: 176 s)
11-20 17:43:24:620 0x8b79f8 OCC::FolderMan::slotRunOneEtagJob: Scheduling "ownCloud" to check remote ETag
11-20 17:43:24:620 0x8b79f8 OCC::AbstractNetworkJob::start: !!! OCC::RequestEtagJob created for "https://owncloud.domain" + "/"
11-20 17:43:24:745 0x8b79f8 OCC::Folder::etagRetreived: * Compare etag with previous etag: last: ""564e6a7a616c3"" , received: ""564e6a7a616c3""
11-20 17:43:24:745 0x8b79f8 OCC::FolderMan::slotRunOneEtagJob: No more remote ETag check jobs to schedule.
11-20 17:43:29:827 0x74425e0 unknown: void QHttpNetworkConnectionChannel::_q_error(QAbstractSocket::SocketError) QAbstractSocket::RemoteHostClosedError QSslSocket(0x7442590) QObject(0x0)  0 false 3 0 QAbstractSocket::ConnectedState
11-20 17:43:29:827 0x74425e0 unknown: void QHttpNetworkConnectionChannel::_q_disconnected() 0 QSslSocket(0x7442590) QObject(0x0)  0 false 3 0
11-20 17:43:37:055 0x8b79f8 OCC::ConnectionValidator::checkAuthentication: # Check whether authenticated propfind works.
11-20 17:43:37:055 0x8b79f8 OCC::AbstractNetworkJob::start: !!! OCC::PropfindJob created for "https://owncloud.domain" + "/"
11-20 17:43:37:086 0x74425e0 unknown: void QHttpNetworkConnectionChannel::_q_error(QAbstractSocket::SocketError) QAbstractSocket::NetworkError QSslSocket(0x7442590) QObject(0x0)  0 false 3 1 QAbstractSocket::UnconnectedState
11-20 17:43:37:086 0x74425e0 unknown: ERRORING OTHER QHttpNetworkReply(0x7571790)  QUrl( "https://owncloud.domain/remote.php/webdav/" ) 
11-20 17:43:37:895 0x8b79f8 OCC::AbstractNetworkJob::start: !!! OCC::PropfindJob created for "https://owncloud.domain" + "/"
11-20 17:43:37:926 0x74425e0 unknown: void QHttpNetworkConnectionChannel::_q_error(QAbstractSocket::SocketError) QAbstractSocket::NetworkError QSslSocket(0x7442590) QObject(0x0)  0 false 3 1 QAbstractSocket::UnconnectedState
11-20 17:43:37:926 0x74425e0 unknown: ERRORING OTHER QHttpNetworkReply(0x75718c8)  QUrl( "https://owncloud.domain/remote.php/webdav/" ) 
11-20 17:43:54:623 0x8b79f8 OCC::Folder::slotRunEtagJob: * Trying to check "ownCloud" for changes via ETag check. (time since last sync: 206 s)
11-20 17:43:54:626 0x8b79f8 OCC::FolderMan::slotRunOneEtagJob: Scheduling "ownCloud" to check remote ETag
11-20 17:43:54:627 0x8b79f8 OCC::AbstractNetworkJob::start: !!! OCC::RequestEtagJob created for "https://owncloud.domain" + "/"
11-20 17:43:54:634 0x74425e0 unknown: void QHttpNetworkConnectionChannel::_q_error(QAbstractSocket::SocketError) QAbstractSocket::HostNotFoundError QSslSocket(0x7442590) QObject(0x0)  0 false 3 1 QAbstractSocket::UnconnectedState
11-20 17:43:54:634 0x74425e0 unknown: ERRORING OTHER QHttpNetworkReply(0x75717c0)  QUrl( "https://owncloud.domain/remote.php/webdav/" ) 
11-20 17:43:54:637 0x8b79f8 OCC::AbstractNetworkJob::slotFinished: void OCC::AbstractNetworkJob::slotFinished() 3 "Servidor owncloud.domain não encontrado" QVariant(Invalid)
11-20 17:43:54:643 0x8b79f8 OCC::FolderMan::slotRunOneEtagJob: No more remote ETag check jobs to schedule.
11-20 17:44:09:056 0x8b79f8 OCC::AccountState::checkConnectivity: ConnectionValidator already running, ignoring "noliveira@domain"
11-20 17:44:24:620 0x8b79f8 OCC::Folder::slotRunEtagJob: * Trying to check "ownCloud" for changes via ETag check. (time since last sync: 236 s)
11-20 17:44:24:620 0x8b79f8 OCC::FolderMan::slotRunOneEtagJob: Scheduling "ownCloud" to check remote ETag
11-20 17:44:24:620 0x8b79f8 OCC::AbstractNetworkJob::start: !!! OCC::RequestEtagJob created for "https://owncloud.domain" + "/"
11-20 17:44:24:620 0x74425e0 unknown: void QHttpNetworkConnectionChannel::_q_error(QAbstractSocket::SocketError) QAbstractSocket::HostNotFoundError QSslSocket(0x7442590) QObject(0x0)  0 false 3 1 QAbstractSocket::UnconnectedState
11-20 17:44:24:620 0x74425e0 unknown: ERRORING OTHER QHttpNetworkReply(0x762f890)  QUrl( "https://owncloud.domain/remote.php/webdav/" ) 
11-20 17:44:24:620 0x8b79f8 OCC::AbstractNetworkJob::slotFinished: void OCC::AbstractNetworkJob::slotFinished() 3 "Servidor owncloud.domain não encontrado" QVariant(Invalid)
11-20 17:44:24:635 0x8b79f8 OCC::FolderMan::slotRunOneEtagJob: No more remote ETag check jobs to schedule.
11-20 17:44:41:054 0x8b79f8 OCC::AccountState::checkConnectivity: ConnectionValidator already running, ignoring "noliveira@domain"
11-20 17:44:54:626 0x8b79f8 OCC::Folder::slotRunEtagJob: * Trying to check "ownCloud" for changes via ETag check. (time since last sync: 266 s)
11-20 17:44:54:626 0x8b79f8 OCC::FolderMan::slotRunOneEtagJob: Scheduling "ownCloud" to check remote ETag
11-20 17:44:54:626 0x8b79f8 OCC::AbstractNetworkJob::start: !!! OCC::RequestEtagJob created for "https://owncloud.domain" + "/"
11-20 17:44:54:626 0x74425e0 unknown: void QHttpNetworkConnectionChannel::_q_error(QAbstractSocket::SocketError) QAbstractSocket::HostNotFoundError QSslSocket(0x7442590) QObject(0x0)  0 false 3 1 QAbstractSocket::UnconnectedState
11-20 17:44:54:626 0x74425e0 unknown: ERRORING OTHER QHttpNetworkReply(0x7571838)  QUrl( "https://owncloud.domain/remote.php/webdav/" ) 
11-20 17:44:54:642 0x8b79f8 OCC::AbstractNetworkJob::slotFinished: void OCC::AbstractNetworkJob::slotFinished() 3 "Servidor owncloud.domain não encontrado" QVariant(Invalid)
11-20 17:44:54:642 0x8b79f8 OCC::FolderMan::slotRunOneEtagJob: No more remote ETag check jobs to schedule.
@guruz

This comment has been minimized.

Copy link
Collaborator

commented Nov 23, 2015

To be honest I really suspect your network is the cause here, see also the discussion on #4097 (comment)
Are you sure you can access websites on the browser?

@noliveira87

This comment has been minimized.

Copy link

commented Nov 23, 2015

Ok. I will test better this question at night.

@guruz

This comment has been minimized.

Copy link
Collaborator

commented Nov 23, 2015

Implemented a faster reconnect when the network interface reconnects as part of http://download.owncloud.com/desktop/daily/ownCloud-2.1.0.5648-nightly20151123-setup.exe

@noliveira87

This comment has been minimized.

Copy link

commented Nov 24, 2015

@guruz I tested that version.

I start the client without access to Owncloud server and after connect to network that I have access nothing changes in log, and the client still without connection.

11-24 00:35:40:543 0x6a7b08 OCC::AccountState::checkConnectivity: ConnectionValidator already running, ignoring "noliveira@owncloud.domain"
11-24 00:36:12:544 0x6a7b08 OCC::AccountState::checkConnectivity: ConnectionValidator already running, ignoring "noliveira@owncloud.domain"
11-24 00:36:44:547 0x6a7b08 OCC::AccountState::checkConnectivity: ConnectionValidator already running, ignoring "noliveira@owncloud.domain"
11-24 00:37:16:544 0x6a7b08 OCC::AccountState::checkConnectivity: ConnectionValidator already running, ignoring "noliveira@owncloud.domain"
11-24 00:37:48:541 0x6a7b08 OCC::AccountState::checkConnectivity: ConnectionValidator already running, ignoring "noliveira@owncloud.domain"
11-24 00:38:20:545 0x6a7b08 OCC::AccountState::checkConnectivity: ConnectionValidator already running, ignoring "noliveira@owncloud.domain"
11-24 00:38:52:542 0x6a7b08 OCC::AccountState::checkConnectivity: ConnectionValidator already running, ignoring "noliveira@owncloud.domain"
@guruz

This comment has been minimized.

Copy link
Collaborator

commented Nov 24, 2015

@noliveira87 Do you have a full log with the lines before?
The request is supposed to time out after ~27 sec so it is actually not really possible to get that log message except if there is something else wrong.

Linking more info: #4097 (comment)

@noliveira87

This comment has been minimized.

Copy link

commented Nov 26, 2015

@guruz How do I get full log? I copied the log from the client since I open it.

@guruz guruz modified the milestones: 2.1.1-nextpatch, 2.1-current Nov 30, 2015

@guruz

This comment has been minimized.

Copy link
Collaborator

commented Nov 30, 2015

We think this is fixed with the 2.1 release coming out tomorrow.

If it still does not work: Please create a new issue with the part of the logfile that shows the error and some context before.

https://github.com/owncloud/client/blob/master/doc/troubleshooting.rst "Saving files directly"

@guruz guruz closed this Nov 30, 2015

@martin-rueegg

This comment has been minimized.

Copy link

commented Dec 14, 2015

not sure if it is the same issue, but i can solve it with pausing/unpausing the folder sync. which is still not perfect, but better than kill/restart.

[Windows client: Version 2.1.0 (build 5683)]

@davitol

This comment has been minimized.

Copy link

commented Jan 21, 2016

WFM in 2.1.1 beta1 version 👍

@noliveira87

This comment has been minimized.

Copy link

commented Sep 27, 2016

I still having the same problem. Should I reopen this issue here or in some other place? Sorry for the inconvenience.

@davitol

This comment has been minimized.

Copy link

commented Sep 28, 2016

@noliveira87 Can you please write here your desktop client version and the windows version that you use? Thanks

@noliveira87

This comment has been minimized.

Copy link

commented Sep 28, 2016

@davitol, obviously. The client version is 2.2.3 build 6307, and I am using Windows 10.

@guruz

This comment has been minimized.

Copy link
Collaborator

commented Sep 28, 2016

https://owncloud.org/changelog/desktop/

ConnectionValidator: properly handle error in status.php request

This one could fix it in 2.2.4.

Please create a new issue if it does not. thanks.

@owncloud owncloud locked and limited conversation to collaborators Sep 28, 2016

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
8 participants
You can’t perform that action at this time.