Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Linux] Hidden files synced only on startup of owncloud client #3980

Closed
tmysik opened this issue Oct 21, 2015 · 22 comments

Comments

@tmysik
Copy link

commented Oct 21, 2015

With v2.0, owncloud client stopped syncing of hidden files. I enabled it in its settings again, however these hidden files are synced only right after the startup of owncloud client. In other words, if I change a hidden file manually, no upload is done. I have to quit owncloud client and start it again, then the changed hidden file is correctly synced.

I am on Kubuntu 15.04, ownloud v2.0.1.

Thanks.

@guruz guruz added this to the 2.1-next milestone Oct 21, 2015

@guruz

This comment has been minimized.

Copy link
Collaborator

commented Oct 21, 2015

Maybe somehow related to the file watcher not getting the updated setting?

@guruz guruz added the bug label Oct 21, 2015

@dragotin

This comment has been minimized.

Copy link
Contributor

commented Oct 21, 2015

@tmysik we're about to release 2.0.2 and I'd ask you to verify with that. There were changes in regards to hidden files and the filesystem watcher.

@tmysik

This comment has been minimized.

Copy link
Author

commented Oct 22, 2015

@dragotin I just updated to v2.0.2 but unfortunately, there is no difference in syncing of hidden files. To be precise, I sync directory .private which contains some files and other directories (with other files, of course).

At least, sync still works fine if I manually restart ownCloud client :)

Thanks.

@dragotin

This comment has been minimized.

Copy link
Contributor

commented Oct 22, 2015

I can confirm that it does not work with 2.0.2. However, it works with current master, which will become the next release called 2.1.

@tmysik

This comment has been minimized.

Copy link
Author

commented Oct 22, 2015

@dragotin

I can confirm that it does not work with 2.0.2. However, it works with current master, which will become the next release called 2.1.

Great to hear! Thanks!

@dragotin

This comment has been minimized.

Copy link
Contributor

commented Oct 22, 2015

Well, it would be good to understand what has changed this behaviour.... @ckamm do you have an idea?

@guruz guruz closed this Oct 22, 2015

@dragotin

This comment has been minimized.

Copy link
Contributor

commented Oct 22, 2015

@Dianafg76 can you please add a testcase to your testplans?

@Dianafg76

This comment has been minimized.

Copy link

commented Oct 23, 2015

of course

dragotin added a commit that referenced this issue Oct 26, 2015

Discovery: Fix detection of hidden files.
In the discovery phase we want to detect that dot-files are hidden
on Linux and Mac.

This fixes strange behaviour seen in issue #3980
@tmysik

This comment has been minimized.

Copy link
Author

commented Dec 9, 2015

@dragotin

However, it works with current master, which will become the next release called 2.1.

Hi all, can anyone please verify that it works for version 2.1.0? I just installed it (from official OpenSuse repository) and it still does not work for me :/ Fortunately, the trick with manual client restarting still works.

Thanks a lot.

@guruz guruz reopened this Dec 14, 2015

@guruz guruz modified the milestones: 2.1.1-nextpatch, 2.1-current Dec 14, 2015

@guruz guruz changed the title Hidden files synced only on startup of owncloud client [Linux] Hidden files synced only on startup of owncloud client Dec 14, 2015

@guruz

This comment has been minimized.

Copy link
Collaborator

commented Jan 4, 2016

@tmysik How many folders do you have in your sync dir? A lot? Then would you please test what was described in #4107 ?

@tmysik

This comment has been minimized.

Copy link
Author

commented Jan 4, 2016

@guruz

How many folders do you have in your sync dir? A lot?

I do not think so:

gapon@cattie ~/storage/ownCloud $ find . -type d | wc -l
196
gapon@cattie ~/storage/ownCloud $ cat /proc/sys/fs/inotify/max_user_watches
524288

Moreover, as I wrote, manual restart of ownCloud client solves the problem for me - that would not help, right? Or am I wrong?

Thanks!

@guruz

This comment has been minimized.

Copy link
Collaborator

commented Jan 4, 2016

@tmysik I also wonder if #3475 is related. Is your sync folder a symlink?

But still why would it only be for hidden files..

@guruz

This comment has been minimized.

Copy link
Collaborator

commented Jan 4, 2016

@tmysik Can you try this:
Go to "Edit ignored files", click the "Sync hidden files" once, Press "OK". Go again to "Edit ignored files", click the "Sync hidden files" once, Press "OK". (so that it is checked at your last step).
Does it work then?

@tmysik

This comment has been minimized.

Copy link
Author

commented Jan 4, 2016

@guruz

Is your sync folder a symlink?

No symlinks in my sync folder:

gapon@cattie ~/storage/ownCloud $ find . -type l | wc -l
0
@tmysik

This comment has been minimized.

Copy link
Author

commented Jan 4, 2016

@guruz

Does it work then?

Did not seem to help.

The strange thing is that sometimes the sync happens but a bit later (no idea why and when).

Guys if I am the only one who sees this problem then it is apparently something with my PC/setup and it makes no sense to waste your time on it. Or is there anyone else who is able to reproduce this issue?

Thanks.

@guruz

This comment has been minimized.

Copy link
Collaborator

commented Jan 4, 2016

(I couldn't on OS X... someone else shall try then)

@ckamm

This comment has been minimized.

Copy link
Member

commented Jan 7, 2016

@tmysik I also can't reproduce the problem on linux.

@tmysik

This comment has been minimized.

Copy link
Author

commented Jan 7, 2016

@ckamm Thanks for trying it. In such a case, feel free to close this issue. However, as I wrote in my initial comment, it worked for me without any problem with ownCloud client v1.x.

Thanks.

@ckamm

This comment has been minimized.

Copy link
Member

commented Jan 7, 2016

@tmysik I'm sorry we can't help! If you have any extra information or figure it out, please let us know!

@ckamm ckamm closed this Jan 7, 2016

@tmysik

This comment has been minimized.

Copy link
Author

commented Jan 7, 2016

@ckamm Sure, will do that. Thank you!

@tmysik

This comment has been minimized.

Copy link
Author

commented Jun 15, 2016

BTW this issue has been solved with version 2.2.0 - so, thanks a lot!

@guruz

This comment has been minimized.

Copy link
Collaborator

commented Jun 15, 2016

👍

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
5 participants
You can’t perform that action at this time.