Setting enable_avatar to false with occ causes some bugs #21949

Closed
Pookay opened this Issue Jan 27, 2016 · 6 comments

Projects

None yet

4 participants

@Pookay
Contributor
Pookay commented Jan 27, 2016

Hello,
I'm Installing owncloud 8.2.2 on CentOS 6.6 with php7

When I set enable_avatar to false through occ, with this command :

sudo -u apache php ${oc_dir}/occ config:system:set enable_avatars --value="false"
  • First it just disable the avatar in the "Personnal" page but not the tiny picture beside the display name (photos of LDAP users are automatically used when I plug my LDAP on owncloud).
  • Then when I go on the user's admin page, loading never ends. Even if I do not enable LDAP user backend app and admin is the only user.
@MorrisJobke
Member
sudo -u apache php ${oc_dir}/occ config:system:set enable_avatars --value="false"

running the occ command form somewhere else and not the owncloud root folder is supported starting with ownCloud 9.0

@MorrisJobke
Member

I will test your reported issue

@MorrisJobke
Member

the correct command would be:

sudo -u apache php occ config:system:set enable_avatars --value="false" --type=boolean

Does this then work for you?

@MorrisJobke MorrisJobke added a commit that referenced this issue Jan 27, 2016
@MorrisJobke MorrisJobke Make enable_avatars setting more robust
* handles the setting in the same way everywhere
* fixes #21949
1601d92
@MorrisJobke
Member

Fix is in #21953

@MorrisJobke MorrisJobke added this to the 9.0-current milestone Jan 27, 2016
@nickvergessen
Contributor

type was added for 9.0, so no chance to en/disable avatars via console in 8.2

@Pookay
Contributor
Pookay commented Jan 27, 2016

Thank you,
If it's not working for 8.2 by the occ. Manual edit of config/config.php seems to work to disable/enable avatars.

@MorrisJobke MorrisJobke removed their assignment Feb 1, 2016
@MorrisJobke MorrisJobke added a commit that referenced this issue Feb 1, 2016
@MorrisJobke MorrisJobke Make enable_avatars setting more robust
* handles the setting in the same way everywhere
* fixes #21949
8569219
@MorrisJobke MorrisJobke removed their assignment Feb 1, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment