Detection of existing tags doesn't allow to create tags named like a prefix substring of an existing tag. #22064

Closed
SergioBertolinSG opened this Issue Feb 2, 2016 · 3 comments

Projects

None yet

5 participants

@SergioBertolinSG
Member

Steps to reproduce

Having no tags in the system do;

  1. Open sidebar of a file and assign(creating it) a tag called "javascript".
  2. In the same file, assign(creating it) a tag called "java".

Expected behaviour

That file has the tags "java" and "javascript" on it.

Actual behaviour

"javascript" tag is unassigned, "java" tag is never created.

Server configuration

Operating system:
Ubuntu 14.04

Web server:
Apache

Database:
MySQL

PHP version:
5.5.9

ownCloud version: (see ownCloud admin page)
Master branch
{"installed":true,"maintenance":false,"version":"9.0.0.8","versionstring":"9.0 pre alpha","edition":"Enterprise"}

Updated from an older ownCloud or fresh install:
Fresh

The content of config/config.php:


Are you using external storage, if yes which one: local/smb/sftp/...
No.

Are you using encryption:
No

Logs

Client configuration

browser
Chrome

@SergioBertolinSG SergioBertolinSG added this to the 9.0-current milestone Feb 2, 2016
@PVince81
Collaborator
PVince81 commented Feb 2, 2016

Ah yes, I know why. Assigning to self.

@PVince81 PVince81 self-assigned this Feb 2, 2016
@PVince81
Collaborator
PVince81 commented Feb 2, 2016

Fix is here #22065

@nickvergessen
Contributor

nice find 😺

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment