[LDAP] A lot of 'noise' in owncloud.log showing LDAP users in users view #22770

Closed
davitol opened this Issue Mar 2, 2016 · 1 comment

Projects

None yet

4 participants

@davitol
Contributor
davitol commented Mar 2, 2016

Steps to reproduce

  1. Configure a LDAP users backend
  2. Go to the users view

Expected behaviour

The users are shown in users page and no logs are shown

Actual behaviour

owncloud.log file is full of logs

Server configuration

Operating system: ubuntu 14.04

Web server: apache 2.4.7

Database: mysql

PHP version: 5.5.9

**ownCloud version: ownCloud Enterprise Edition 9.0.0 beta 2 (daily) Build:2016-02-25T04:15:38+00:00 faf65e7

Logs

{"reqId":"r+kyRntoy99t1xLKiOZs","remoteAddr":"XX.XX.XXX.XX","app":"PHP","message":"Argument 9 passed to OCA\\user_ldap\\lib\\user\\User::__construct() must implement interface OCP\\IUserManager, instance of OCA\\user_ldap\\lib\\user\\Manager given, called in \/opt\/owncloud\/apps\/user_ldap\/lib\/user\/manager.php on line 121 and defined at \/opt\/owncloud\/apps\/user_ldap\/lib\/user\/user.php#111","level":3,"time":"2016-03-02T09:09:59+00:00"}
{"reqId":"QJnexZj+GWVUcLeE5Gga","remoteAddr":"XX.XXX.XXX.XX","app":"PHP","message":"Argument 7 passed to OCA\\user_ldap\\lib\\user\\Manager::__construct() must implement interface OCP\\IUserManager, instance of OCA\\user_ldap\\lib\\user\\Manager given, called in \/opt\/owncloud\/apps\/user_ldap\/lib\/proxy.php on line 76 and defined at \/opt\/owncloud\/apps\/user_ldap\/lib\/user\/manager.php#90","level":3,"time":"2016-03-02T09:10:27+00:00"}

This log is shown hundreds of times

Updated from an older ownCloud or fresh install: Fresh install

Are you using external storage, if yes which one: no
Are you using encryption: no
Are you using an external user-backend, if yes which one: LDAP

Client configuration

Browser: Firefox for Mac OSX

@blizzz

@davitol davitol added this to the 9.0.1-next-maintenance milestone Mar 2, 2016
@blizzz blizzz added the sev3-medium label Mar 2, 2016
@blizzz blizzz was assigned by DeepDiver1975 Mar 2, 2016
@blizzz blizzz removed the sev4-low label Mar 2, 2016
@blizzz
Contributor
blizzz commented Mar 2, 2016

Fix in #22778

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment