New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Web Installer - Failed To Download Zip - SSL Problem #2648

Closed
laurin1 opened this Issue Apr 2, 2013 · 19 comments

Comments

Projects
None yet
@laurin1

laurin1 commented Apr 2, 2013

download of ownCloud source file failed.
SSL certificate problem: self signed certificate in certificate chainSSL certificate problem: self signed certificate in certificate chain

Solution:

curl_setopt($ch, CURLOPT_CERTINFO, FALSE);
curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, FALSE);

@BernhardPosselt

This comment has been minimized.

Show comment
Hide comment
@BernhardPosselt
Contributor

BernhardPosselt commented Apr 2, 2013

@VicDeo

This comment has been minimized.

Show comment
Hide comment
@VicDeo
Member

VicDeo commented Apr 2, 2013

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Apr 2, 2013

Probably not because https://download.owncloud.org is used for downloading this package. When browsing https://download.owncloud.org there is no warning in the browser and the zertificate contains the correct alternative names:

DNS-Name: www.owncloud.org
DNS-Name: owncloud.org
DNS-Name: download.owncloud.org
DNS-Name: forum.owncloud.org

ghost commented Apr 2, 2013

Probably not because https://download.owncloud.org is used for downloading this package. When browsing https://download.owncloud.org there is no warning in the browser and the zertificate contains the correct alternative names:

DNS-Name: www.owncloud.org
DNS-Name: owncloud.org
DNS-Name: download.owncloud.org
DNS-Name: forum.owncloud.org

@VicDeo

This comment has been minimized.

Show comment
Hide comment
@VicDeo

VicDeo Apr 2, 2013

Member

@laurin1 can you update the issue with versions of curl and ca-certificates you have installed?
Output of

php -i | grep SSL

would also be helpful.
Thanks

Member

VicDeo commented Apr 2, 2013

@laurin1 can you update the issue with versions of curl and ca-certificates you have installed?
Output of

php -i | grep SSL

would also be helpful.
Thanks

@laurin1

This comment has been minimized.

Show comment
Hide comment
@laurin1

laurin1 Apr 3, 2013

Forgive me, but I have never really used curl, and so I'm not sure what you mean by version. The php_curl.dll version is 5.4.13.

ca-certificates? Do you mean Certificate Authorities? Like Trust Root or all of them (it's quite a list, either way)?

C:\Windows\System32>php -i | grep SSL
SSL => Yes
SSL Version => OpenSSL/0.9.8y
SSL Support => enabled
SSL => supported
OpenSSL support => disabled (install ext/openssl)
OPENSSL_CONF => C:\OpenSSL-Win32\bin\openssl.cfg
_SERVER["OPENSSL_CONF"] => C:\OpenSSL-Win32\bin\openssl.cfg

laurin1 commented Apr 3, 2013

Forgive me, but I have never really used curl, and so I'm not sure what you mean by version. The php_curl.dll version is 5.4.13.

ca-certificates? Do you mean Certificate Authorities? Like Trust Root or all of them (it's quite a list, either way)?

C:\Windows\System32>php -i | grep SSL
SSL => Yes
SSL Version => OpenSSL/0.9.8y
SSL Support => enabled
SSL => supported
OpenSSL support => disabled (install ext/openssl)
OPENSSL_CONF => C:\OpenSSL-Win32\bin\openssl.cfg
_SERVER["OPENSSL_CONF"] => C:\OpenSSL-Win32\bin\openssl.cfg

@jancborchardt

This comment has been minimized.

Show comment
Hide comment
@jancborchardt

jancborchardt Aug 7, 2013

Member

I’m closing this issue because it has been inactive for a few months. This probably means that the issue is not reproducible or it has been fixed in a newer version.

Please reopen if you still encounter this issue with the latest stable version (currently ownCloud 5.0.9) and then please use the issue template. You an also contribute directly by providing a patch – see the developer manual. :)

Thank you!

Member

jancborchardt commented Aug 7, 2013

I’m closing this issue because it has been inactive for a few months. This probably means that the issue is not reproducible or it has been fixed in a newer version.

Please reopen if you still encounter this issue with the latest stable version (currently ownCloud 5.0.9) and then please use the issue template. You an also contribute directly by providing a patch – see the developer manual. :)

Thank you!

@lborgman

This comment has been minimized.

Show comment
Hide comment
@lborgman

lborgman Jun 5, 2014

I just got this error message when trying to install with the web installer. I believe it is the same as @laurin1 got.

ownCloud is NOT installed
download of ownCloud source file failed.
SSL: certificate subject name '.owncloud.com' does not match target host name 'download.owncloud.org'SSL: certificate subject name '.owncloud.com' does not match target host name 'download.owncloud.org'

The solution suggested here by him did not work for me.

lborgman commented Jun 5, 2014

I just got this error message when trying to install with the web installer. I believe it is the same as @laurin1 got.

ownCloud is NOT installed
download of ownCloud source file failed.
SSL: certificate subject name '.owncloud.com' does not match target host name 'download.owncloud.org'SSL: certificate subject name '.owncloud.com' does not match target host name 'download.owncloud.org'

The solution suggested here by him did not work for me.

@Rouzax

This comment has been minimized.

Show comment
Hide comment
@Rouzax

Rouzax Feb 19, 2015

I'm having the same issue with the install of 8.0
image

Rouzax commented Feb 19, 2015

I'm having the same issue with the install of 8.0
image

@karlitschek

This comment has been minimized.

Show comment
Hide comment
@karlitschek

karlitschek Feb 19, 2015

Member

strange. @LukasReschke snx idea?

Member

karlitschek commented Feb 19, 2015

strange. @LukasReschke snx idea?

@Rouzax

This comment has been minimized.

Show comment
Hide comment
@Rouzax

Rouzax Feb 19, 2015

I'm no doing an install using the zip and manually uploading the files.

Rouzax commented Feb 19, 2015

I'm no doing an install using the zip and manually uploading the files.

@LukasReschke

This comment has been minimized.

Show comment
Hide comment
@LukasReschke

LukasReschke Feb 19, 2015

Member

Can be caused by older distributions that do not ship the new Root Certificates that we use.

We can partially work around this by adding our certificate manually to the setup-owncloud.php script, however, other parts of ownCloud will still not work properly as they do also remote requests to our servers. (such as the appstore)

Proper solution would be that the SSL certificates are properly configured on the server.

@Rouzax Which OS?

Member

LukasReschke commented Feb 19, 2015

Can be caused by older distributions that do not ship the new Root Certificates that we use.

We can partially work around this by adding our certificate manually to the setup-owncloud.php script, however, other parts of ownCloud will still not work properly as they do also remote requests to our servers. (such as the appstore)

Proper solution would be that the SSL certificates are properly configured on the server.

@Rouzax Which OS?

@Rouzax

This comment has been minimized.

Show comment
Hide comment
@Rouzax

Rouzax Feb 19, 2015

It is a shared host.
Here is cPanel info

Apache Version  2.4.10
PHP Version 5.4.33
MySQL Version   5.0.96-community
Architecture    x86_64
Operating System    linux
Path to sendmail    /usr/sbin/sendmail
Path to Perl    /usr/bin/perl
Perl Version    5.8.8
Kernel Version  2.6.32-042stab088.4

Rouzax commented Feb 19, 2015

It is a shared host.
Here is cPanel info

Apache Version  2.4.10
PHP Version 5.4.33
MySQL Version   5.0.96-community
Architecture    x86_64
Operating System    linux
Path to sendmail    /usr/sbin/sendmail
Path to Perl    /usr/bin/perl
Perl Version    5.8.8
Kernel Version  2.6.32-042stab088.4
@Rouzax

This comment has been minimized.

Show comment
Hide comment
@Rouzax

Rouzax Feb 19, 2015

The manual uplaod of the files wass successful the install is now working.

Rouzax commented Feb 19, 2015

The manual uplaod of the files wass successful the install is now working.

@escservices

This comment has been minimized.

Show comment
Hide comment
@escservices

escservices Mar 13, 2015

Just got the same error, if you go through the php setup file and change all https: to http: it works fine. Just make sure your secure enough where you don't need ssl. lol

escservices commented Mar 13, 2015

Just got the same error, if you go through the php setup file and change all https: to http: it works fine. Just make sure your secure enough where you don't need ssl. lol

@rvega

This comment has been minimized.

Show comment
Hide comment
@rvega

rvega May 12, 2015

Same error here.

rvega commented May 12, 2015

Same error here.

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost May 12, 2015

The message about the SSL in the screenshots is probably caused by a CURL version not supporting SNI (at least version 7.18.1 is needed).

#16211 (comment)

ghost commented May 12, 2015

The message about the SSL in the screenshots is probably caused by a CURL version not supporting SNI (at least version 7.18.1 is needed).

#16211 (comment)

@upamanyudas

This comment has been minimized.

Show comment
Hide comment
@upamanyudas

upamanyudas May 27, 2015

@Rouzax Can you give details on how you installed manually?

upamanyudas commented May 27, 2015

@Rouzax Can you give details on how you installed manually?

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost May 27, 2015

@upamanyudas

Install instructions for installations without the webinstaller are available here: https://doc.owncloud.org/server/8.0/admin_manual/installation/index.html

ghost commented May 27, 2015

@upamanyudas

Install instructions for installations without the webinstaller are available here: https://doc.owncloud.org/server/8.0/admin_manual/installation/index.html

@Rouzax

This comment has been minimized.

Show comment
Hide comment
@Rouzax

Rouzax May 27, 2015

Or edit the install file and change all https to http.

Rouzax commented May 27, 2015

Or edit the install file and change all https to http.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment