Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

External storage S3 mount folders disappear from Web GUI #818

Closed
MTRichards opened this Issue Dec 11, 2012 · 2 comments

Comments

Projects
None yet
3 participants
Contributor

MTRichards commented Dec 11, 2012

Transferred from bug genie.
http://bugs.owncloud.org/thebuggenie/owncloud/issues/oc-1879

Description:
I recently installed OC 4.5 Dev on latest Bitnami LAMP stack, while trying to mount S3 via the external storage app or custom mount.php file the mount folder just disappear from the screen.

Reproduction steps:
The first error i got was this:

[Mon Oct 01 00:50:01 2012] [error] [client 202.180.91.***] PHP Fatal error:  Uncaught exception 'cURL_Exception' with message 'cURL resource: Resource id #102; cURL error: SSL peer certificate or SSH remote key was not OK (cURL error code 51). See http://curl.haxx.se/libcurl/c/libcurl-errors.html for an explanation of error codes.' in /opt/bitnami/apps/owncloud/htdocs/3rdparty/aws-sdk/lib/requestcore/requestcore.class.php:824\nStack trace:\n#0 /opt/bitnami/apps/owncloud/htdocs/3rdparty/aws-sdk/services/s3.class.php(903): RequestCore->send_request()\n#1 /opt/bitnami/apps/owncloud/htdocs/3rdparty/aws-sdk/services/s3.class.php(1624): AmazonS3->authenticate('omrimoyal.com', Array)\n#2 /opt/bitnami/apps/owncloud/htdocs/3rdparty/aws-sdk/services/s3.class.php(2181): AmazonS3->list_objects('omrimoyal.com')\n#3 /opt/bitnami/apps/owncloud/htdocs/apps/files_external/lib/amazons3.php(107): AmazonS3->get_bucket_filesize('*****.com')\n#4 /opt/bitnami/apps/owncloud/htdocs/lib/filestorage/common.php(74): OC_Filestorage_AmazonS3->stat(false)\n#5 /opt/bitnami/apps/owncloud/htdocs/lib/filesystemview.php(58 in /opt/bitnami/apps/owncloud/htdocs/3rdparty/aws-sdk/lib/requestcore/requestcore.class.php on line 824, referer: http://bitnami.*****.co/owncloud/?app=files

after a bit of searching i figured out that its cURL problem authnticating buckets with names using "." via this commit: amazonwebservices/aws-sdk-for-php#42

so i made another bucket with just one line name and deleted AmazonS3 folder via ssh and recreated it with the client. This time the bucket mounted correctly and I was able to see the files on S3 however, soon as i refreshed the page the folder was gone again. Once again i deleted the folder via ssh and recreated it and same problem return, can only browse into the AmazonS3 bucket once then its gone again.

not idea where t continue from here because cant see any new error_logs.

Thank you!

Member

jancborchardt commented Mar 20, 2013

@MTRichards does this error still occur? @MTGap can you look into it?

@MTGap MTGap was assigned Mar 20, 2013

Member

jancborchardt commented Aug 7, 2013

I’m closing this issue because it has been inactive for a few months. This probably means that the issue is not reproducible or it has been fixed in a newer version.

Please reopen if you still encounter this issue with the latest stable version (currently ownCloud 5.0.9) and then please use the issue template. You an also contribute directly by providing a patch – see the developer manual. :)

Thank you!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment