Smarter Runner #430

Closed
viyatb opened this Issue May 1, 2015 · 1 comment

Comments

Projects
None yet
1 participant
@viyatb
Member

viyatb commented May 1, 2015

@7a : The runner should be smart enough to see if OWTF has been installed or not, to avoid stack traces like the following (on an up-to-date Kali):

# ./owtf.py 
Traceback (most recent call last):
  File "./owtf.py", line 42, in <module>
    verify_dependencies(os.path.dirname(os.path.abspath(sys.argv[0])) or '.')
  File "/root/owtf_develop/framework/dependency_check.py", line 58, in verify_dependencies
    owtf_reqs = pip.req.parse_requirements(
AttributeError: 'module' object has no attribute 'req'

FIX :

pip install pip --upgrade # this updates pip and replaces pip by pip2
apt-get install libpq-dev # this fixes the error which occurs during installation of psycopg2

@viyatb viyatb added the Enhancement label May 1, 2015

@viyatb

This comment has been minimized.

Show comment
Hide comment
@viyatb

viyatb Dec 13, 2015

Member

Closing as this was an old pip error. :)

Member

viyatb commented Dec 13, 2015

Closing as this was an old pip error. :)

@viyatb viyatb closed this Dec 13, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment