Incorrect Flash version requirement in README #201

Open
khansen opened this Issue Nov 16, 2012 · 2 comments

2 participants

@khansen

The README states that Flash 6+ is required. However, the Flash plugin uses ExternalInterface, which, according to http://help.adobe.com/en_US/FlashPlatform/reference/actionscript/3/flash/external/ExternalInterface.html#call(), is only available since Flash Player 9.

This might explain why easyXDM initialization silently fails on IE6 with Flash version 6.0.79.0, for example. The final log entries on the consumer side are

07:28:33.497:easyXDM.stack.FlashTransport: creating factory with SWF from provider.example.net
07:28:33.497:easyXDM.Fn: storing function flash_loadedprovider_example_net

The provider log is blank.

@oyvindkinsey

It was added at 6.1 something, so your'e nearly there :)
But I would seriously suggest that you require anyone still using 6.0.79 to upgrade!

@khansen

Hehe, we just happened to have a test VM with Flash 6, it's probably not intentionally configured like that (anymore). :-P

Any point in easyXDM checking for version >=6.1, then? I couldn't get the fallback transports (NameTransport, HashTransport) to work on IE6, anyway.

Could you perhaps add some instructions on how to build the Flash plugin, though? It would have helped me out while debugging some other Flash initialization issues. Is FlashDevelop on Windows the only way to go? I tried the latest FlexSDK on Mac without success. (The line "if (!Validate(_root.ns) || !Validate(_root.proto) || !Validate(_root.domain) || !Validate(_root.port)) || !Validate(_root.callback) return;" seems to have mismatched parentheses, for starters.)

Lastly: Cool lib! We're using it in https://github.com/GyldendalDigital/jQuery-EasyXDM to provide a fallback for non-CORS enabled browsers.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment