Permalink
Browse files

Update readme, cabal & bump version

  • Loading branch information...
1 parent bdb36b3 commit 844ae2edd5990e63fd0968ddd27e94ff8f68b222 @ozataman committed Jan 7, 2011
Showing with 26 additions and 3 deletions.
  1. +13 −0 .ghci
  2. +6 −2 README.md
  3. +7 −1 snap-extension-mongodb.cabal
View
13 .ghci
@@ -0,0 +1,13 @@
+:set -XOverloadedStrings
+:set -XGeneralizedNewtypeDeriving
+:set -XDeriveDataTypeable
+:set -XMultiParamTypeClasses
+:set -XFunctionalDependencies
+:set -XFlexibleInstances
+:set -XTypeSynonymInstances
+:set -Wall
+:set -isrc
+:set -itest/suite
+:set -hide-package monads-tf
+:set -hide-package monads-fd
+
View
@@ -4,7 +4,11 @@ Snap Extension for MongoDB
This package provides a straightforward way to integrate MongoDB database
connectivity into Snap applications.
-This is a very crude initial realease to be refined on an ongoing basis. The
-API may change, so please use at your own risk for the time being.
+The API is a work in progress, so expect changes.
+
+Starting with 0.3, this library provides out-of-box integration with Snap.Auth,
+but you will need to install the devel branch from the source repo:
+
+ https://github.com/snapframework/snap-auth/tree/devel
@@ -1,5 +1,5 @@
Name: snap-extension-mongodb
-Version: 0.2.2.0
+Version: 0.3.0.0
Synopsis: MongoDB extension for Snap Framework
Homepage: https://github.com/ozataman/snap-extension-mongodb
License: BSD3
@@ -21,13 +21,19 @@ Library
Build-depends:
base >= 4 && < 5
, bytestring >= 0.9
+ , bson
, compact-string-fix >= 0.3.1 && < 0.4
, containers >= 0.3 && < 0.4
, mongoDB == 0.9
, mtl >= 2 && < 3
+ , safe
, snap >= 0.3 && < 0.4
, snap-core >= 0.3 && < 0.4
+ , snap-auth >= 0.1
+ , time
extensions:
OverloadedStrings
, FlexibleInstances
+ , TypeSynonymInstances
+ , MultiParamTypeClasses

0 comments on commit 844ae2e

Please sign in to comment.