JPackage compatibility layer for the Sun Java SE 7 JDK (You need this if you want to use JPackage RPMs like Ant with the Sun JDK)
Switch branches/tags
Nothing to show
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
RPMS/x86_64
SOURCES
SPECS
SRPMS
README

README

java-1.7.0-sun-compat
---------------------
JPackage compatibility layer for the Sun Java SE 7 JDK (You need this if you
want to use JPackage RPMs like Ant with the Sun JDK)

This provides the missing "java-devel" dependency when trying to use
JPackage RPMs with the Sun JDK.

Forked from java-1.6.0-sun-compat at the JPackage project:
http://mirrors.dotsrc.org/jpackage/5.0/generic/non-free/SRPMS/java-1.6.0-sun-compat-1.6.0.03-1jpp.src.rpm


Example installation of Sun Java SE 7 JDK + JPackage Ant 1.8.2 on CentOS EL5 64-bit:

### 
# wget http://download.oracle.com/otn-pub/java/jdk/7u1-b08/jdk-7u1-linux-x64.rpm
#
#   Oracle has disabled direct HTTP access to their downloads, so you will need to visit their site
#   here with a graphical browser, register with an email address, and log in to download the JDK rpm.
#        http://www.oracle.com/technetwork/java/javase/downloads/jdk-7u1-download-513651.html
###
wget http://mirrors.dotsrc.org/jpackage/6.0/generic/free/RPMS/jpackage-utils-5.0.0-7.jpp6.noarch.rpm
wget http://p120ph37.github.com/java-1.7.0-sun-compat/RPMS/x86_64/java-1.7.0-sun-compat-1.7.0.01-1jpp.x86_64.rpm
wget http://mirrors.dotsrc.org/jpackage/6.0/generic/free/RPMS/xalan-j2-2.7.1-8.jbossorg_1.jpp6.noarch.rpm
wget http://mirrors.dotsrc.org/jpackage/6.0/generic/free/RPMS/xml-commons-1.3.04-10.jpp6.noarch.rpm
wget http://mirrors.dotsrc.org/jpackage/6.0/generic/free/RPMS/xml-commons-jaxp-1.3-apis-1.3.04-10.jpp6.noarch.rpm
wget http://mirrors.dotsrc.org/jpackage/6.0/generic/free/RPMS/xml-commons-resolver12-1.3.04-10.jpp6.noarch.rpm
wget http://mirrors.dotsrc.org/jpackage/6.0/generic/free/RPMS/xerces-j2-2.9.1-2.jpp6.noarch.rpm
wget http://mirrors.dotsrc.org/jpackage/6.0/generic/free/RPMS/ant-1.8.2-5.jpp6.noarch.rpm
rpm -i jdk-7u1-linux-x64.rpm
rpm -i jpackage-utils-5.0.0-7.jpp6.noarch.rpm
rpm -i java-1.7.0-sun-compat-1.7.0.01-1jpp.x86_64.rpm
rpm -i xalan-j2-2.7.1-8.jbossorg_1.jpp6.noarch.rpm
rpm -i xml-commons-1.3.04-10.jpp6.noarch.rpm
rpm -i xml-commons-jaxp-1.3-apis-1.3.04-10.jpp6.noarch.rpm
rpm -i xml-commons-resolver12-1.3.04-10.jpp6.noarch.rpm
rpm -i xerces-j2-2.9.1-2.jpp6.noarch.rpm
rpm -i ant-1.8.2-5.jpp6.noarch.rpm


Testing if Ant works:

[root@ember root]# java -version
java version "1.7.0_01"
Java(TM) SE Runtime Environment (build 1.7.0_01-b08)
Java HotSpot(TM) 64-Bit Server VM (build 21.1-b02, mixed mode)
[root@ember root]# ant -version
Apache Ant(TM) version 1.8.2 compiled on May 13 2011
[root@ember root]#