New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

GPL license and dynamic loaded content #286

Closed
JildertDW opened this Issue Nov 20, 2017 · 10 comments

Comments

Projects
None yet
3 participants
@JildertDW

JildertDW commented Nov 20, 2017

Hi Peter,

We plan on using the Open Web Analytics framework for our master thesis. However, the company who are working with has some questions regarding the GPL license. Is it correct that we only need to make the source code of the changes to the OWA publicly available? Or do we need to open source the code in which we are using the OWA tracker publicly available as well - meaning we need to open source the entire product of our company?

Secondly, the company is using a single web application in which dynamic content is loaded with javascript. The clicks on the dynamically loaded element don't seem to be tracked. We are guessing that this is currently not supported. If not, can you give us a direction in which we need to start looking in the code to implement this? If it is supported, any idea why the clicks aren't tracked in our application?

Thanks in advance,

Jildert

@HussainMD

This comment has been minimized.

Show comment
Hide comment
@HussainMD

HussainMD Nov 20, 2017

Hi JiltertDW,

Have you checked database tables to see if stats are gathered? I checked mine and it seems stats are fine on local db its just for some reason OWA is not displaying them on the site.

Thank you.

HussainMD commented Nov 20, 2017

Hi JiltertDW,

Have you checked database tables to see if stats are gathered? I checked mine and it seems stats are fine on local db its just for some reason OWA is not displaying them on the site.

Thank you.

@JildertDW

This comment has been minimized.

Show comment
Hide comment
@JildertDW

JildertDW Nov 20, 2017

The clicks are tracked perfectly in the database as well as visitor id's etc. Currently we found how to to gain information about dynamically loaded content.

Still not showing up in the dashboard though.

JildertDW commented Nov 20, 2017

The clicks are tracked perfectly in the database as well as visitor id's etc. Currently we found how to to gain information about dynamically loaded content.

Still not showing up in the dashboard though.

@padams

This comment has been minimized.

Show comment
Hide comment
@padams

padams Nov 21, 2017

Owner
Owner

padams commented Nov 21, 2017

@JildertDW

This comment has been minimized.

Show comment
Hide comment
@JildertDW

JildertDW Nov 27, 2017

I got these logs in de owa_data>logs folder.
errors_ae5f6c8be5b423af22f774fb7aa598a6.txt

As for network errors after login, I don't see any popping up. I attached an image of the request that happen during loading up the dashboard. Hope this can help you to help us figure out the issue.
screen shot 2017-11-27 at 10 19 44

JildertDW commented Nov 27, 2017

I got these logs in de owa_data>logs folder.
errors_ae5f6c8be5b423af22f774fb7aa598a6.txt

As for network errors after login, I don't see any popping up. I attached an image of the request that happen during loading up the dashboard. Hope this can help you to help us figure out the issue.
screen shot 2017-11-27 at 10 19 44

@padams

This comment has been minimized.

Show comment
Hide comment
@padams

padams Nov 27, 2017

Owner
Owner

padams commented Nov 27, 2017

@JildertDW

This comment has been minimized.

Show comment
Hide comment
@JildertDW

JildertDW Nov 27, 2017

Turned "define('OWA_LOG_PHP_ERRORS', true);" on in de owa-config.php, cleared out the log file and got this. From what I make from it, it may be an issue in the API?

errors_ae5f6c8be5b423af22f774fb7aa598a6.txt

Not sure if it is the correct config file, as it says localhost for database and I'm running it on my server taptics.be.
owa-config.txt

JildertDW commented Nov 27, 2017

Turned "define('OWA_LOG_PHP_ERRORS', true);" on in de owa-config.php, cleared out the log file and got this. From what I make from it, it may be an issue in the API?

errors_ae5f6c8be5b423af22f774fb7aa598a6.txt

Not sure if it is the correct config file, as it says localhost for database and I'm running it on my server taptics.be.
owa-config.txt

@padams

This comment has been minimized.

Show comment
Hide comment
@padams

padams Nov 27, 2017

Owner
Owner

padams commented Nov 27, 2017

@JildertDW

This comment has been minimized.

Show comment
Hide comment
@JildertDW

JildertDW Nov 28, 2017

Oke, this should be all the logs. error.txt

JildertDW commented Nov 28, 2017

Oke, this should be all the logs. error.txt

@padams

This comment has been minimized.

Show comment
Hide comment
@padams

padams Nov 29, 2017

Owner

ok. Try updating the new code in master and see how that works for you.

Owner

padams commented Nov 29, 2017

ok. Try updating the new code in master and see how that works for you.

@JildertDW

This comment has been minimized.

Show comment
Hide comment
@JildertDW

JildertDW Dec 4, 2017

It seems to be working now !

JildertDW commented Dec 4, 2017

It seems to be working now !

@JildertDW JildertDW closed this Dec 4, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment