Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

"Uncaught TypeError: Cannot read property 'apply' of undefined" #384

Open
davetbo opened this Issue Feb 25, 2019 · 5 comments

Comments

Projects
None yet
3 participants
@davetbo
Copy link

davetbo commented Feb 25, 2019

Hello,

I'm using the most recent code from Master as of 2019-02-25. I just installed a new copy of your OWA into Wordpress. The WP site is running on PHP 7.0.x.

I'm getting a javascript error in the subject line, and it's from owa.tracker-combined-min.js line 140. Can you advise as to how to get your code working? For some reason it's working on a different site that I have set up, but not this new one. Please advise.

Thanks,
Dave

@davetbo

This comment has been minimized.

Copy link
Author

davetbo commented Feb 25, 2019

Here's the full stack trace. Sorry for the double post:

owa.tracker-combined-min.js:140 Uncaught TypeError: Cannot read property 'apply' of undefined
    at OWA.commandQueue.push (owa.tracker-combined-min.js:140)
    at OWA.commandQueue.process (owa.tracker-combined-min.js:143)
    at callback (owa.tracker-combined-min.js:142)
    at OWA.commandQueue.push (owa.tracker-combined-min.js:142)
    at OWA.commandQueue.process (owa.tracker-combined-min.js:143)
    at callback (owa.tracker-combined-min.js:142)
    at OWA.commandQueue.push (owa.tracker-combined-min.js:142)
    at OWA.commandQueue.process (owa.tracker-combined-min.js:143)
    at owa.tracker-combined-min.js:244
    at owa.tracker-combined-min.js:244
@davetbo

This comment has been minimized.

Copy link
Author

davetbo commented Feb 25, 2019

I should also note (sorry for the TRIPLE post) that all I've changed so far in the settings for this fresh install of your plugin is to set the timezone properly. All the other settings and modules are out-of-the-box defaults.

@yrammos

This comment has been minimized.

Copy link

yrammos commented Mar 10, 2019

I'm facing exactly the same issue on the same kind of setup.

@yrammos

This comment has been minimized.

Copy link

yrammos commented Mar 10, 2019

UPDATE: @davetbo the HEAD commit apparently contains a breaking change since the latest validated release. I solved the issue by checking out 73bd248. Do not check out the commit of the validated release itself (796fe3e), which appears a couple of nodes earlier in the history and introduces a new error.

@padams

This comment has been minimized.

Copy link
Owner

padams commented Mar 10, 2019

Can you isolate what is causing this error on one site but not on another?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.