Browse files

Manage hamcrest dev-dependency properly through composer

  • Loading branch information...
1 parent 2bb5347 commit c6ed5fc903776089e9db9d15ffd9f1dc1764143d @igorw igorw committed Oct 12, 2012
Showing with 22 additions and 7 deletions.
  1. +21 −3 composer.json
  2. +1 −4 tests/Bootstrap.php
View
24 composer.json
@@ -14,10 +14,28 @@
"require": {
"php": ">=5.3.2"
},
+ "require-dev": {
+ "hamcrest/hamcrest": "1.1.0"
+ },
"autoload": {
"psr-0": { "Mockery": "library/" }
},
- "suggest": {
- "Hamcrest": "1.0.0"
- }
+ "repositories": [
+ {
+ "type": "package",
+ "package": {
+ "name": "hamcrest/hamcrest",
+ "version": "1.1.0",
+ "dist": {
+ "type": "zip",
+ "url": "https://hamcrest.googlecode.com/files/hamcrest-php-1.1.0.zip"
+ },
+ "include-path": ["Hamcrest-1.1.0/"],
+ "autoload": {
+ "psr-0": { "Hamcrest_": "Hamcrest-1.1.0/" },
+ "files": ["Hamcrest-1.1.0/Hamcrest/Hamcrest.php"]
+ }
+ }
+ }
+ ]
}
View
5 tests/Bootstrap.php
@@ -66,10 +66,7 @@
PHPUnit_Util_Filter::addDirectoryToFilter(PHP_LIBDIR);
}
-require_once 'Mockery/Loader.php';
-$loader = new \Mockery\Loader;
-$loader->register();
-require_once 'Hamcrest/Hamcrest.php';
+require __DIR__.'/../vendor/autoload.php';
/*
* Unset global variables that are no longer needed.

0 comments on commit c6ed5fc

Please sign in to comment.