New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Double escaping of urls in link_to #1529

Closed
ueno1969 opened this Issue Dec 25, 2013 · 1 comment

Comments

Projects
None yet
2 participants
@ueno1969

ueno1969 commented Dec 25, 2013

I use link_to method in slim, but url is dobule escaped.

My test is:

= link_to("test link",  '/?x=1&y=2')

result:

<a href="/?x=1&amp;amp;y=2">test link</a>

'&' is escaped double.
This result is the same in using erb.

So I tested other parameters (https://gist.github.com/ueno1969/8109254).
Test 3 and 4 is escaped rightly.

What is the right way?

@ghost ghost assigned ujifgc Dec 25, 2013

@ujifgc ujifgc closed this in 73b7964 Dec 26, 2013

ujifgc added a commit that referenced this issue Dec 26, 2013

Merge pull request #1530 from padrino/fix-1529
remove SafeBuffer from link_to helper options, fixes #1529, add tests
@ueno1969

This comment has been minimized.

Show comment
Hide comment
@ueno1969

ueno1969 Dec 27, 2013

Thank you.
I'll test later.
(Sorry I'll do in next year).

ueno1969 commented Dec 27, 2013

Thank you.
I'll test later.
(Sorry I'll do in next year).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment