New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix for Issue 921 with provides array in routes #1111

Closed
wants to merge 2 commits into
base: master
from

Conversation

Projects
None yet
5 participants
@Ortuna
Member

Ortuna commented Mar 13, 2013

Fix for #921 where a routes block was getting called with more arguments if a :provides array was passed.

@nesquena

This comment has been minimized.

Show comment
Hide comment
@nesquena

nesquena Mar 15, 2013

Member

I think we upgraded to 0.11.0 @DAddYE ? Is this still needed?

Member

nesquena commented Mar 15, 2013

I think we upgraded to 0.11.0 @DAddYE ? Is this still needed?

@DAddYE

This comment has been minimized.

Show comment
Hide comment
@DAddYE

DAddYE Mar 15, 2013

Member

Let me check it a bit more, I want to add some new test (fix the small one on 1.8.7) and check thread safety

Member

DAddYE commented Mar 15, 2013

Let me check it a bit more, I want to add some new test (fix the small one on 1.8.7) and check thread safety

@nesquena

This comment has been minimized.

Show comment
Hide comment
@nesquena

nesquena Mar 15, 2013

Member

Yeah was going to mention one failing test on 1.8.7 on travis :(

Member

nesquena commented Mar 15, 2013

Yeah was going to mention one failing test on 1.8.7 on travis :(

@dariocravero

This comment has been minimized.

Show comment
Hide comment
@dariocravero

dariocravero Mar 15, 2013

Contributor

Saw that too, I think it might be something with http_router's gem.

Contributor

dariocravero commented Mar 15, 2013

Saw that too, I think it might be something with http_router's gem.

@DAddYE

This comment has been minimized.

Show comment
Hide comment
@DAddYE

DAddYE Mar 15, 2013

Member

Yep very simple to fix don't worry ;)

Member

DAddYE commented Mar 15, 2013

Yep very simple to fix don't worry ;)

@WaYdotNET

This comment has been minimized.

Show comment
Hide comment
@WaYdotNET

WaYdotNET Mar 16, 2013

Contributor

close please :D

Contributor

WaYdotNET commented Mar 16, 2013

close please :D

@dariocravero

This comment has been minimized.

Show comment
Hide comment
@dariocravero

dariocravero Mar 16, 2013

Contributor

The original issue #921 is already fixed by the upgrade to http_router 0.11.0. What I don't think is, is the second example @Ortuna proposes, perhaps we should support that? @DAddYE ?

Contributor

dariocravero commented Mar 16, 2013

The original issue #921 is already fixed by the upgrade to http_router 0.11.0. What I don't think is, is the second example @Ortuna proposes, perhaps we should support that? @DAddYE ?

@nesquena

This comment has been minimized.

Show comment
Hide comment
@nesquena

nesquena Mar 16, 2013

Member

Is this something we can move to 0.11.1?

Member

nesquena commented Mar 16, 2013

Is this something we can move to 0.11.1?

@DAddYE DAddYE closed this in aafb761 Mar 17, 2013

@Ortuna Ortuna deleted the Ortuna:issue-921 branch Mar 20, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment