Skip to content
Permalink
main
Switch branches/tags

Name already in use

A tag already exists with the provided branch name. Many Git commands accept both tag and branch names, so creating this branch may cause unexpected behavior. Are you sure you want to create this branch?
Go to file
 
 
Cannot retrieve contributors at this time
api = "0.7"
[buildpack]
description = "A buildpack for installing the appropriate MRI version for an app"
homepage = "https://github.com/paketo-buildpacks/mri"
id = "paketo-buildpacks/mri"
keywords = ["ruby", "mri"]
name = "Paketo Buildpack for MRI"
sbom-formats = ["application/vnd.cyclonedx+json", "application/spdx+json", "application/vnd.syft+json"]
[[buildpack.licenses]]
type = "Apache-2.0"
uri = "https://github.com/paketo-buildpacks/mri/blob/main/LICENSE"
[metadata]
include-files = ["bin/run", "bin/build", "bin/detect", "buildpack.toml"]
pre-package = "./scripts/build.sh"
[metadata.default-versions]
ruby = "3.1.*"
[[metadata.dependencies]]
checksum = "sha256:20cb73d706b00d6b3fb2bdd0ccf3bce956d8f17c1886209b2ede56a6859bd8fc"
cpe = "cpe:2.3:a:ruby-lang:ruby:2.7.6:*:*:*:*:*:*:*"
id = "ruby"
licenses = ["BSD-2-Clause", "BSD-2-Clause-NetBSD", "BSD-3-Clause", "BSD-3-Clause-No-Nuclear-License-2014", "Bison-exception-2.2", "GPL-2.0-only", "GPL-2.0-or-later", "MIT", "MIT-0", "Ruby", "deprecated_GPL-2.0", "deprecated_GPL-2.0+"]
name = "Ruby"
purl = "pkg:generic/ruby@2.7.6?checksum=e7203b0cc09442ed2c08936d483f8ac140ec1c72e37bb5c401646b7866cb5d10&download_url=https://cache.ruby-lang.org/pub/ruby/2.7/ruby-2.7.6.tar.gz"
source = "https://cache.ruby-lang.org/pub/ruby/2.7/ruby-2.7.6.tar.gz"
source-checksum = "sha256:e7203b0cc09442ed2c08936d483f8ac140ec1c72e37bb5c401646b7866cb5d10"
stacks = ["io.buildpacks.stacks.bionic"]
uri = "https://artifacts.paketo.io/ruby/ruby_2.7.6_linux_x64_bionic_20cb73d7.tgz"
version = "2.7.6"
[[metadata.dependencies]]
checksum = "sha256:1e003b9b9753d81a076a8034bc70efbed6be6c2d25e5c62c9f50bacf5c166f25"
cpe = "cpe:2.3:a:ruby-lang:ruby:2.7.7:*:*:*:*:*:*:*"
id = "ruby"
licenses = ["BSD-2-Clause", "BSD-2-Clause-NetBSD", "BSD-3-Clause", "BSD-3-Clause-No-Nuclear-License-2014", "Bison-exception-2.2", "GPL-2.0-only", "GPL-2.0-or-later", "MIT", "MIT-0", "Ruby", "deprecated_GPL-2.0", "deprecated_GPL-2.0+"]
name = "Ruby"
purl = "pkg:generic/ruby@2.7.7?checksum=e10127db691d7ff36402cfe88f418c8d025a3f1eea92044b162dd72f0b8c7b90&download_url=https://cache.ruby-lang.org/pub/ruby/2.7/ruby-2.7.7.tar.gz"
source = "https://cache.ruby-lang.org/pub/ruby/2.7/ruby-2.7.7.tar.gz"
source-checksum = "sha256:e10127db691d7ff36402cfe88f418c8d025a3f1eea92044b162dd72f0b8c7b90"
stacks = ["io.buildpacks.stacks.bionic"]
uri = "https://artifacts.paketo.io/ruby/ruby_2.7.7_linux_x64_bionic_1e003b9b.tgz"
version = "2.7.7"
[[metadata.dependencies]]
checksum = "sha256:9198d20052e1f95e387736b8c5e036c451796851f4284671ecfef30a00ad187a"
cpe = "cpe:2.3:a:ruby-lang:ruby:3.0.4:*:*:*:*:*:*:*"
id = "ruby"
licenses = ["BSD-2-Clause", "BSD-2-Clause-NetBSD", "BSD-3-Clause", "BSD-3-Clause-No-Nuclear-License-2014", "Bison-exception-2.2", "FSFUL", "GPL-2.0-only", "GPL-2.0-or-later", "MIT", "MIT-0", "Ruby", "deprecated_GPL-2.0", "deprecated_GPL-2.0+"]
name = "Ruby"
purl = "pkg:generic/ruby@3.0.4?checksum=70b47c207af04bce9acea262308fb42893d3e244f39a4abc586920a1c723722b&download_url=https://cache.ruby-lang.org/pub/ruby/3.0/ruby-3.0.4.tar.gz"
source = "https://cache.ruby-lang.org/pub/ruby/3.0/ruby-3.0.4.tar.gz"
source-checksum = "sha256:70b47c207af04bce9acea262308fb42893d3e244f39a4abc586920a1c723722b"
stacks = ["io.buildpacks.stacks.bionic"]
uri = "https://artifacts.paketo.io/ruby/ruby_3.0.4_linux_x64_bionic_9198d200.tgz"
version = "3.0.4"
[[metadata.dependencies]]
checksum = "sha256:0de6dcaca9e8dd1efdcf07e400eab8a7a8f19b5b5bdf206cd8da16b59f93752c"
cpe = "cpe:2.3:a:ruby-lang:ruby:3.0.5:*:*:*:*:*:*:*"
id = "ruby"
licenses = ["BSD-2-Clause", "BSD-2-Clause-NetBSD", "BSD-3-Clause", "BSD-3-Clause-No-Nuclear-License-2014", "Bison-exception-2.2", "FSFUL", "GPL-2.0-only", "GPL-2.0-or-later", "MIT", "MIT-0", "Ruby", "deprecated_GPL-2.0", "deprecated_GPL-2.0+"]
name = "Ruby"
purl = "pkg:generic/ruby@3.0.5?checksum=9afc6380a027a4fe1ae1a3e2eccb6b497b9c5ac0631c12ca56f9b7beb4848776&download_url=https://cache.ruby-lang.org/pub/ruby/3.0/ruby-3.0.5.tar.gz"
source = "https://cache.ruby-lang.org/pub/ruby/3.0/ruby-3.0.5.tar.gz"
source-checksum = "sha256:9afc6380a027a4fe1ae1a3e2eccb6b497b9c5ac0631c12ca56f9b7beb4848776"
stacks = ["io.buildpacks.stacks.bionic"]
uri = "https://artifacts.paketo.io/ruby/ruby_3.0.5_linux_x64_bionic_0de6dcac.tgz"
version = "3.0.5"
[[metadata.dependencies]]
checksum = "sha256:2df36ef8f98a8e45b5dae3a2c8c4b55298f35c3de707d4e9a46a1e7ebf285877"
cpe = "cpe:2.3:a:ruby-lang:ruby:3.1.2:*:*:*:*:*:*:*"
id = "ruby"
licenses = ["BSD-2-Clause", "BSD-2-Clause-NetBSD", "BSD-3-Clause", "BSD-3-Clause-No-Nuclear-License-2014", "Bison-exception-2.2", "GPL-2.0-only", "GPL-2.0-or-later", "MIT", "MIT-0", "Ruby", "deprecated_GPL-2.0", "deprecated_GPL-2.0+"]
name = "Ruby"
purl = "pkg:generic/ruby@3.1.2?checksum=61843112389f02b735428b53bb64cf988ad9fb81858b8248e22e57336f24a83e&download_url=https://cache.ruby-lang.org/pub/ruby/3.1/ruby-3.1.2.tar.gz"
source = "https://cache.ruby-lang.org/pub/ruby/3.1/ruby-3.1.2.tar.gz"
source-checksum = "sha256:61843112389f02b735428b53bb64cf988ad9fb81858b8248e22e57336f24a83e"
stacks = ["io.buildpacks.stacks.jammy"]
uri = "https://artifacts.paketo.io/ruby/ruby_3.1.2_linux_x64_jammy_2df36ef8.tgz"
version = "3.1.2"
[[metadata.dependencies]]
checksum = "sha256:8ec033a97e7c6074ce188eee74b465fe16e5870f06445e6fd1b001f5b8c567af"
cpe = "cpe:2.3:a:ruby-lang:ruby:3.1.2:*:*:*:*:*:*:*"
id = "ruby"
licenses = ["BSD-2-Clause", "BSD-2-Clause-NetBSD", "BSD-3-Clause", "BSD-3-Clause-No-Nuclear-License-2014", "Bison-exception-2.2", "GPL-2.0-only", "GPL-2.0-or-later", "MIT", "MIT-0", "Ruby", "deprecated_GPL-2.0", "deprecated_GPL-2.0+"]
name = "Ruby"
purl = "pkg:generic/ruby@3.1.2?checksum=61843112389f02b735428b53bb64cf988ad9fb81858b8248e22e57336f24a83e&download_url=https://cache.ruby-lang.org/pub/ruby/3.1/ruby-3.1.2.tar.gz"
source = "https://cache.ruby-lang.org/pub/ruby/3.1/ruby-3.1.2.tar.gz"
source-checksum = "sha256:61843112389f02b735428b53bb64cf988ad9fb81858b8248e22e57336f24a83e"
stacks = ["io.buildpacks.stacks.bionic"]
uri = "https://artifacts.paketo.io/ruby/ruby_3.1.2_linux_x64_bionic_8ec033a9.tgz"
version = "3.1.2"
[[metadata.dependencies]]
checksum = "sha256:a9c084d0785d047f9b2394cccfb16acd326654c74f201abd6d220eef386addca"
cpe = "cpe:2.3:a:ruby-lang:ruby:3.1.3:*:*:*:*:*:*:*"
id = "ruby"
licenses = ["BSD-2-Clause", "BSD-2-Clause-NetBSD", "BSD-3-Clause", "BSD-3-Clause-No-Nuclear-License-2014", "Bison-exception-2.2", "GPL-2.0-only", "GPL-2.0-or-later", "MIT", "MIT-0", "Ruby", "deprecated_GPL-2.0", "deprecated_GPL-2.0+"]
name = "Ruby"
purl = "pkg:generic/ruby@3.1.3?checksum=5ea498a35f4cd15875200a52dde42b6eb179e1264e17d78732c3a57cd1c6ab9e&download_url=https://cache.ruby-lang.org/pub/ruby/3.1/ruby-3.1.3.tar.gz"
source = "https://cache.ruby-lang.org/pub/ruby/3.1/ruby-3.1.3.tar.gz"
source-checksum = "sha256:5ea498a35f4cd15875200a52dde42b6eb179e1264e17d78732c3a57cd1c6ab9e"
stacks = ["io.buildpacks.stacks.jammy"]
uri = "https://artifacts.paketo.io/ruby/ruby_3.1.3_linux_x64_jammy_a9c084d0.tgz"
version = "3.1.3"
[[metadata.dependencies]]
checksum = "sha256:04ebd8ebc799ad9cb877fc5ea5deced163b481bb113614cf59ec9a5b602cb055"
cpe = "cpe:2.3:a:ruby-lang:ruby:3.1.3:*:*:*:*:*:*:*"
id = "ruby"
licenses = ["BSD-2-Clause", "BSD-2-Clause-NetBSD", "BSD-3-Clause", "BSD-3-Clause-No-Nuclear-License-2014", "Bison-exception-2.2", "GPL-2.0-only", "GPL-2.0-or-later", "MIT", "MIT-0", "Ruby", "deprecated_GPL-2.0", "deprecated_GPL-2.0+"]
name = "Ruby"
purl = "pkg:generic/ruby@3.1.3?checksum=5ea498a35f4cd15875200a52dde42b6eb179e1264e17d78732c3a57cd1c6ab9e&download_url=https://cache.ruby-lang.org/pub/ruby/3.1/ruby-3.1.3.tar.gz"
source = "https://cache.ruby-lang.org/pub/ruby/3.1/ruby-3.1.3.tar.gz"
source-checksum = "sha256:5ea498a35f4cd15875200a52dde42b6eb179e1264e17d78732c3a57cd1c6ab9e"
stacks = ["io.buildpacks.stacks.bionic"]
uri = "https://artifacts.paketo.io/ruby/ruby_3.1.3_linux_x64_bionic_04ebd8eb.tgz"
version = "3.1.3"
[[metadata.dependency-constraints]]
constraint = "2.7.*"
id = "ruby"
patches = 2
[[metadata.dependency-constraints]]
constraint = "3.0.*"
id = "ruby"
patches = 2
[[metadata.dependency-constraints]]
constraint = "3.1.*"
id = "ruby"
patches = 2
[[stacks]]
id = "io.buildpacks.stacks.bionic"
[[stacks]]
id = "io.buildpacks.stacks.jammy"