Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

App container failed to start!! #22

Closed
O-mkar opened this Issue Sep 5, 2018 · 7 comments

Comments

Projects
None yet
5 participants
@O-mkar
Copy link

O-mkar commented Sep 5, 2018

Removing intermediate container 02364079ddba
---> ac1a82c2c0ed
Successfully built ac1a82c2c0ed
Successfully tagged dokku/wharf:latest
-----> Releasing wharf (dokku/wharf:latest)...
-----> Deploying wharf (dokku/wharf:latest)...
-----> Attempting to run scripts.dokku.predeploy from app.json (if defined)
-----> No Procfile found in app image
-----> DOKKU_SCALE file found (/home/dokku/wharf/DOKKU_SCALE)
=====> web=1
-----> Attempting pre-flight checks
For more efficient zero downtime deployments, create a file CHECKS.
See http://dokku.viewdocs.io/dokku/deployment/zero-downtime-deploys/ for examples
CHECKS file not found in container: Running simple container check...
-----> Waiting for 10 seconds ...
remote: App container failed to start!!
=====> wharf web container output:
=====> end wharf web container output

@matt-goingout

This comment has been minimized.

Copy link

matt-goingout commented Nov 20, 2018

same:
-----> Attempting pre-flight checks
For more efficient zero downtime deployments, create a file CHECKS.
See http://dokku.viewdocs.io/dokku/deployment/zero-downtime-deploys/ for examples
CHECKS file not found in container: Running simple container check...
-----> Waiting for 10 seconds ...
remote: App container failed to start!!
=====> wharf web container output:
=====> end wharf web container output

any clues?

@matt-goingout

This comment has been minimized.

Copy link

matt-goingout commented Nov 20, 2018

docker-compose up locally works fine, and browsing to localhost:8000 presents the login screen (but obviously doesn't do much), pushing the repo to a latest dokku results in above error (installed with sudo DOKKU_TAG=v0.12.13 bash bootstrap.sh)

@wesbos

This comment has been minimized.

Copy link
Contributor

wesbos commented Nov 28, 2018

same here :\

@wesbos

This comment has been minimized.

Copy link
Contributor

wesbos commented Dec 18, 2018

@palfrey any idea?

@palfrey

This comment has been minimized.

Copy link
Owner

palfrey commented Dec 18, 2018

Sorry, I've only just seen this. So, not sure yet. I'm running 0.11.3 locally, so that might work. The "No Procfile found in app image" is suspicious, as a) there is a Procfile and b) that would probably stop things from starting properly.

I'll try and spin up dokku fully locally again in a while, but I've got a fairly dodgy internet connection, so might be a bit.

@pedrofracassi

This comment has been minimized.

Copy link

pedrofracassi commented Dec 31, 2018

Any fixes for this? I'm getting the same error.

pedrofracassi added a commit to pedrofracassi/wharf that referenced this issue Dec 31, 2018

pedrofracassi added a commit to pedrofracassi/wharf that referenced this issue Dec 31, 2018

@palfrey palfrey referenced this issue Jan 27, 2019

Merged

Add Travis CI #34

@palfrey palfrey closed this in #34 Jan 27, 2019

@palfrey

This comment has been minimized.

Copy link
Owner

palfrey commented Jan 27, 2019

This should now be fixed by #34

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.