Recent Werkzeug required? #449

SimonSapin opened this Issue Mar 18, 2012 · 1 comment

2 participants


Running the test suite from git master in an old virtualenv with Werkzeug 0.6.2 installed, I got a failure went away when upgrading Werkzeug to 0.7 or the latest 0.8.3:

FAIL: test_test_app_proper_environ (flask.testsuite.basic.BasicFunctionalityTestCase)
Traceback (most recent call last):
  File "/home/simon/dev/projects/flask/flask/testsuite/", line 820, in test_test_app_proper_environ
    self.assert_equal(rv.status_code, 404)
  File "/home/simon/dev/projects/flask/flask/testsuite/", line 133, in assert_equal
    return self.assertEqual(x, y)
AssertionError: 200 != 404

The fix was hinted by the test having different code paths for Werkzeug 0.7 and 0.8. Flask’s requires Werkzeug>=0.6.1, should that be changed to 0.7?

@rduplain rduplain added a commit that referenced this issue Apr 24, 2012
@rduplain rduplain Require Werkzeug>=0.7, #449. b31f2d9

Good catch, thanks.

@rduplain rduplain closed this Apr 24, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment